Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Аналог ВПР - поиск по неск. столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Аналог ВПР - поиск по неск. столбцам (Формулы/Formulas)
Аналог ВПР - поиск по неск. столбцам
Krasnyi Дата: Вторник, 16.02.2016, 16:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Подскажите, как решить проблему с поиском значения в формуле =ИНДЕКС(Лист2!A1:A13;ПОИСКПОЗ(A4;Лист2!$B$1:$D$13;0);1)
К сообщению приложен файл: 0202578.xlsx(10Kb)


Тяжело жить на одну зарплату

Сообщение отредактировал Krasnyi - Вторник, 16.02.2016, 16:19
 
Ответить
СообщениеПодскажите, как решить проблему с поиском значения в формуле =ИНДЕКС(Лист2!A1:A13;ПОИСКПОЗ(A4;Лист2!$B$1:$D$13;0);1)

Автор - Krasnyi
Дата добавления - 16.02.2016 в 16:04
китин Дата: Вторник, 16.02.2016, 16:07 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
диапазончики в ПОИСКПОЗ не те
Код
=ИНДЕКС(Лист2!A1:A13;ПОИСКПОЗ(A4;Лист2!$C$1:$C$13;0);1)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениедиапазончики в ПОИСКПОЗ не те
Код
=ИНДЕКС(Лист2!A1:A13;ПОИСКПОЗ(A4;Лист2!$C$1:$C$13;0);1)

Автор - китин
Дата добавления - 16.02.2016 в 16:07
Krasnyi Дата: Вторник, 16.02.2016, 16:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Мне не по 1 столбцу надо искать, а сразу в 3 ((((
Есть ли какое-нибудь решение по поиску в нескольких столбцах?


Тяжело жить на одну зарплату
 
Ответить
СообщениеМне не по 1 столбцу надо искать, а сразу в 3 ((((
Есть ли какое-нибудь решение по поиску в нескольких столбцах?

Автор - Krasnyi
Дата добавления - 16.02.2016 в 16:09
Nic70y Дата: Вторник, 16.02.2016, 16:11 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
есть, но за название темы модераторы выпишут рецепт на пилюли.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеесть, но за название темы модераторы выпишут рецепт на пилюли.

Автор - Nic70y
Дата добавления - 16.02.2016 в 16:11
Krasnyi Дата: Вторник, 16.02.2016, 16:12 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Я согласен на люли, только проблемку бы решить....


Тяжело жить на одну зарплату
 
Ответить
СообщениеЯ согласен на люли, только проблемку бы решить....

Автор - Krasnyi
Дата добавления - 16.02.2016 в 16:12
Udik Дата: Вторник, 16.02.2016, 16:14 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1218
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
только проблемку бы решить.

Так эти злыдни и ответы уберут :D
[moder]Ага! Ой злыдни мы! Ну ваще прям.
Переименуйте тему во что-то типа "Аналог ВПР - поиск по неск. столбцам".


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Вторник, 16.02.2016, 16:44
 
Ответить
Сообщение
только проблемку бы решить.

Так эти злыдни и ответы уберут :D
[moder]Ага! Ой злыдни мы! Ну ваще прям.
Переименуйте тему во что-то типа "Аналог ВПР - поиск по неск. столбцам".

Автор - Udik
Дата добавления - 16.02.2016 в 16:14
_Boroda_ Дата: Вторник, 16.02.2016, 16:21 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(Лист2!B1:D13))))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Хотя нет, при неверном вводе не ругается
Вот так лучше
Код
=ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(Лист2!B1:D13);99)))

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(Лист2!B1:D13);99)));"Отсутствует")


Добавлено.
Николай, удели любую строку, меньшую 13, на ОДНОМ из листов - формула упадет. Очень часто такая ситуация возникает и народ в недоумении - вроде ж "ничего не делал", а формула не работает.
К сообщению приложен файл: 0202578_2.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(Лист2!B1:D13))))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Хотя нет, при неверном вводе не ругается
Вот так лучше
Код
=ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(Лист2!B1:D13);99)))

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(Лист2!B1:D13);99)));"Отсутствует")


Добавлено.
Николай, удели любую строку, меньшую 13, на ОДНОМ из листов - формула упадет. Очень часто такая ситуация возникает и народ в недоумении - вроде ж "ничего не делал", а формула не работает.

Автор - _Boroda_
Дата добавления - 16.02.2016 в 16:21
Nic70y Дата: Вторник, 16.02.2016, 16:22 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(Лист2!A1:A13;СУММПРОИЗВ((A4=Лист2!B1:D13)*СТРОКА(B1:D13)))
или для надежности массивная:
Код
=ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(B1:D13))))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист2!A1:A13;СУММПРОИЗВ((A4=Лист2!B1:D13)*СТРОКА(B1:D13)))
или для надежности массивная:
Код
=ИНДЕКС(Лист2!A1:A13;МИН(ЕСЛИ(A4=Лист2!B1:D13;СТРОКА(B1:D13))))

Автор - Nic70y
Дата добавления - 16.02.2016 в 16:22
Krasnyi Дата: Вторник, 16.02.2016, 16:51 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Не работает(((

Информация отображается неверно

И еще один момент, диапазоны лучше прописывать без привязки к конкретным местам (не B1:С12, а B:C), у меня прайсы з/ч, там от тысячи строк (и до 350000)
К сообщению приложен файл: 4947480.xlsx(11Kb)


Тяжело жить на одну зарплату
 
Ответить
СообщениеНе работает(((

Информация отображается неверно

И еще один момент, диапазоны лучше прописывать без привязки к конкретным местам (не B1:С12, а B:C), у меня прайсы з/ч, там от тысячи строк (и до 350000)

Автор - Krasnyi
Дата добавления - 16.02.2016 в 16:51
Nic70y Дата: Вторник, 16.02.2016, 16:59 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Не работает(((
F4
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$1:$A$35000;МИН(ЕСЛИ(A4=Лист2!$B$1:$D$35000;СТРОКА(Лист2!$B$1:$D$35000);35001)));"Отсутствует")
Николай, удели любую строку
жалко, но согласен.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Не работает(((
F4
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$1:$A$35000;МИН(ЕСЛИ(A4=Лист2!$B$1:$D$35000;СТРОКА(Лист2!$B$1:$D$35000);35001)));"Отсутствует")
Николай, удели любую строку
жалко, но согласен.

Автор - Nic70y
Дата добавления - 16.02.2016 в 16:59
Krasnyi Дата: Вторник, 16.02.2016, 17:27 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Ребята, большое спасибо за Ваше внимание, но ... сами посмотрите, что я делаю не так?
К сообщению приложен файл: 1672864.xlsx(97Kb)


Тяжело жить на одну зарплату
 
Ответить
СообщениеРебята, большое спасибо за Ваше внимание, но ... сами посмотрите, что я делаю не так?

Автор - Krasnyi
Дата добавления - 16.02.2016 в 17:27
_Boroda_ Дата: Вторник, 16.02.2016, 17:34 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
что я делаю не так?
Не читаете то, что Вам пишут -
Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер


Не
Не работает(((
, а работает соответственно Вашему примеру. Написали бы 2 значения для поиска, получили бы сразу ответ с долларами.
.
.
диапазоны лучше прописывать без привязки к конкретным местам
Кто Вам мешает? Вперед, флаг в руки, попутного ветра, возглавьте колонну ждущих, пока компьютер отвиснет.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
что я делаю не так?
Не читаете то, что Вам пишут -
Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер


Не
Не работает(((
, а работает соответственно Вашему примеру. Написали бы 2 значения для поиска, получили бы сразу ответ с долларами.
.
.
диапазоны лучше прописывать без привязки к конкретным местам
Кто Вам мешает? Вперед, флаг в руки, попутного ветра, возглавьте колонну ждущих, пока компьютер отвиснет.

Автор - _Boroda_
Дата добавления - 16.02.2016 в 17:34
Nic70y Дата: Вторник, 16.02.2016, 21:23 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Krasnyi, сегодня я добрый (получил бабло за проект)
давайте рассудим здраво.
что я делаю не так?

все не так.
У Вас всегда 3 столбца? или бывает больше?
от этого уже можно исходить с наименьшей зависаемостью.
Ответ - фигегознает не принимается.

[p.s.]Завтра, я протрезвею и стану как обычно злым[/p.s.]


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 16.02.2016, 21:27
 
Ответить
СообщениеKrasnyi, сегодня я добрый (получил бабло за проект)
давайте рассудим здраво.
что я делаю не так?

все не так.
У Вас всегда 3 столбца? или бывает больше?
от этого уже можно исходить с наименьшей зависаемостью.
Ответ - фигегознает не принимается.

[p.s.]Завтра, я протрезвею и стану как обычно злым[/p.s.]

Автор - Nic70y
Дата добавления - 16.02.2016 в 21:23
Мурад Дата: Среда, 17.02.2016, 16:17 | Сообщение № 14
Группа: Проверенные
Ранг: Обитатель
Сообщений: 412
Репутация: 17 ±
Замечаний: 0% ±

Excel 2007
Вот Вам немассивная формула, если вдруг заметите, что компьютер сдох при обработке массивной формулы :)
Код
=ЕСЛИ(ЕНД(ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!B:B;0)));ЕСЛИ(ЕНД(ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!C:C;0)));ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!D:D;0));ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!C:C;0)));ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!B:B;0)))


А если надо покороче, вот Вам покороче:
Код
=ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;СМЕЩ(Лист2!B:B;;ЕСЛИ(ЕНД(ПОИСКПОЗ(A4;Лист2!B:B;0));ЕСЛИ(ЕНД(ПОИСКПОЗ(A4;Лист2!C:C;0));2;1);0));0))


Сообщение отредактировал Мурад - Среда, 17.02.2016, 16:30
 
Ответить
СообщениеВот Вам немассивная формула, если вдруг заметите, что компьютер сдох при обработке массивной формулы :)
Код
=ЕСЛИ(ЕНД(ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!B:B;0)));ЕСЛИ(ЕНД(ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!C:C;0)));ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!D:D;0));ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!C:C;0)));ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;Лист2!B:B;0)))


А если надо покороче, вот Вам покороче:
Код
=ИНДЕКС(Лист2!A:A;ПОИСКПОЗ(A4;СМЕЩ(Лист2!B:B;;ЕСЛИ(ЕНД(ПОИСКПОЗ(A4;Лист2!B:B;0));ЕСЛИ(ЕНД(ПОИСКПОЗ(A4;Лист2!C:C;0));2;1);0));0))

Автор - Мурад
Дата добавления - 17.02.2016 в 16:17
jakim Дата: Среда, 17.02.2016, 17:30 | Сообщение № 15
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Попробуйте такую формулу:

Код
=IFERROR(AGGREGATE(15;6;ROW(A$1:A$2000)/(Лист2!$A$1:$G$2000=A1);1);"отсутствует")
К сообщению приложен файл: of_1672864-1.xlsx(97Kb)


Сообщение отредактировал jakim - Среда, 17.02.2016, 18:38
 
Ответить
Сообщение
Попробуйте такую формулу:

Код
=IFERROR(AGGREGATE(15;6;ROW(A$1:A$2000)/(Лист2!$A$1:$G$2000=A1);1);"отсутствует")

Автор - jakim
Дата добавления - 17.02.2016 в 17:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Аналог ВПР - поиск по неск. столбцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!