Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставление знач. и сложение соответствующих ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление знач. и сложение соответствующих ячеек (Формулы/Formulas)
Сопоставление знач. и сложение соответствующих ячеек
Rusel Дата: Четверг, 18.02.2016, 12:42 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 10 ±
Замечаний: 0% ±

Добрый день.
Встала задача для учета договоров по отдельному направлению компании. Придумана некая форма, но опыта для завершения не хватает. Меня не раз выручали на этом сайте, может и в этот раз что посоветуете. Задачи следующие:
1. Необходимо, чтобы в колонке "Отгружено, количество" суммировались соответствующие данному контрагенту значения с листа "Отгрузка". Например: на листе "отгрузка" в данном примере два раза введены значения для Фирма 1, значит нужно чтобы при обнаружении контрагента с названием Фирма 1 на листе "отгрузка" суммировались соответствующие значения в ячейке на листе "База данных". Причем нужно учесть, что на всех листах будут постоянно добавляться новые строки по мере прибавления новых клиентов и совершения операций по ним. Если же на листе "отгрузка" не встречается контрагент, который введен на листе "База данных", тогда нужно чтобы в соответствующей ячейке стояло 0. Аналогично нужно сделать и для столбца "Получено, деньги".
2. Статусы в красных колонках должны устанавливаться автоматически на основании расчетов: Если D-I=0 то "отгружено", Если D-I=D то "не отгружено", Если D-I >0 и <D то "отгружено частично". По оплате аналогично.
К сообщению приложен файл: 2741144.xlsx(18Kb)
 
Ответить
СообщениеДобрый день.
Встала задача для учета договоров по отдельному направлению компании. Придумана некая форма, но опыта для завершения не хватает. Меня не раз выручали на этом сайте, может и в этот раз что посоветуете. Задачи следующие:
1. Необходимо, чтобы в колонке "Отгружено, количество" суммировались соответствующие данному контрагенту значения с листа "Отгрузка". Например: на листе "отгрузка" в данном примере два раза введены значения для Фирма 1, значит нужно чтобы при обнаружении контрагента с названием Фирма 1 на листе "отгрузка" суммировались соответствующие значения в ячейке на листе "База данных". Причем нужно учесть, что на всех листах будут постоянно добавляться новые строки по мере прибавления новых клиентов и совершения операций по ним. Если же на листе "отгрузка" не встречается контрагент, который введен на листе "База данных", тогда нужно чтобы в соответствующей ячейке стояло 0. Аналогично нужно сделать и для столбца "Получено, деньги".
2. Статусы в красных колонках должны устанавливаться автоматически на основании расчетов: Если D-I=0 то "отгружено", Если D-I=D то "не отгружено", Если D-I >0 и <D то "отгружено частично". По оплате аналогично.

Автор - Rusel
Дата добавления - 18.02.2016 в 12:42
Manyasha Дата: Четверг, 18.02.2016, 13:02 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1590
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
Rusel, по первому пункту: так?
Код
=СУММЕСЛИ(Таблица2[Контрагент];[@Контрагент];Таблица2[Количество, шт])


по 2-му пункту: используйте ф-ию ЕСЛИ.
Если не подходит, создавайте новую тему, чтобы не нарушать п4 Правил.
К сообщению приложен файл: 2741144-1.xlsx(18Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеRusel, по первому пункту: так?
Код
=СУММЕСЛИ(Таблица2[Контрагент];[@Контрагент];Таблица2[Количество, шт])


по 2-му пункту: используйте ф-ию ЕСЛИ.
Если не подходит, создавайте новую тему, чтобы не нарушать п4 Правил.

Автор - Manyasha
Дата добавления - 18.02.2016 в 13:02
Rusel Дата: Четверг, 18.02.2016, 16:36 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 10 ±
Замечаний: 0% ±

Manyasha, Спасибо большое. С помощью ваших советов получилось то, что нужно. Использовал еще формулу СУММЕСЛИМН. Также вспомнил как применяется ЕСЛИ.
Прилагаю то, что получилось.
К сообщению приложен файл: 8595568.xlsx(17Kb)
 
Ответить
СообщениеManyasha, Спасибо большое. С помощью ваших советов получилось то, что нужно. Использовал еще формулу СУММЕСЛИМН. Также вспомнил как применяется ЕСЛИ.
Прилагаю то, что получилось.

Автор - Rusel
Дата добавления - 18.02.2016 в 16:36
_Boroda_ Дата: Четверг, 18.02.2016, 16:45 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Это не спортивно. Я про ЕСЛИ.
Раз уж Вы сами сделали и новую тему все равно создавать не будете, положу варианты здесь
Код
=ТЕКСТ(D2-I2;"[="&D2&"]Не от\гружено;[=0]От\гружено;От\гружено \ча\сти\чно")

Код
=ТЕКСТ((I2>0)+(I2=D2)-1;"От\гружено;Не от\гружено;От\гружено \ча\сти\чно")

Код
=ВЫБОР(1+(I2>0)+(I2=D2);"Не отгружено";"Отгружено частично";"Отгружено")

Код
=ЕСЛИ(I2=0;"не ";"")&"отгружено"&ЕСЛИ((D2>I2)*I2;" частично";"")

Код
=ЕСЛИ(I2;ЕСЛИ(D2-I2;"Отгружено частично";"Отгружено");"Не отгружено")

Код
=ПОДСТАВИТЬ(ЕСЛИ(I2;ЕСЛИ(D2-I2;"О1 частично";"О1");"Не о1");1;"тгружено")

И с форматом ячейки От\гружено;Не от\гружено;От\гружено \ча\сти\чно
Код
=(I2>0)+(I2=D2)-1
К сообщению приложен файл: 2741144_1.xlsx(19Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЭто не спортивно. Я про ЕСЛИ.
Раз уж Вы сами сделали и новую тему все равно создавать не будете, положу варианты здесь
Код
=ТЕКСТ(D2-I2;"[="&D2&"]Не от\гружено;[=0]От\гружено;От\гружено \ча\сти\чно")

Код
=ТЕКСТ((I2>0)+(I2=D2)-1;"От\гружено;Не от\гружено;От\гружено \ча\сти\чно")

Код
=ВЫБОР(1+(I2>0)+(I2=D2);"Не отгружено";"Отгружено частично";"Отгружено")

Код
=ЕСЛИ(I2=0;"не ";"")&"отгружено"&ЕСЛИ((D2>I2)*I2;" частично";"")

Код
=ЕСЛИ(I2;ЕСЛИ(D2-I2;"Отгружено частично";"Отгружено");"Не отгружено")

Код
=ПОДСТАВИТЬ(ЕСЛИ(I2;ЕСЛИ(D2-I2;"О1 частично";"О1");"Не о1");1;"тгружено")

И с форматом ячейки От\гружено;Не от\гружено;От\гружено \ча\сти\чно
Код
=(I2>0)+(I2=D2)-1

Автор - _Boroda_
Дата добавления - 18.02.2016 в 16:45
Rusel Дата: Четверг, 18.02.2016, 19:15 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 10 ±
Замечаний: 0% ±

_Boroda_, отличные варианты, и мне ни один не знаком. Обязательно воспользуюсь одним из них. Спасибо.
 
Ответить
Сообщение_Boroda_, отличные варианты, и мне ни один не знаком. Обязательно воспользуюсь одним из них. Спасибо.

Автор - Rusel
Дата добавления - 18.02.2016 в 19:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставление знач. и сложение соответствующих ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!