Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск по двум условиям снизу вверх - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск по двум условиям снизу вверх (Формулы/Formulas)
поиск по двум условиям снизу вверх
MBuh Дата: Воскресенье, 21.02.2016, 13:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Помогите рассчитать рабочее время шоферов, учитывая не только время в поездке, но и время между заказами
Поиск должен осуществляться по двум критериям
1) Дата поездки
2) Шофер
Искать нужно в таблице снизу вверх
Прикрепляю файл, Желтым цветом отмечен не не правильный результат, формула нашла первое значение сверху вниз , а нужно снизу вверх
Помогите пожалуйста, очень нужно
 
Ответить
СообщениеПомогите рассчитать рабочее время шоферов, учитывая не только время в поездке, но и время между заказами
Поиск должен осуществляться по двум критериям
1) Дата поездки
2) Шофер
Искать нужно в таблице снизу вверх
Прикрепляю файл, Желтым цветом отмечен не не правильный результат, формула нашла первое значение сверху вниз , а нужно снизу вверх
Помогите пожалуйста, очень нужно

Автор - MBuh
Дата добавления - 21.02.2016 в 13:39
gling Дата: Воскресенье, 21.02.2016, 13:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Прикрепляю файл
И где он?
 
Ответить
Сообщение
Прикрепляю файл
И где он?

Автор - gling
Дата добавления - 21.02.2016 в 13:52
MBuh Дата: Воскресенье, 21.02.2016, 14:10 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Файл
К сообщению приложен файл: 3635148.xlsx(17Kb)
 
Ответить
СообщениеФайл

Автор - MBuh
Дата добавления - 21.02.2016 в 14:10
MBuh Дата: Воскресенье, 21.02.2016, 14:35 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
gling, прикрепляю файл :)
К сообщению приложен файл: 9477118.xlsx(17Kb)
 
Ответить
Сообщениеgling, прикрепляю файл :)

Автор - MBuh
Дата добавления - 21.02.2016 в 14:35
gling Дата: Воскресенье, 21.02.2016, 15:07 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Что то я не понял, каким должен быть конечный результат. Нарисуйте руками что должно получиться. В файле переделал сводную угадал или нет, не знаю.
К сообщению приложен файл: 8605179.xlsx(19Kb)
 
Ответить
СообщениеЧто то я не понял, каким должен быть конечный результат. Нарисуйте руками что должно получиться. В файле переделал сводную угадал или нет, не знаю.

Автор - gling
Дата добавления - 21.02.2016 в 15:07
Pelena Дата: Воскресенье, 21.02.2016, 15:46 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9851
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Для G4 формула массива
Код
=МАКС(ЕСЛИ(($A$3:A3=A4)*($B$3:B3=B4);$E$3:E3))

или немассивная
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/($A$3:A3=A4)/($B$3:B3=B4);$E$3:E3);0)
К сообщению приложен файл: 8070063.xlsx(19Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДля G4 формула массива
Код
=МАКС(ЕСЛИ(($A$3:A3=A4)*($B$3:B3=B4);$E$3:E3))

или немассивная
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/($A$3:A3=A4)/($B$3:B3=B4);$E$3:E3);0)

Автор - Pelena
Дата добавления - 21.02.2016 в 15:46
MBuh Дата: Воскресенье, 21.02.2016, 15:54 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
gling,
Результат за 15,02,2016 по Берзыньшу, должен получиться следующий:
(Строка 8) 15.02.2016 Berzins AZ369 13:00 - 15:00
моя формула посчитала время ожидания 2:50 (что не верно), с 12:10 по 13:00 время ожидания заказа должно получиться 00:50
 
Ответить
Сообщениеgling,
Результат за 15,02,2016 по Берзыньшу, должен получиться следующий:
(Строка 8) 15.02.2016 Berzins AZ369 13:00 - 15:00
моя формула посчитала время ожидания 2:50 (что не верно), с 12:10 по 13:00 время ожидания заказа должно получиться 00:50

Автор - MBuh
Дата добавления - 21.02.2016 в 15:54
MBuh Дата: Воскресенье, 21.02.2016, 16:17 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Pelena,
Огромное вам спасибо! Вы мне очень помогли :)
 
Ответить
СообщениеPelena,
Огромное вам спасибо! Вы мне очень помогли :)

Автор - MBuh
Дата добавления - 21.02.2016 в 16:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск по двум условиям снизу вверх (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!