Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ограничение по максимальному числу через =ЕСЛИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ограничение по максимальному числу через =ЕСЛИ (Формулы/Formulas)
Ограничение по максимальному числу через =ЕСЛИ
MarinaT Дата: Пятница, 26.02.2016, 19:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2003; 2007
Здравствуйте. Возникла необходимость создать что-то типа лимитера (ограничителя) значений. В моём случае числа (в столбце В) не должны превышать 99. В моём примере все работает так, как мне надо, только если число в A2 больше 99. Не понимаю в чем ошибка - я в экселе все еще новичок :'(
Значения в столбце А могут меняться.
К сообщению приложен файл: 2488038.xlsx(10Kb)
 
Ответить
СообщениеЗдравствуйте. Возникла необходимость создать что-то типа лимитера (ограничителя) значений. В моём случае числа (в столбце В) не должны превышать 99. В моём примере все работает так, как мне надо, только если число в A2 больше 99. Не понимаю в чем ошибка - я в экселе все еще новичок :'(
Значения в столбце А могут меняться.

Автор - MarinaT
Дата добавления - 26.02.2016 в 19:16
buchlotnik Дата: Пятница, 26.02.2016, 19:41 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 645 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
а что должно получиться? покажите в файле
может в формуле массива дело - немассивка
Код
=ЕСЛИ(A2>99;A2+(99-$A$1); A2)
тогда массивка
Код
=ЕСЛИ($A$2:$A$31>99;$A$2:$A$31+(99-$A$1); $A$2:$A$31)
К сообщению приложен файл: 2488038-2-.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 26.02.2016, 19:48
 
Ответить
Сообщениеа что должно получиться? покажите в файле
может в формуле массива дело - немассивка
Код
=ЕСЛИ(A2>99;A2+(99-$A$1); A2)
тогда массивка
Код
=ЕСЛИ($A$2:$A$31>99;$A$2:$A$31+(99-$A$1); $A$2:$A$31)

Автор - buchlotnik
Дата добавления - 26.02.2016 в 19:41
gling Дата: Пятница, 26.02.2016, 19:45 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1392
Репутация: 341 ±
Замечаний: 0% ±

2010
Не понятно, а что нужно то? Что должно получиться в итоге? Покажите.
 
Ответить
СообщениеНе понятно, а что нужно то? Что должно получиться в итоге? Покажите.

Автор - gling
Дата добавления - 26.02.2016 в 19:45
MarinaT Дата: Пятница, 26.02.2016, 19:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2003; 2007
Вот новый пример, на котором показано, что должно получиться в столбце В, если в ячейке А2 вписать 77.
К сообщению приложен файл: 4394462.xlsx(10Kb)
 
Ответить
СообщениеВот новый пример, на котором показано, что должно получиться в столбце В, если в ячейке А2 вписать 77.

Автор - MarinaT
Дата добавления - 26.02.2016 в 19:50
buchlotnik Дата: Пятница, 26.02.2016, 19:55 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 645 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Так?
Код
=ЕСЛИ(D2:D31<=99;D2:D31+(99-$A$1); 99)
К сообщению приложен файл: 5283693.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеТак?
Код
=ЕСЛИ(D2:D31<=99;D2:D31+(99-$A$1); 99)

Автор - buchlotnik
Дата добавления - 26.02.2016 в 19:55
AlexM Дата: Пятница, 26.02.2016, 20:03 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3224
Репутация: 804 ±
Замечаний: 0% ±

А зачем ЕСЛИ()?
Код
=99+(D2-D$1)*(D2<=99)
или
Код
=МИН(99+D2-D$1;99)
или даже так
Код
=99+МИН(D2-D$1;)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 26.02.2016, 20:09
 
Ответить
СообщениеА зачем ЕСЛИ()?
Код
=99+(D2-D$1)*(D2<=99)
или
Код
=МИН(99+D2-D$1;99)
или даже так
Код
=99+МИН(D2-D$1;)

Автор - AlexM
Дата добавления - 26.02.2016 в 20:03
_Boroda_ Дата: Пятница, 26.02.2016, 20:10 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9783
Репутация: 4134 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=МИН(99;99-D$1+D2)

Но я все равно не понял - так ли нужно
Поскольку D1 не может быть меньше Di (там МАКС по D), то просто вот так
Код
=99-D$1+D2


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=МИН(99;99-D$1+D2)

Но я все равно не понял - так ли нужно
Поскольку D1 не может быть меньше Di (там МАКС по D), то просто вот так
Код
=99-D$1+D2

Автор - _Boroda_
Дата добавления - 26.02.2016 в 20:10
MarinaT Дата: Пятница, 26.02.2016, 20:23 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2003; 2007
Благодарю всех за старания, а _Boroda_ за правильный ответ :hands:


Сообщение отредактировал MarinaT - Пятница, 26.02.2016, 20:59
 
Ответить
СообщениеБлагодарю всех за старания, а _Boroda_ за правильный ответ :hands:

Автор - MarinaT
Дата добавления - 26.02.2016 в 20:23
MarinaT Дата: Пятница, 26.02.2016, 21:23 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2003; 2007
Прошу прощения - рановано я радовалась. Как я уже говорила - числа (в столбце В) не должны превышать 99, но они могут быть меньше 99. Вот ещё один пример, на сей раз максимально наглядный. Просто введите во вложенной таблице в ячейках А2 и А30 данные из приведённых в ней примеров, чтобы понять в чем моя проблема. Извините за то, что не могу объяснить нормальным человеческим языком. Мне стыдно, правда :'(
К сообщению приложен файл: 1689739.xlsx(13Kb)


Сообщение отредактировал MarinaT - Пятница, 26.02.2016, 21:24
 
Ответить
СообщениеПрошу прощения - рановано я радовалась. Как я уже говорила - числа (в столбце В) не должны превышать 99, но они могут быть меньше 99. Вот ещё один пример, на сей раз максимально наглядный. Просто введите во вложенной таблице в ячейках А2 и А30 данные из приведённых в ней примеров, чтобы понять в чем моя проблема. Извините за то, что не могу объяснить нормальным человеческим языком. Мне стыдно, правда :'(

Автор - MarinaT
Дата добавления - 26.02.2016 в 21:23
Udik Дата: Пятница, 26.02.2016, 21:39 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1291
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Может просто скажете, что должно выводиться в ячейку В2, если в ячейке А2=199, т.е. больше 99. И какие числа могут быть в А?
Не сразу с таблицей разобрался.
==
Всё равно не понимаю, что должно выводиться, если число больше 99 - тупо 99 или как-то хитро высчитываться число меньшее 99.


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Пятница, 26.02.2016, 21:46
 
Ответить
СообщениеМожет просто скажете, что должно выводиться в ячейку В2, если в ячейке А2=199, т.е. больше 99. И какие числа могут быть в А?
Не сразу с таблицей разобрался.
==
Всё равно не понимаю, что должно выводиться, если число больше 99 - тупо 99 или как-то хитро высчитываться число меньшее 99.

Автор - Udik
Дата добавления - 26.02.2016 в 21:39
AlexM Дата: Пятница, 26.02.2016, 22:15 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3224
Репутация: 804 ±
Замечаний: 0% ±

Код
=МИН(99-A$1;)+A2


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=МИН(99-A$1;)+A2

Автор - AlexM
Дата добавления - 26.02.2016 в 22:15
MarinaT Дата: Суббота, 27.02.2016, 08:41 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2003; 2007
AlexM, спасибо!
 
Ответить
СообщениеAlexM, спасибо!

Автор - MarinaT
Дата добавления - 27.02.2016 в 08:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ограничение по максимальному числу через =ЕСЛИ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!