Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск в диапазоне через ЛЕВСИМВ() - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск в диапазоне через ЛЕВСИМВ() (Формулы/Formulas)
поиск в диапазоне через ЛЕВСИМВ()
nikitan95 Дата: Понедельник, 29.02.2016, 21:21 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 229
Репутация: 0 ±
Замечаний: 0% ±

2016
Мира всем! У меня наверное опять весеннее обострение тугодумия). Надо в большом диапазоне найти определенный текст, начинающийся на 4-5 букв. Можно ли через ЛЕВСИМВ() это решить? У меня не получилось, увы. Пожалуйста, подскажите, что тут применить? Пример прилагается.
К сообщению приложен файл: 22.xlsx(10Kb)
 
Ответить
СообщениеМира всем! У меня наверное опять весеннее обострение тугодумия). Надо в большом диапазоне найти определенный текст, начинающийся на 4-5 букв. Можно ли через ЛЕВСИМВ() это решить? У меня не получилось, увы. Пожалуйста, подскажите, что тут применить? Пример прилагается.

Автор - nikitan95
Дата добавления - 29.02.2016 в 21:21
китин Дата: Понедельник, 29.02.2016, 21:23 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
может так ? массивная
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("бур";$A$1:$A$5));1;0)

[p.s.]я при помощи УФ и доп.ячейки ищу.при списке в 1500 строк оч.помогает :D
файл перевложил
К сообщению приложен файл: nikitan95.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 29.02.2016, 21:31
 
Ответить
Сообщениеможет так ? массивная
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("бур";$A$1:$A$5));1;0)

[p.s.]я при помощи УФ и доп.ячейки ищу.при списке в 1500 строк оч.помогает :D
файл перевложил

Автор - китин
Дата добавления - 29.02.2016 в 21:23
Serge_007 Дата: Понедельник, 29.02.2016, 21:32 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13145
Репутация: ±
Замечаний: ±

Excel 2010
Можно ли через ЛЕВСИМВ() это решить?
Можно:
Код
=СУММПРОИЗВ(--(ЛЕВБ(A1:A5;3)=A1:A5))


У меня не получилось, увы
Всё получилось :)
К сообщению приложен файл: 20160229_nikita.xlsx(12Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Можно ли через ЛЕВСИМВ() это решить?
Можно:
Код
=СУММПРОИЗВ(--(ЛЕВБ(A1:A5;3)=A1:A5))


У меня не получилось, увы
Всё получилось :)

Автор - Serge_007
Дата добавления - 29.02.2016 в 21:32
nikitan95 Дата: Понедельник, 29.02.2016, 21:44 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 229
Репутация: 0 ±
Замечаний: 0% ±

2016
Сергей, скорее всего ваша версия близка, но может сон мутит мою голову. С утра на свежую голову посмотрю внимательнее. До завтра! И спасибо)
 
Ответить
СообщениеСергей, скорее всего ваша версия близка, но может сон мутит мою голову. С утра на свежую голову посмотрю внимательнее. До завтра! И спасибо)

Автор - nikitan95
Дата добавления - 29.02.2016 в 21:44
nikitan95 Дата: Вторник, 01.03.2016, 12:03 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 229
Репутация: 0 ±
Замечаний: 0% ±

2016
Увы, оба варианта не дали желаемого результата. Значит, скорее всего постановка вопроса была туманной. В рабочем варианте файла, надо суммировать итоги определенного счета. Файл подправил. Кстати, подкопавшись в ЛЕВБ(), нашел более интересную – НАЙТИБ(). Не вариант что этот подойдет, но почти равнозначно ЛЕВБ() в данном контексте. По мнению любителя, конечно...
К сообщению приложен файл: 001.xlsx(18Kb)
 
Ответить
СообщениеУвы, оба варианта не дали желаемого результата. Значит, скорее всего постановка вопроса была туманной. В рабочем варианте файла, надо суммировать итоги определенного счета. Файл подправил. Кстати, подкопавшись в ЛЕВБ(), нашел более интересную – НАЙТИБ(). Не вариант что этот подойдет, но почти равнозначно ЛЕВБ() в данном контексте. По мнению любителя, конечно...

Автор - nikitan95
Дата добавления - 01.03.2016 в 12:03
_Boroda_ Дата: Вторник, 01.03.2016, 12:09 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11349
Репутация: 4679 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
подкопавшись в ЛЕВБ(), нашел более интересную – НАЙТИБ()

[offtop]НАЙТИБ.. ЛЕВБ.. бегомБ..
:D


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
подкопавшись в ЛЕВБ(), нашел более интересную – НАЙТИБ()

[offtop]НАЙТИБ.. ЛЕВБ.. бегомБ..
:D

Автор - _Boroda_
Дата добавления - 01.03.2016 в 12:09
nikitan95 Дата: Вторник, 01.03.2016, 12:31 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 229
Репутация: 0 ±
Замечаний: 0% ±

2016
_Boroda_, Да, потом КругомБ и повторно ЦиклБ() :(
 
Ответить
Сообщение_Boroda_, Да, потом КругомБ и повторно ЦиклБ() :(

Автор - nikitan95
Дата добавления - 01.03.2016 в 12:31
китин Дата: Вторник, 01.03.2016, 12:55 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4331
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Ну не знаю, как понял из файла про идеал :D
Код
=СУММПРОИЗВ($D$9:$BS$9*($D$3:$BS$3=B$12)*(ЛЕВБ($D$1:$BS$1;ДЛСТР($A13))=$A13))
К сообщению приложен файл: nikitan95_2.xlsx(18Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеНу не знаю, как понял из файла про идеал :D
Код
=СУММПРОИЗВ($D$9:$BS$9*($D$3:$BS$3=B$12)*(ЛЕВБ($D$1:$BS$1;ДЛСТР($A13))=$A13))

Автор - китин
Дата добавления - 01.03.2016 в 12:55
nikitan95 Дата: Вторник, 01.03.2016, 13:10 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 229
Репутация: 0 ±
Замечаний: 0% ±

2016
китин, спасибо!
На самом деле то что надо. Пашет))
 
Ответить
Сообщениекитин, спасибо!
На самом деле то что надо. Пашет))

Автор - nikitan95
Дата добавления - 01.03.2016 в 13:10
_Boroda_ Дата: Вторник, 01.03.2016, 13:31 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11349
Репутация: 4679 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ($D$9:$BS$9*($D$3:$BS$3=B$12)*ЕЧИСЛО(1/(ПОИСК($A13;$D$1:$BS$1)=1)))

А вообще-то, дебет-кредит там не нужен. Достаточно снять доллары на диапазоне сумм. Вот так можно
Код
=СУММПРОИЗВ(D$9:BS$9*ЕЧИСЛО(1/(ПОИСК($A13;$D$2:$BS$2)=1)))

Ну или Игореву формулу
Код
=СУММПРОИЗВ(D$9:BS$9*(ЛЕВБ($D$2:$BS$2;ДЛСТР($A13))=$A13))
К сообщению приложен файл: 001_1.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ($D$9:$BS$9*($D$3:$BS$3=B$12)*ЕЧИСЛО(1/(ПОИСК($A13;$D$1:$BS$1)=1)))

А вообще-то, дебет-кредит там не нужен. Достаточно снять доллары на диапазоне сумм. Вот так можно
Код
=СУММПРОИЗВ(D$9:BS$9*ЕЧИСЛО(1/(ПОИСК($A13;$D$2:$BS$2)=1)))

Ну или Игореву формулу
Код
=СУММПРОИЗВ(D$9:BS$9*(ЛЕВБ($D$2:$BS$2;ДЛСТР($A13))=$A13))

Автор - _Boroda_
Дата добавления - 01.03.2016 в 13:31
antycapral Дата: Вторник, 01.03.2016, 14:33 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 61
Репутация: 5 ±
Замечаний: 0% ±

Excel 2016
У меня вот так вышло:

Код
=СУММЕСЛИМН($D$9:$BS$9;$D$1:$BS$1;A28&"*";$D$3:$BS$3;$B$27)
К сообщению приложен файл: _001.xlsx(18Kb)


Сообщение отредактировал antycapral - Вторник, 01.03.2016, 14:33
 
Ответить
СообщениеУ меня вот так вышло:

Код
=СУММЕСЛИМН($D$9:$BS$9;$D$1:$BS$1;A28&"*";$D$3:$BS$3;$B$27)

Автор - antycapral
Дата добавления - 01.03.2016 в 14:33
nikitan95 Дата: Вторник, 01.03.2016, 14:41 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 229
Репутация: 0 ±
Замечаний: 0% ±

2016
Всегда радуешься когда видишь, сколько имеется методов решения. И огорчаешься тем самим, что не знал)) Спасибо всем! Весенних всем пробуждений!
 
Ответить
СообщениеВсегда радуешься когда видишь, сколько имеется методов решения. И огорчаешься тем самим, что не знал)) Спасибо всем! Весенних всем пробуждений!

Автор - nikitan95
Дата добавления - 01.03.2016 в 14:41
_Boroda_ Дата: Вторник, 01.03.2016, 14:44 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11349
Репутация: 4679 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня вот так вышло:

Действительно, так еще лучше.
Если все собрать вместе, то в итоге вот так можно
Код
=СУММЕСЛИМН(D$9:BS$9;$D$2:$BS$2;$A28&"*")
К сообщению приложен файл: _001_3.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
У меня вот так вышло:

Действительно, так еще лучше.
Если все собрать вместе, то в итоге вот так можно
Код
=СУММЕСЛИМН(D$9:BS$9;$D$2:$BS$2;$A28&"*")

Автор - _Boroda_
Дата добавления - 01.03.2016 в 14:44
antycapral Дата: Вторник, 01.03.2016, 14:53 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 61
Репутация: 5 ±
Замечаний: 0% ±

Excel 2016
На больших обьемах СУММЕСЛИМН намного быстрее СУММПРОИЗВ, однажды споткнулся об это.
[moder]Конечно.


Сообщение отредактировал _Boroda_ - Вторник, 01.03.2016, 14:55
 
Ответить
СообщениеНа больших обьемах СУММЕСЛИМН намного быстрее СУММПРОИЗВ, однажды споткнулся об это.
[moder]Конечно.

Автор - antycapral
Дата добавления - 01.03.2016 в 14:53
nikitan95 Дата: Вторник, 01.03.2016, 15:14 | Сообщение № 15
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 229
Репутация: 0 ±
Замечаний: 0% ±

2016
Почти постоянно пользуюсь СУММЕСЛИ, а вот СУММЕСЛИМН мне никак не сдался. Продолжаем учиться...
 
Ответить
СообщениеПочти постоянно пользуюсь СУММЕСЛИ, а вот СУММЕСЛИМН мне никак не сдался. Продолжаем учиться...

Автор - nikitan95
Дата добавления - 01.03.2016 в 15:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск в диапазоне через ЛЕВСИМВ() (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!