Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование значений по нескольким критериями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений по нескольким критериями (Формулы/Formulas)
Суммирование значений по нескольким критериями
stElen Дата: Воскресенье, 13.03.2016, 16:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Помогите пож-та составить формулы в желтой таблице прикрепленного файла. В разных пунктах принимаю товары с одинаковым наименованием каждый день нужно в желтых таблицах суммы этих товаров по разным пунктам понедельно для составления другой таблицы. Заранее спасибо за помощь.
К сообщению приложен файл: 1122.xlsx(12Kb)


Сообщение отредактировал stElen - Понедельник, 14.03.2016, 09:22
 
Ответить
СообщениеПомогите пож-та составить формулы в желтой таблице прикрепленного файла. В разных пунктах принимаю товары с одинаковым наименованием каждый день нужно в желтых таблицах суммы этих товаров по разным пунктам понедельно для составления другой таблицы. Заранее спасибо за помощь.

Автор - stElen
Дата добавления - 13.03.2016 в 16:59
StoTisteg Дата: Воскресенье, 13.03.2016, 17:19 | Сообщение № 2
Группа: Авторы
Ранг: Ветеран
Сообщений: 541
Репутация: 45 ±
Замечаний: 0% ±

Excel 2010
Где-то примерно так?
К сообщению приложен файл: milk.xlsx(13Kb)


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
СообщениеГде-то примерно так?

Автор - StoTisteg
Дата добавления - 13.03.2016 в 17:19
stElen Дата: Воскресенье, 13.03.2016, 17:27 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
StoTisteg, так примерно не получается, дело в том что нужно по недельно, номер недели указан над датой. В месяце их 3-4 потому внизу 2 желтые таблицы и наименований и пунктов более 10 (товаров до 10 ) и в каждый делать диапазон затратно по времени и каждый месяц составляя таблицы нужно менять диапазоны суммирования снова. Я думала суммы произведений или сумеслин но у меня выдает ошибку, да и как правильно задать в условие номер недели не пойму ни как


Сообщение отредактировал stElen - Воскресенье, 13.03.2016, 17:37
 
Ответить
СообщениеStoTisteg, так примерно не получается, дело в том что нужно по недельно, номер недели указан над датой. В месяце их 3-4 потому внизу 2 желтые таблицы и наименований и пунктов более 10 (товаров до 10 ) и в каждый делать диапазон затратно по времени и каждый месяц составляя таблицы нужно менять диапазоны суммирования снова. Я думала суммы произведений или сумеслин но у меня выдает ошибку, да и как правильно задать в условие номер недели не пойму ни как

Автор - stElen
Дата добавления - 13.03.2016 в 17:27
StoTisteg Дата: Воскресенье, 13.03.2016, 17:40 | Сообщение № 4
Группа: Авторы
Ранг: Ветеран
Сообщений: 541
Репутация: 45 ±
Замечаний: 0% ±

Excel 2010
То есть каждую неделю нужно генерировать новую жёлтую таблицу? Тогда формулами я пас.
[offtop]
А вообще всё это молоко, пшеница, рожь... Что-то мне всё это напоминает. Признавайтесь
для составления другого отчета

не П1-СХ часом? ;)


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
СообщениеТо есть каждую неделю нужно генерировать новую жёлтую таблицу? Тогда формулами я пас.
[offtop]
А вообще всё это молоко, пшеница, рожь... Что-то мне всё это напоминает. Признавайтесь
для составления другого отчета

не П1-СХ часом? ;)

Автор - StoTisteg
Дата добавления - 13.03.2016 в 17:40
stElen Дата: Воскресенье, 13.03.2016, 17:56 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
П1-СХ

печалька. Это просто пример.


Сообщение отредактировал stElen - Воскресенье, 13.03.2016, 18:16
 
Ответить
Сообщение
П1-СХ

печалька. Это просто пример.

Автор - stElen
Дата добавления - 13.03.2016 в 17:56
Nic70y Дата: Понедельник, 14.03.2016, 08:23 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3658
Репутация: 752 ±
Замечаний: 0% ±

Excel 2013
просто пример
молоко от сливок как-то можно отделить?
т.е. что-бы наименования во всех таблицах совпадали?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
просто пример
молоко от сливок как-то можно отделить?
т.е. что-бы наименования во всех таблицах совпадали?

Автор - Nic70y
Дата добавления - 14.03.2016 в 08:23
stElen Дата: Понедельник, 14.03.2016, 09:18 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Nic70y, да конечно,нужно было вообще их брать
сейчас подправлю таблицу
 
Ответить
СообщениеNic70y, да конечно,нужно было вообще их брать
сейчас подправлю таблицу

Автор - stElen
Дата добавления - 14.03.2016 в 09:18
Nic70y Дата: Понедельник, 14.03.2016, 16:03 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3658
Репутация: 752 ±
Замечаний: 0% ±

Excel 2013
stElen, я уже тогда (до моего последнего сообщения) начал писать формулу.
фиг с ним молоком, в таблицах разное кол-во строк и молоко не всегда присутствует в новой таблице
был бы какой-то стандарт - было бы проще (хотя я не сказал, что не решаемо)
например каждая из таблиц содержит 1000 строк, они идут строго по-порядку и т.п.,
если нет этих сведений - формула будет в 15 этажей...


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеstElen, я уже тогда (до моего последнего сообщения) начал писать формулу.
фиг с ним молоком, в таблицах разное кол-во строк и молоко не всегда присутствует в новой таблице
был бы какой-то стандарт - было бы проще (хотя я не сказал, что не решаемо)
например каждая из таблиц содержит 1000 строк, они идут строго по-порядку и т.п.,
если нет этих сведений - формула будет в 15 этажей...

Автор - Nic70y
Дата добавления - 14.03.2016 в 16:03
Nic70y Дата: Вторник, 15.03.2016, 08:35 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3658
Репутация: 752 ±
Замечаний: 0% ±

Excel 2013
Заменил в итоговых таблицах №недели числами.
Код
=СУММПРОИЗВ((ИНДЕКС($A$1:$A33;ПОИСКПОЗ(ВПР("我我";B$1:B33;1);$A$1:$A33;)+1):ИНДЕКС($A$1:$A33;ПОИСКПОЗ(ВПР(ИНДЕКС(A$1:A33;ПОИСКПОЗ(9^9;$A$1:$A33)+1);A$1:A33;1;);$A$1:$A33;)-1)=$A34)*(ИНДЕКС($B$1:$I33;ПОИСКПОЗ(ВПР("我我";B$1:B33;1);$A$1:$A33;)+1;):ИНДЕКС($B$1:$I33;ПОИСКПОЗ(ВПР(ИНДЕКС(A$1:A33;ПОИСКПОЗ(9^9;$A$1:$A33)+1);A$1:A33;1;);$A$1:$A33;)-1;))*($B$2:$I$2=ВПР(9^9;$A$1:$A33;1;1)))
К сообщению приложен файл: 1129.xlsx(13Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеЗаменил в итоговых таблицах №недели числами.
Код
=СУММПРОИЗВ((ИНДЕКС($A$1:$A33;ПОИСКПОЗ(ВПР("我我";B$1:B33;1);$A$1:$A33;)+1):ИНДЕКС($A$1:$A33;ПОИСКПОЗ(ВПР(ИНДЕКС(A$1:A33;ПОИСКПОЗ(9^9;$A$1:$A33)+1);A$1:A33;1;);$A$1:$A33;)-1)=$A34)*(ИНДЕКС($B$1:$I33;ПОИСКПОЗ(ВПР("我我";B$1:B33;1);$A$1:$A33;)+1;):ИНДЕКС($B$1:$I33;ПОИСКПОЗ(ВПР(ИНДЕКС(A$1:A33;ПОИСКПОЗ(9^9;$A$1:$A33)+1);A$1:A33;1;);$A$1:$A33;)-1;))*($B$2:$I$2=ВПР(9^9;$A$1:$A33;1;1)))

Автор - Nic70y
Дата добавления - 15.03.2016 в 08:35
_Boroda_ Дата: Вторник, 15.03.2016, 09:50 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9803
Репутация: 4139 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Заменил в итоговых таблицах №недели числами.
Я тоже. И поставил формат
Код
0" неделя"
Еще убрал пробелы в С1 и С9. В итоге получилось вот так -
Код
=СУММПРОИЗВ($B$1:$I$32*(ПРОСМОТР(СТРОКА($1:$32);СТРОКА($1:$32)/ЕЧИСЛО(-ПРАВБ($A$1:$A$32));$A$1:$A$32)=B$33)*($B$2:$I$2=МАКС($A$32:$A34))*($A$1:$A$32=$A34))
К сообщению приложен файл: 1122_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Заменил в итоговых таблицах №недели числами.
Я тоже. И поставил формат
Код
0" неделя"
Еще убрал пробелы в С1 и С9. В итоге получилось вот так -
Код
=СУММПРОИЗВ($B$1:$I$32*(ПРОСМОТР(СТРОКА($1:$32);СТРОКА($1:$32)/ЕЧИСЛО(-ПРАВБ($A$1:$A$32));$A$1:$A$32)=B$33)*($B$2:$I$2=МАКС($A$32:$A34))*($A$1:$A$32=$A34))

Автор - _Boroda_
Дата добавления - 15.03.2016 в 09:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование значений по нескольким критериями (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!