Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечь данные из ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь данные из ячейки (Формулы/Formulas)
Извлечь данные из ячейки
ryazanov_74 Дата: Понедельник, 14.03.2016, 09:35 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Есть данные я ячейках (E29, F29, G29), подскажите пожалуйста, как из них вытащить нужную информацию (количества каждого артикула, выделил красным шрифтом) в таблицу A1:D26, желательно чтобы протягивалась формула.
К сообщению приложен файл: 7527294.xlsx(10Kb)
 
Ответить
СообщениеДобрый день!
Есть данные я ячейках (E29, F29, G29), подскажите пожалуйста, как из них вытащить нужную информацию (количества каждого артикула, выделил красным шрифтом) в таблицу A1:D26, желательно чтобы протягивалась формула.

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 09:35
Pelena Дата: Понедельник, 14.03.2016, 09:55 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Так можно
Код
=ЕСЛИОШИБКА(ПСТР(E$29;ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)+8;ПОИСК("(?)";E$29;ПОИСК($A2;E$29)-20)-ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)-9);"")

А если количество всегда однозначное число (как в примере), то существенно короче
Код
=ЕСЛИОШИБКА(ПСТР(E$29;ПОИСК("(?)";E$29;ПОИСК($A2;E$29)-20)+1;1);"")
К сообщению приложен файл: 7240045.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Так можно
Код
=ЕСЛИОШИБКА(ПСТР(E$29;ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)+8;ПОИСК("(?)";E$29;ПОИСК($A2;E$29)-20)-ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)-9);"")

А если количество всегда однозначное число (как в примере), то существенно короче
Код
=ЕСЛИОШИБКА(ПСТР(E$29;ПОИСК("(?)";E$29;ПОИСК($A2;E$29)-20)+1;1);"")

Автор - Pelena
Дата добавления - 14.03.2016 в 09:55
ryazanov_74 Дата: Понедельник, 14.03.2016, 09:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большое!!!
 
Ответить
СообщениеСпасибо большое!!!

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 09:58
vikttur Дата: Понедельник, 14.03.2016, 10:43 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Код
=ЛЕВБ(ПСТР(E$29;ПОИСК("(?) "&$A2;E$29&"(?) "&$A2)+1;1))
 
Ответить
Сообщение
Код
=ЛЕВБ(ПСТР(E$29;ПОИСК("(?) "&$A2;E$29&"(?) "&$A2)+1;1))

Автор - vikttur
Дата добавления - 14.03.2016 в 10:43
ryazanov_74 Дата: Понедельник, 14.03.2016, 11:04 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Можно ещё вопрос, почему полученные данные не суммируются?
К сообщению приложен файл: 7229197.xlsx(13Kb)
 
Ответить
СообщениеМожно ещё вопрос, почему полученные данные не суммируются?

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 11:04
buchlotnik Дата: Понедельник, 14.03.2016, 11:11 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
потому что формула возвращает текст, попробуйте так:
Код
=ЕСЛИОШИБКА(--ПСТР(D$42;ПОИСК("Кол-во";D$42;ПОИСК($B3;D$42)-20)+8;ПОИСК("(?)";D$42;ПОИСК($B3;D$42)-20)-ПОИСК("Кол-во";D$42;ПОИСК($B3;D$42)-20)-9);"")
К сообщению приложен файл: 7229197-1-.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениепотому что формула возвращает текст, попробуйте так:
Код
=ЕСЛИОШИБКА(--ПСТР(D$42;ПОИСК("Кол-во";D$42;ПОИСК($B3;D$42)-20)+8;ПОИСК("(?)";D$42;ПОИСК($B3;D$42)-20)-ПОИСК("Кол-во";D$42;ПОИСК($B3;D$42)-20)-9);"")

Автор - buchlotnik
Дата добавления - 14.03.2016 в 11:11
vikttur Дата: Понедельник, 14.03.2016, 11:16 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Код
=ЕСЛИОШИБКА(--ЛЕВБ(ПСТР(D$42;ПОИСК("(?) "&$B3;D$42&"(?) "&$B3)+1;1));"")

Код
=--ЛЕВБ(ПСТР(D$42&"000";ПОИСК($B3;D$42&"000"&$B3)-3;1))


Сообщение отредактировал vikttur - Понедельник, 14.03.2016, 11:22
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(--ЛЕВБ(ПСТР(D$42;ПОИСК("(?) "&$B3;D$42&"(?) "&$B3)+1;1));"")

Код
=--ЛЕВБ(ПСТР(D$42&"000";ПОИСК($B3;D$42&"000"&$B3)-3;1))

Автор - vikttur
Дата добавления - 14.03.2016 в 11:16
ryazanov_74 Дата: Понедельник, 14.03.2016, 11:27 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Работает, спасибо!
 
Ответить
СообщениеРаботает, спасибо!

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 11:27
ryazanov_74 Дата: Понедельник, 14.03.2016, 11:53 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А подскажите ещё пожалуйста, как количество копий вытащить в первую строку?
Оно в тексте указано: "Лист №: 2 Количество копий: 3"
И перед количеством изделий в скобках: "No 30 1220x3588 Кол-во: 1 (3) Н-5"
К сообщению приложен файл: 1727893.xlsx(14Kb)
 
Ответить
СообщениеА подскажите ещё пожалуйста, как количество копий вытащить в первую строку?
Оно в тексте указано: "Лист №: 2 Количество копий: 3"
И перед количеством изделий в скобках: "No 30 1220x3588 Кол-во: 1 (3) Н-5"

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 11:53
vikttur Дата: Понедельник, 14.03.2016, 12:10 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Правила читали? Наверное, прогнорировали...
 
Ответить
СообщениеПравила читали? Наверное, прогнорировали...

Автор - vikttur
Дата добавления - 14.03.2016 в 12:10
ryazanov_74 Дата: Понедельник, 14.03.2016, 12:13 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Одна тема - один вопрос?
[moder]Да. Один вопрос - одна тема.
Для другого вопроса - создавайте другую тему.[/moder]


Сообщение отредактировал SLAVICK - Понедельник, 14.03.2016, 12:55
 
Ответить
СообщениеОдна тема - один вопрос?
[moder]Да. Один вопрос - одна тема.
Для другого вопроса - создавайте другую тему.[/moder]

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 12:13
ryazanov_74 Дата: Понедельник, 14.03.2016, 16:00 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Можно в продолжение темы вопрос?
Когда попадаются двузначные значения, формулы не считают...
 
Ответить
СообщениеМожно в продолжение темы вопрос?
Когда попадаются двузначные значения, формулы не считают...

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 16:00
Pelena Дата: Понедельник, 14.03.2016, 16:14 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Моя первая формула должна считать. Показывайте в файле


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМоя первая формула должна считать. Показывайте в файле

Автор - Pelena
Дата добавления - 14.03.2016 в 16:14
ryazanov_74 Дата: Понедельник, 14.03.2016, 16:16 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В приложении
К сообщению приложен файл: 1127098.xlsx(11Kb)
 
Ответить
СообщениеВ приложении

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 16:16
Pelena Дата: Понедельник, 14.03.2016, 16:26 | Сообщение № 15
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Замените в формуле знак ? на *


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗамените в формуле знак ? на *

Автор - Pelena
Дата добавления - 14.03.2016 в 16:26
ryazanov_74 Дата: Понедельник, 14.03.2016, 16:40 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Заменил. Количество показывает, но я этими данными затем не могу пользоваться..
Например, суммирую по строке - результат ноль..
К сообщению приложен файл: 5699545.xlsx(12Kb)
 
Ответить
СообщениеЗаменил. Количество показывает, но я этими данными затем не могу пользоваться..
Например, суммирую по строке - результат ноль..

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 16:40
SLAVICK Дата: Понедельник, 14.03.2016, 16:43 | Сообщение № 17
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Добавьте --
Код
=ЕСЛИОШИБКА(--ПСТР(E$29;ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)+8;ПОИСК("(*)";E$29;ПОИСК($A2;E$29)-20)-ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)-9);"")
К сообщению приложен файл: 1301492.xlsx(12Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеДобавьте --
Код
=ЕСЛИОШИБКА(--ПСТР(E$29;ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)+8;ПОИСК("(*)";E$29;ПОИСК($A2;E$29)-20)-ПОИСК("Кол-во";E$29;ПОИСК($A2;E$29)-20)-9);"")

Автор - SLAVICK
Дата добавления - 14.03.2016 в 16:43
ryazanov_74 Дата: Понедельник, 14.03.2016, 16:55 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - ryazanov_74
Дата добавления - 14.03.2016 в 16:55
МВТ Дата: Понедельник, 14.03.2016, 19:43 | Сообщение № 19
Группа: Проверенные
Ранг: Обитатель
Сообщений: 476
Репутация: 136 ±
Замечаний: 0% ±

Excel 2007
Можно еще количество можно брать UDFкой
[vba]
Код
Function КоличествоПоАртикулу(Ячейка As String, Артикул As String)
    Dim Obj As Object
    With CreateObject("VBScript.RegExp")
        .ignorecase = True
        .Global = True
        .Pattern = "Кол-во: +(\d+).+" & Артикул
        Set Obj = .Execute(Ячейка)
        If Obj.Count > 0 Then КоличествоПоАртикулу = Val(Obj(0).submatches(0))
    End With
End Function
[/vba]
 
Ответить
СообщениеМожно еще количество можно брать UDFкой
[vba]
Код
Function КоличествоПоАртикулу(Ячейка As String, Артикул As String)
    Dim Obj As Object
    With CreateObject("VBScript.RegExp")
        .ignorecase = True
        .Global = True
        .Pattern = "Кол-во: +(\d+).+" & Артикул
        Set Obj = .Execute(Ячейка)
        If Obj.Count > 0 Then КоличествоПоАртикулу = Val(Obj(0).submatches(0))
    End With
End Function
[/vba]

Автор - МВТ
Дата добавления - 14.03.2016 в 19:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь данные из ячейки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!