Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет слов в диапазоне, в т.ч. одинаковых в одной ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет слов в диапазоне, в т.ч. одинаковых в одной ячейке (Формулы/Formulas)
Подсчет слов в диапазоне, в т.ч. одинаковых в одной ячейке
Leprotto Дата: Вторник, 15.03.2016, 18:05 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Обычный СЧЕТЕСЛИ не видит кол-во слов, если в одной ячейке несколько раз встречается искомое слово.
Дополнительная задача: показывать единицу при любом кол-ве ключевого слова.
К сообщению приложен файл: banany.xlsx(9Kb)
 
Ответить
СообщениеОбычный СЧЕТЕСЛИ не видит кол-во слов, если в одной ячейке несколько раз встречается искомое слово.
Дополнительная задача: показывать единицу при любом кол-ве ключевого слова.

Автор - Leprotto
Дата добавления - 15.03.2016 в 18:05
MacSieM Дата: Вторник, 15.03.2016, 18:16 | Сообщение № 2
Группа: Проверенные
Ранг: Участник
Сообщений: 84
Репутация: 18 ±
Замечаний: 0% ±

Excel 2010
На первый вопрос решение такое (формула массивная):
Код
=СУММ(ДЛСТР(A2:C2)-ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";"")))/ДЛСТР("банан")


На второй вопрос такое:
Код
=--(СЧЁТЕСЛИ(A7:C7;"яблоко")>0)


Сообщение отредактировал MacSieM - Вторник, 15.03.2016, 18:25
 
Ответить
СообщениеНа первый вопрос решение такое (формула массивная):
Код
=СУММ(ДЛСТР(A2:C2)-ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";"")))/ДЛСТР("банан")


На второй вопрос такое:
Код
=--(СЧЁТЕСЛИ(A7:C7;"яблоко")>0)

Автор - MacSieM
Дата добавления - 15.03.2016 в 18:16
Pelena Дата: Вторник, 15.03.2016, 18:22 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11491
Репутация: 2555 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Варианты формул, обе массивные
Код
=СУММ(--(ПСТР(A2:C2;СТРОКА(1:99);5)="банан"))

Код
=--ИЛИ(ПОИСК("яблоко";A7:C7))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВарианты формул, обе массивные
Код
=СУММ(--(ПСТР(A2:C2;СТРОКА(1:99);5)="банан"))

Код
=--ИЛИ(ПОИСК("яблоко";A7:C7))

Автор - Pelena
Дата добавления - 15.03.2016 в 18:22
Che79 Дата: Вторник, 15.03.2016, 18:28 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 465
Репутация: 73 ±
Замечаний: 0% ±

Excel 2010 RUS
про бананы - первое, что пришло в голову, не особо думая
массивная
Код
=СЧЁТ(ПОИСК({"бананы":"банан"};A2:C2))

массивная
Код
=СЧЁТ(--ЕСЛИ(A2:C2="бан*";))

хотя, вот эта очень сомнительная %)

про яблоки
массивная
Код
=ЕСЛИ(ИЛИ(A7:C7="яблоко");1;"")

:D


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Вторник, 15.03.2016, 19:01
 
Ответить
Сообщениепро бананы - первое, что пришло в голову, не особо думая
массивная
Код
=СЧЁТ(ПОИСК({"бананы":"банан"};A2:C2))

массивная
Код
=СЧЁТ(--ЕСЛИ(A2:C2="бан*";))

хотя, вот эта очень сомнительная %)

про яблоки
массивная
Код
=ЕСЛИ(ИЛИ(A7:C7="яблоко");1;"")

:D

Автор - Che79
Дата добавления - 15.03.2016 в 18:28
Udik Дата: Вторник, 15.03.2016, 18:38 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 191 ±
Замечаний: 0% ±

Excel 2016 х 64
или простая, на основе формулы MacSieM
Код
=СУММПРОИЗВ((ДЛСТР(A2:C2)-ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";"")))/ДЛСТР("банан"))


и вторая

Код
=--(СУММПРОИЗВ((ДЛСТР(A7:C7)-ДЛСТР(ПОДСТАВИТЬ(A7:C7;"яблоко";""))))>0)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Вторник, 15.03.2016, 18:48
 
Ответить
Сообщениеили простая, на основе формулы MacSieM
Код
=СУММПРОИЗВ((ДЛСТР(A2:C2)-ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";"")))/ДЛСТР("банан"))


и вторая

Код
=--(СУММПРОИЗВ((ДЛСТР(A7:C7)-ДЛСТР(ПОДСТАВИТЬ(A7:C7;"яблоко";""))))>0)

Автор - Udik
Дата добавления - 15.03.2016 в 18:38
abtextime Дата: Вторник, 15.03.2016, 18:45 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
а меня на UDF потянуло ...

[vba]
Код
Function Ban(RR As Range, SS As String) As Integer

Dim R As Range, S As String

Ban = 0

For Each R In RR

S = R.Value

Ban = Ban + (Len(S) - Len(Replace(S, SS, ""))) / Len(SS)

Next

End Function
[/vba]
К сообщению приложен файл: _banany.xlsm(14Kb)


Сообщение отредактировал abtextime - Вторник, 15.03.2016, 18:47
 
Ответить
Сообщениеа меня на UDF потянуло ...

[vba]
Код
Function Ban(RR As Range, SS As String) As Integer

Dim R As Range, S As String

Ban = 0

For Each R In RR

S = R.Value

Ban = Ban + (Len(S) - Len(Replace(S, SS, ""))) / Len(SS)

Next

End Function
[/vba]

Автор - abtextime
Дата добавления - 15.03.2016 в 18:45
_Boroda_ Дата: Вторник, 15.03.2016, 20:08 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11327
Репутация: 4676 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну и еще немассивные формулы
Код
=ОТБР(СУММПРОИЗВ(ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";ПОВТОР(" ";99))))/99)

Код
=ОТБР(СУММПРОИЗВ(ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";ПОВТОР(" ";100))))%)

Во второй слово "яблоко" не обязательно же первое, правильно? Может быть что-то типа "куча яблок стухла"?
Код
=--ЕТЕКСТ(ГПР("*яблок*";A7:C7;1;))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу и еще немассивные формулы
Код
=ОТБР(СУММПРОИЗВ(ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";ПОВТОР(" ";99))))/99)

Код
=ОТБР(СУММПРОИЗВ(ДЛСТР(ПОДСТАВИТЬ(A2:C2;"банан";ПОВТОР(" ";100))))%)

Во второй слово "яблоко" не обязательно же первое, правильно? Может быть что-то типа "куча яблок стухла"?
Код
=--ЕТЕКСТ(ГПР("*яблок*";A7:C7;1;))

Автор - _Boroda_
Дата добавления - 15.03.2016 в 20:08
Leprotto Дата: Среда, 16.03.2016, 09:32 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
MacSieM, Pelena, Che79 к сожалению первая задача в моем примере не работает (см. файл).
Udik, _Boroda_, а Ваши работают. clap
Вторая задача от всех работает. specool
Спасибо большое ВСЕМ !!!
К сообщению приложен файл: 9862522.xlsx(11Kb)
 
Ответить
СообщениеMacSieM, Pelena, Che79 к сожалению первая задача в моем примере не работает (см. файл).
Udik, _Boroda_, а Ваши работают. clap
Вторая задача от всех работает. specool
Спасибо большое ВСЕМ !!!

Автор - Leprotto
Дата добавления - 16.03.2016 в 09:32
Che79 Дата: Среда, 16.03.2016, 09:41 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 465
Репутация: 73 ±
Замечаний: 0% ±

Excel 2010 RUS
Leprotto, добрый день.
За свои варианты в задаче с бананами готов с Вами спорить ;)
массивная

=СЧЁТ(ПОИСК({"бананы":"банан"};A2:C2))

вводится одновременным нажатием Кнтрл+Шифт+Энтер.

а задачи про тренировки изначально в примере не было ))


Делай нормально и будет нормально!
 
Ответить
СообщениеLeprotto, добрый день.
За свои варианты в задаче с бананами готов с Вами спорить ;)
массивная

=СЧЁТ(ПОИСК({"бананы":"банан"};A2:C2))

вводится одновременным нажатием Кнтрл+Шифт+Энтер.

а задачи про тренировки изначально в примере не было ))

Автор - Che79
Дата добавления - 16.03.2016 в 09:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет слов в диапазоне, в т.ч. одинаковых в одной ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!