Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных на новый лист при выполнении условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на новый лист при выполнении условий (Формулы/Formulas)
Перенос данных на новый лист при выполнении условий
Iha Дата: Четверг, 17.03.2016, 13:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день!
Очень нужна помощь!
Есть лист с данными из него нужно перенести все строки, удовлетворяющие условию по колонке сумма долга(=0) на новый лист. Понимаю что должна работать формула ИНДЕКС, только что-то с ней не клеится.

Код
=ИНДЕКС('исходные данные'!$A3:$F13;НАИМЕНЬШИЙ(ЕСЛИ(('исходные данные'!$A$3:$F13=0);СТРОКА('исходные данные'!$A$3:$F$13)-1);СТРОКА(A2)))


И как лучше поступить, если нужно переносить не всю строку целиком, а только значения по конкретным колонкам?
К сообщению приложен файл: 17032016.xlsx(13Kb)


Сообщение отредактировал Manyasha - Четверг, 17.03.2016, 13:59
 
Ответить
СообщениеДобрый день!
Очень нужна помощь!
Есть лист с данными из него нужно перенести все строки, удовлетворяющие условию по колонке сумма долга(=0) на новый лист. Понимаю что должна работать формула ИНДЕКС, только что-то с ней не клеится.

Код
=ИНДЕКС('исходные данные'!$A3:$F13;НАИМЕНЬШИЙ(ЕСЛИ(('исходные данные'!$A$3:$F13=0);СТРОКА('исходные данные'!$A$3:$F$13)-1);СТРОКА(A2)))


И как лучше поступить, если нужно переносить не всю строку целиком, а только значения по конкретным колонкам?

Автор - Iha
Дата добавления - 17.03.2016 в 13:34
китин Дата: Четверг, 17.03.2016, 13:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3681
Репутация: 573 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как то вот так
Код
=ИНДЕКС('исходные данные'!$A3:$A13;НАИМЕНЬШИЙ(ЕСЛИ(('исходные данные'!$F$3:$F$13=0);СТРОКА('исходные данные'!$A$3:$F$13)-2);СТРОКА(A1)))
а если протягиваемой формулой тогда тока так
Код
=ИНДЕКС('исходные данные'!$A3:$F13;НАИМЕНЬШИЙ(ЕСЛИ(('исходные данные'!$F$3:$F$13=0);СТРОКА('исходные данные'!$A$3:$A$13)-2);СТРОКА(A1));ПОИСКПОЗ(A$2;'исходные данные'!$A$2:$F$2;0))
файл №2
К сообщению приложен файл: Iha.xlsx(13Kb) · Iha_2.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 17.03.2016, 13:50
 
Ответить
Сообщениекак то вот так
Код
=ИНДЕКС('исходные данные'!$A3:$A13;НАИМЕНЬШИЙ(ЕСЛИ(('исходные данные'!$F$3:$F$13=0);СТРОКА('исходные данные'!$A$3:$F$13)-2);СТРОКА(A1)))
а если протягиваемой формулой тогда тока так
Код
=ИНДЕКС('исходные данные'!$A3:$F13;НАИМЕНЬШИЙ(ЕСЛИ(('исходные данные'!$F$3:$F$13=0);СТРОКА('исходные данные'!$A$3:$A$13)-2);СТРОКА(A1));ПОИСКПОЗ(A$2;'исходные данные'!$A$2:$F$2;0))
файл №2

Автор - китин
Дата добавления - 17.03.2016 в 13:47
_Boroda_ Дата: Четверг, 17.03.2016, 13:53 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9795
Репутация: 4138 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вполне себе протягиваемая вроде. Или нет?
Код
=ЕСЛИОШИБКА(ИНДЕКС('исходные данные'!A$3:A$13;НАИМЕНЬШИЙ(ЕСЛИ('исходные данные'!$F$3:$F$13=0;СТРОКА('исходные данные'!A$3:A$13)-2);СТРОКА(A1)));"")
К сообщению приложен файл: 17032016_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВполне себе протягиваемая вроде. Или нет?
Код
=ЕСЛИОШИБКА(ИНДЕКС('исходные данные'!A$3:A$13;НАИМЕНЬШИЙ(ЕСЛИ('исходные данные'!$F$3:$F$13=0;СТРОКА('исходные данные'!A$3:A$13)-2);СТРОКА(A1)));"")

Автор - _Boroda_
Дата добавления - 17.03.2016 в 13:53
jakim Дата: Четверг, 17.03.2016, 14:00 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 708
Репутация: 182 ±
Замечаний: 0% ±

Вы можете применить функцию АГРЕГАТ.
К сообщению приложен файл: 3698864.xlsx(12Kb)
 
Ответить
Сообщение
Вы можете применить функцию АГРЕГАТ.

Автор - jakim
Дата добавления - 17.03.2016 в 14:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на новый лист при выполнении условий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!