Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическая сортировка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая сортировка (Формулы/Formulas)
Автоматическая сортировка
maxx13 Дата: Среда, 23.03.2016, 13:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день. подскажите, пожалуйста, возможен ли вариант, чтобы excel автоматом подставлял из таблицы 1 (выделена красным цветом) в нужные сроки таблицы 2 (выделена желтым).
 
Ответить
СообщениеДобрый день. подскажите, пожалуйста, возможен ли вариант, чтобы excel автоматом подставлял из таблицы 1 (выделена красным цветом) в нужные сроки таблицы 2 (выделена желтым).

Автор - maxx13
Дата добавления - 23.03.2016 в 13:00
BobroEJ Дата: Среда, 23.03.2016, 13:06 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
maxx13, вы там что-то забыли приложить.
 
Ответить
Сообщениеmaxx13, вы там что-то забыли приложить.

Автор - BobroEJ
Дата добавления - 23.03.2016 в 13:06
maxx13 Дата: Среда, 23.03.2016, 13:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
сори
К сообщению приложен файл: ___01.03.2016-.xls(58Kb)
 
Ответить
Сообщениесори

Автор - maxx13
Дата добавления - 23.03.2016 в 13:07
buchlotnik Дата: Среда, 23.03.2016, 13:15 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2627
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$90:D$108;ПОИСКПОЗ($C17;$C$90:$C$108;0));"")
К сообщению приложен файл: _01.03.2016-.xls(78Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$90:D$108;ПОИСКПОЗ($C17;$C$90:$C$108;0));"")

Автор - buchlotnik
Дата добавления - 23.03.2016 в 13:15
_Boroda_ Дата: Среда, 23.03.2016, 13:21 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ(($C17=$C$90:$C$108)*D$90:D$108)

И формат ячеек
# ##0,00;;
К сообщению приложен файл: _01.03.2016-1.xls(78Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(($C17=$C$90:$C$108)*D$90:D$108)

И формат ячеек
# ##0,00;;

Автор - _Boroda_
Дата добавления - 23.03.2016 в 13:21
maxx13 Дата: Среда, 23.03.2016, 13:22 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
да, спасибо огромное. уже проще от 200 органов такое свести 2 разных файла
 
Ответить
Сообщениеда, спасибо огромное. уже проще от 200 органов такое свести 2 разных файла

Автор - maxx13
Дата добавления - 23.03.2016 в 13:22
BobroEJ Дата: Среда, 23.03.2016, 13:29 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(Таблица1;ПОИСКПОЗ($C17;ИНДЕКС(Таблица1;;1);0);D$16-3));"";ИНДЕКС(Таблица1;ПОИСКПОЗ($C17;ИНДЕКС(Таблица1;;1);0);D$16-3))


Файл не получилось приложить, ну и ладно... (Только нужно первую таблицу сделать массивом "Таблица1")

upd Получилось.
К сообщению приложен файл: 4287448.xls(64Kb)


Сообщение отредактировал BobroEJ - Среда, 23.03.2016, 13:35
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(Таблица1;ПОИСКПОЗ($C17;ИНДЕКС(Таблица1;;1);0);D$16-3));"";ИНДЕКС(Таблица1;ПОИСКПОЗ($C17;ИНДЕКС(Таблица1;;1);0);D$16-3))


Файл не получилось приложить, ну и ладно... (Только нужно первую таблицу сделать массивом "Таблица1")

upd Получилось.

Автор - BobroEJ
Дата добавления - 23.03.2016 в 13:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическая сортировка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!