Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Может ли excel читать данные таблицы в книжном порядке ? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Может ли excel читать данные таблицы в книжном порядке ? (Формулы/Formulas)
Может ли excel читать данные таблицы в книжном порядке ?
Шептун Дата: Четверг, 24.03.2016, 13:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день уважаемые знатоки !

Вроде думал что неплохо знаю excel, но вот столкнулся с задачкой, которую не могу решить уже второй день. Возможно вы мне подскажите: у меня есть таблица (см. файл в приложении) со значениями. Вопрос - какой формулой можно упорядочить значения таблицы как бы в книжном порядке, то есть сверху вниз; слева направо ?
К сообщению приложен файл: 6788519.xlsx(9Kb)


Сообщение отредактировал Шептун - Четверг, 24.03.2016, 13:10
 
Ответить
СообщениеДобрый день уважаемые знатоки !

Вроде думал что неплохо знаю excel, но вот столкнулся с задачкой, которую не могу решить уже второй день. Возможно вы мне подскажите: у меня есть таблица (см. файл в приложении) со значениями. Вопрос - какой формулой можно упорядочить значения таблицы как бы в книжном порядке, то есть сверху вниз; слева направо ?

Автор - Шептун
Дата добавления - 24.03.2016 в 13:08
_Boroda_ Дата: Четверг, 24.03.2016, 13:34 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9354
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? Формула массива. Вводится одновременным нажатием Кнтрл Шифт Ентер
Код
=ИНДЕКС(C$2:H$21;НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";СТРОКА($1:$20));СТРОКА(K1));ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";СТОЛБЕЦ(A:F)%%+СТРОКА($2:$21));СТРОКА(K1));1)/1%%+0,1)
К сообщению приложен файл: 6788519_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? Формула массива. Вводится одновременным нажатием Кнтрл Шифт Ентер
Код
=ИНДЕКС(C$2:H$21;НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";СТРОКА($1:$20));СТРОКА(K1));ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";СТОЛБЕЦ(A:F)%%+СТРОКА($2:$21));СТРОКА(K1));1)/1%%+0,1)

Автор - _Boroda_
Дата добавления - 24.03.2016 в 13:34
Udik Дата: Четверг, 24.03.2016, 13:47 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1214
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
можно упорядочить значения таблицы как бы в книжном порядке

Не совсем понял задачу. Может вам достаточно последовательно отсортировать по столбцам?
К сообщению приложен файл: 1306032.xlsx(9Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщение
можно упорядочить значения таблицы как бы в книжном порядке

Не совсем понял задачу. Может вам достаточно последовательно отсортировать по столбцам?

Автор - Udik
Дата добавления - 24.03.2016 в 13:47
vikttur Дата: Четверг, 24.03.2016, 14:02 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

Вариант (формула массива):
Код
=ИНДЕКС(C$2:H$21;ЦЕЛОЕ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";B$2:B$21+{1;2;3;4;5;6}*0,1);СТРОКА(A1)));--ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";B$2:B$21+{1;2;3;4;5;6}*0,1);СТРОКА(A1))))
 
Ответить
СообщениеВариант (формула массива):
Код
=ИНДЕКС(C$2:H$21;ЦЕЛОЕ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";B$2:B$21+{1;2;3;4;5;6}*0,1);СТРОКА(A1)));--ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";B$2:B$21+{1;2;3;4;5;6}*0,1);СТРОКА(A1))))

Автор - vikttur
Дата добавления - 24.03.2016 в 14:02
_Boroda_ Дата: Четверг, 24.03.2016, 14:57 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9354
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну, со ссылкой на числовой столбец и до десятка полей и так можно
Код
=ИНДЕКС(C$2:H$21;НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";B$2:B$21);B2);ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";СТОЛБЕЦ(A:F)%+B$2:B$21);B2)))

Только это не интересно


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу, со ссылкой на числовой столбец и до десятка полей и так можно
Код
=ИНДЕКС(C$2:H$21;НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";B$2:B$21);B2);ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(C$2:H$21<>"";СТОЛБЕЦ(A:F)%+B$2:B$21);B2)))

Только это не интересно

Автор - _Boroda_
Дата добавления - 24.03.2016 в 14:57
vikttur Дата: Четверг, 24.03.2016, 15:41 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

Точно по примеру )
Код
=СИМВОЛ(ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ($C$2:$H$21<>"";$B$2:$B$21+(СТОЛБЕЦ(C:H)-2)*0,1);СТРОКА(A1)))+96)
 
Ответить
СообщениеТочно по примеру )
Код
=СИМВОЛ(ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ($C$2:$H$21<>"";$B$2:$B$21+(СТОЛБЕЦ(C:H)-2)*0,1);СТРОКА(A1)))+96)

Автор - vikttur
Дата добавления - 24.03.2016 в 15:41
Шептун Дата: Четверг, 24.03.2016, 17:47 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Большое спасибо за быстрый ответ. Boroda и vikttur - да вы всё правильно поняли. У меня только один дополнение: я бы хотел чтобы таблица работала в режиме on-line. То есть при добавлении нового значения оно автоматически сортировалось, а здесь без нажатия клавиш ctrl+shift+enter это не работает.
 
Ответить
СообщениеБольшое спасибо за быстрый ответ. Boroda и vikttur - да вы всё правильно поняли. У меня только один дополнение: я бы хотел чтобы таблица работала в режиме on-line. То есть при добавлении нового значения оно автоматически сортировалось, а здесь без нажатия клавиш ctrl+shift+enter это не работает.

Автор - Шептун
Дата добавления - 24.03.2016 в 17:47
Wasilich Дата: Четверг, 24.03.2016, 18:29 | Сообщение № 8
Группа: Друзья
Ранг: Ветеран
Сообщений: 866
Репутация: 221 ±
Замечаний: 0% ±

2003
Вопрос - какой формулой можно упорядочить значения
Не, а чё именно формулой. Да ещё такой громоздкой. Для такой маленькой таблицы подойдет маленький макрос. :)
К сообщению приложен файл: 2924782.xls(35Kb)


Сообщение отредактировал Wasilich - Четверг, 24.03.2016, 18:37
 
Ответить
Сообщение
Вопрос - какой формулой можно упорядочить значения
Не, а чё именно формулой. Да ещё такой громоздкой. Для такой маленькой таблицы подойдет маленький макрос. :)

Автор - Wasilich
Дата добавления - 24.03.2016 в 18:29
vikttur Дата: Четверг, 24.03.2016, 19:14 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

я бы хотел чтобы таблица работала в режиме on-line

Да ну? Задайте диапазоны больше. ЕСЛИОШИБКА для обхода ошибки - и порядок.
 
Ответить
Сообщение
я бы хотел чтобы таблица работала в режиме on-line

Да ну? Задайте диапазоны больше. ЕСЛИОШИБКА для обхода ошибки - и порядок.

Автор - vikttur
Дата добавления - 24.03.2016 в 19:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Может ли excel читать данные таблицы в книжном порядке ? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!