Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Совокупная сумма по датам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совокупная сумма по датам (Формулы/Formulas)
Совокупная сумма по датам
maksimusus Дата: Четверг, 24.03.2016, 22:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер. Прошу помочь если это возможно в решении следующей задачи:
в таблицу по мере возникновения вносится дата и суммы, необходимо, что б в отдельном столбце в ячейке суммировались все суммы за каждую возникающую дату отдельно.. Заранее не известно какая дата будет в следующей строке и сколько строк будет с одной датой. Пример во вложении.
К сообщению приложен файл: 6894573.xls(28Kb)
 
Ответить
СообщениеДобрый вечер. Прошу помочь если это возможно в решении следующей задачи:
в таблицу по мере возникновения вносится дата и суммы, необходимо, что б в отдельном столбце в ячейке суммировались все суммы за каждую возникающую дату отдельно.. Заранее не известно какая дата будет в следующей строке и сколько строк будет с одной датой. Пример во вложении.

Автор - maksimusus
Дата добавления - 24.03.2016 в 22:29
_Boroda_ Дата: Четверг, 24.03.2016, 22:33 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9345
Репутация: 3921 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(A2<>A1;СУММЕСЛИ(A2:A11;A2;B2:C11);"")
К сообщению приложен файл: 6894573_1.xls(38Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(A2<>A1;СУММЕСЛИ(A2:A11;A2;B2:C11);"")

Автор - _Boroda_
Дата добавления - 24.03.2016 в 22:33
maksimusus Дата: Четверг, 24.03.2016, 22:39 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, очень на то, что нужно похоже, но из столбца "сумма2" не добавляются суммы в общий результат
 
Ответить
Сообщение_Boroda_, очень на то, что нужно похоже, но из столбца "сумма2" не добавляются суммы в общий результат

Автор - maksimusus
Дата добавления - 24.03.2016 в 22:39
Nic70y Дата: Четверг, 24.03.2016, 22:41 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3469
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(A2=A1;"";СУММЕСЛИ([дата];[@дата];[сумма])+СУММЕСЛИ([дата];[@дата];[сумма2]))
К сообщению приложен файл: 6894573.xlsx(14Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(A2=A1;"";СУММЕСЛИ([дата];[@дата];[сумма])+СУММЕСЛИ([дата];[@дата];[сумма2]))

Автор - Nic70y
Дата добавления - 24.03.2016 в 22:41
buchlotnik Дата: Четверг, 24.03.2016, 22:47 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно так (нули форматом снял):
Код
=СУММПРОИЗВ((A1<>A2)*(A2=$A$2:$A$11)*$B$2:$C$11)
К сообщению приложен файл: 6894573-1-.xls(35Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеможно так (нули форматом снял):
Код
=СУММПРОИЗВ((A1<>A2)*(A2=$A$2:$A$11)*$B$2:$C$11)

Автор - buchlotnik
Дата добавления - 24.03.2016 в 22:47
maksimusus Дата: Четверг, 24.03.2016, 22:56 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
buchlotnik, Nic70y, Спасибо! возникает одна проблема, при добавлении новой даты, которая была раньше, строка дублируется, можно сделать так, что б не дублировалась, а сумма добавлялась в соответствующую ячейку ? кроме как сортировку по дате поставить )
К сообщению приложен файл: _1.xlsx(13Kb)


Сообщение отредактировал maksimusus - Четверг, 24.03.2016, 22:56
 
Ответить
Сообщениеbuchlotnik, Nic70y, Спасибо! возникает одна проблема, при добавлении новой даты, которая была раньше, строка дублируется, можно сделать так, что б не дублировалась, а сумма добавлялась в соответствующую ячейку ? кроме как сортировку по дате поставить )

Автор - maksimusus
Дата добавления - 24.03.2016 в 22:56
buchlotnik Дата: Четверг, 24.03.2016, 23:01 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так тоже можно B)
Код
=СУММПРОИЗВ((СЧЁТЕСЛИ($A$1:A1;A2)=0)*(A2=$A$2:$A$11)*$B$2:$C$11)
тупой вопрос - на кой?
К сообщению приложен файл: 6894573-1-2-.xls(36Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак тоже можно B)
Код
=СУММПРОИЗВ((СЧЁТЕСЛИ($A$1:A1;A2)=0)*(A2=$A$2:$A$11)*$B$2:$C$11)
тупой вопрос - на кой?

Автор - buchlotnik
Дата добавления - 24.03.2016 в 23:01
Nic70y Дата: Четверг, 24.03.2016, 23:01 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3469
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ([@дата];[дата];)=СТРОКА()-1;СУММЕСЛИ([дата];[@дата];[сумма])+СУММЕСЛИ([дата];[@дата];[сумма2]);"");"")
К сообщению приложен файл: 6059344.xlsx(14Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ([@дата];[дата];)=СТРОКА()-1;СУММЕСЛИ([дата];[@дата];[сумма])+СУММЕСЛИ([дата];[@дата];[сумма2]);"");"")

Автор - Nic70y
Дата добавления - 24.03.2016 в 23:01
maksimusus Дата: Четверг, 24.03.2016, 23:07 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
buchlotnik, Благодарю! вся таблица намного сложней - расчет совершенных сделок на фондовой бирже, один из ее параметров - комиссия которая зависит от суммы оборота по всем сделкам за день..)) если сумма 100 то комиссия одна, если 200 то другая.., вот задача свести все в одну таблицу, что б пр вводе основных параметров, как дата, цена и объем - все автоматически считалось )


Сообщение отредактировал maksimusus - Четверг, 24.03.2016, 23:11
 
Ответить
Сообщениеbuchlotnik, Благодарю! вся таблица намного сложней - расчет совершенных сделок на фондовой бирже, один из ее параметров - комиссия которая зависит от суммы оборота по всем сделкам за день..)) если сумма 100 то комиссия одна, если 200 то другая.., вот задача свести все в одну таблицу, что б пр вводе основных параметров, как дата, цена и объем - все автоматически считалось )

Автор - maksimusus
Дата добавления - 24.03.2016 в 23:07
maksimusus Дата: Четверг, 24.03.2016, 23:10 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Спасибо )
 
Ответить
СообщениеNic70y, Спасибо )

Автор - maksimusus
Дата добавления - 24.03.2016 в 23:10
_Boroda_ Дата: Четверг, 24.03.2016, 23:19 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9345
Репутация: 3921 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Отвлекли меня
Еще вариант
Код
=СУММПРОИЗВ(ЕНД(ПОИСКПОЗ([@дата];A$1:A1;))*([@дата]=[дата])*([сумма]+[сумма2]))
К сообщению приложен файл: _1555_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОтвлекли меня
Еще вариант
Код
=СУММПРОИЗВ(ЕНД(ПОИСКПОЗ([@дата];A$1:A1;))*([@дата]=[дата])*([сумма]+[сумма2]))

Автор - _Boroda_
Дата добавления - 24.03.2016 в 23:19
maksimusus Дата: Четверг, 24.03.2016, 23:32 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, Спасибо)
 
Ответить
Сообщение_Boroda_, Спасибо)

Автор - maksimusus
Дата добавления - 24.03.2016 в 23:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совокупная сумма по датам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!