Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение ячеек значениями по дате - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение ячеек значениями по дате (Формулы/Formulas)
Заполнение ячеек значениями по дате
maksimusus Дата: Пятница, 25.03.2016, 16:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер. Продолжаю мучать свою таблицу, с вашей помощью ) прошу помочь решить следующую задачу: необходимо заполнить каждую ячейку в "столбец1"соответствующим по дате значением(заполнил в таблице как должно быть), которое определяется в столбце "комиссия"(в общей таблице это значение формируется через формулу). предупреждая вопросы отвечу это не самоцель, данная формула будет частью, другой формулы.. заранее благодарю, за помощь!
К сообщению приложен файл: 3210123.xlsx(11Kb)


Сообщение отредактировал maksimusus - Пятница, 25.03.2016, 16:47
 
Ответить
СообщениеДобрый вечер. Продолжаю мучать свою таблицу, с вашей помощью ) прошу помочь решить следующую задачу: необходимо заполнить каждую ячейку в "столбец1"соответствующим по дате значением(заполнил в таблице как должно быть), которое определяется в столбце "комиссия"(в общей таблице это значение формируется через формулу). предупреждая вопросы отвечу это не самоцель, данная формула будет частью, другой формулы.. заранее благодарю, за помощь!

Автор - maksimusus
Дата добавления - 25.03.2016 в 16:46
Che79 Дата: Пятница, 25.03.2016, 16:58 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
maksimusus, наверное, не совсем понял задачу.
Может, это нужно?
Но тут не формульное решение


Делай нормально и будет нормально!
 
Ответить
Сообщениеmaksimusus, наверное, не совсем понял задачу.
Может, это нужно?
Но тут не формульное решение

Автор - Che79
Дата добавления - 25.03.2016 в 16:58
abtextime Дата: Пятница, 25.03.2016, 17:00 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
До чёрта вариантов. Если ИМЕННО ТАКАЯ структура, то простейшее

Код
=ЕСЛИ([@комиссия]="";D1;[@комиссия])
К сообщению приложен файл: _3210123.xlsx(12Kb)
 
Ответить
СообщениеДо чёрта вариантов. Если ИМЕННО ТАКАЯ структура, то простейшее

Код
=ЕСЛИ([@комиссия]="";D1;[@комиссия])

Автор - abtextime
Дата добавления - 25.03.2016 в 17:00
abtextime Дата: Пятница, 25.03.2016, 17:02 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
или так

Код
=ВПР([@дата];Таблица1;2;0)
К сообщению приложен файл: 3802138.xlsx(12Kb)
 
Ответить
Сообщениеили так

Код
=ВПР([@дата];Таблица1;2;0)

Автор - abtextime
Дата добавления - 25.03.2016 в 17:02
_Boroda_ Дата: Пятница, 25.03.2016, 17:03 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если комиссия может быть пустой, то, возможно, вот такой вариант поможет
Код
=ЕСЛИ([@дата]=B1;D1;[@комиссия])
К сообщению приложен файл: 3210123_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли комиссия может быть пустой, то, возможно, вот такой вариант поможет
Код
=ЕСЛИ([@дата]=B1;D1;[@комиссия])

Автор - _Boroda_
Дата добавления - 25.03.2016 в 17:03
maksimusus Дата: Пятница, 25.03.2016, 17:05 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем, Большое спасибо!
 
Ответить
СообщениеВсем, Большое спасибо!

Автор - maksimusus
Дата добавления - 25.03.2016 в 17:05
maksimusus Дата: Пятница, 25.03.2016, 18:10 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
abtextime, дата должна быть обязательно в первом столбце?
 
Ответить
Сообщениеabtextime, дата должна быть обязательно в первом столбце?

Автор - maksimusus
Дата добавления - 25.03.2016 в 18:10
abtextime Дата: Пятница, 25.03.2016, 18:15 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
maksimusus,

Для ВПР - да, поиск идет по первому столбцу массива. Бывает, что поиск надо производить по столбцу, который идет ПОСЛЕ столбца, откуда извлекается информация, тогда используйте связку ИНДЕКС(... ПОИСКПОЗ())
 
Ответить
Сообщениеmaksimusus,

Для ВПР - да, поиск идет по первому столбцу массива. Бывает, что поиск надо производить по столбцу, который идет ПОСЛЕ столбца, откуда извлекается информация, тогда используйте связку ИНДЕКС(... ПОИСКПОЗ())

Автор - abtextime
Дата добавления - 25.03.2016 в 18:15
abtextime Дата: Пятница, 25.03.2016, 18:17 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
в дополнение, в качестве массива для ВПР() можно брать не всю таблицу, а только часть ее смежных столбцов, и тогда поиск идет именно по первому из этих столбцов
 
Ответить
Сообщениев дополнение, в качестве массива для ВПР() можно брать не всю таблицу, а только часть ее смежных столбцов, и тогда поиск идет именно по первому из этих столбцов

Автор - abtextime
Дата добавления - 25.03.2016 в 18:17
maksimusus Дата: Пятница, 25.03.2016, 18:37 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
abtextime, спасибо!
 
Ответить
Сообщениеabtextime, спасибо!

Автор - maksimusus
Дата добавления - 25.03.2016 в 18:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение ячеек значениями по дате (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!