Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подбор списка по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подбор списка по нескольким условиям (Формулы/Formulas)
подбор списка по нескольким условиям
zaak88 Дата: Пятница, 25.03.2016, 17:26 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
помогите, пожалуйста, в файле пример хочется чтобы на листе "заявка на поставку" в графе наименование подбирались позиции из листа "расчёт поставки" наименование показателя при условии 1 совпадения номера недели и условии 2 если в графе "Итого потребность на начало недели +1" значение будет больше нуля. Пробовал несколько формул - подобрать не получилось. Спасибо! Хочется, чтобы формулой подбирался список - много недель поставки.
К сообщению приложен файл: 1495813.xlsx(17Kb)
 
Ответить
Сообщениепомогите, пожалуйста, в файле пример хочется чтобы на листе "заявка на поставку" в графе наименование подбирались позиции из листа "расчёт поставки" наименование показателя при условии 1 совпадения номера недели и условии 2 если в графе "Итого потребность на начало недели +1" значение будет больше нуля. Пробовал несколько формул - подобрать не получилось. Спасибо! Хочется, чтобы формулой подбирался список - много недель поставки.

Автор - zaak88
Дата добавления - 25.03.2016 в 17:26
krosav4ig Дата: Пятница, 25.03.2016, 18:07 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1342
Репутация: 536 ±
Замечаний: 0% ±

Excel 2007, 2013
наворотил монстра, аж самому страшно стало
Код
=ЕСЛИОШИБКА(ИНДЕКС('Расчет поставки'!$A:$A;НАИМЕНЬШИЙ(ЕСЛИ(('Расчет поставки'!$C$6:ИНДЕКС('Расчет поставки'!$6:$6;ПОИСКПОЗ(54;'Расчет поставки'!$6:$6))=$F$2)*'Расчет поставки'!$D$8:ИНДЕКС('Расчет поставки'!$1:$100000;ПОИСКПОЗ("яяя";'Расчет поставки'!$A:$A)-1;ПОИСКПОЗ("яяя";'Расчет поставки'!$7:$7));СТРОКА('Расчет поставки'!$A$8:ИНДЕКС('Расчет поставки'!$A:$A;ПОИСКПОЗ("яяя";'Расчет поставки'!$A:$A)-1));"");A6));"")
К сообщению приложен файл: 7039026.xlsx(20Kb)


(_)Õvõ(_)
 
Ответить
Сообщениенаворотил монстра, аж самому страшно стало
Код
=ЕСЛИОШИБКА(ИНДЕКС('Расчет поставки'!$A:$A;НАИМЕНЬШИЙ(ЕСЛИ(('Расчет поставки'!$C$6:ИНДЕКС('Расчет поставки'!$6:$6;ПОИСКПОЗ(54;'Расчет поставки'!$6:$6))=$F$2)*'Расчет поставки'!$D$8:ИНДЕКС('Расчет поставки'!$1:$100000;ПОИСКПОЗ("яяя";'Расчет поставки'!$A:$A)-1;ПОИСКПОЗ("яяя";'Расчет поставки'!$7:$7));СТРОКА('Расчет поставки'!$A$8:ИНДЕКС('Расчет поставки'!$A:$A;ПОИСКПОЗ("яяя";'Расчет поставки'!$A:$A)-1));"");A6));"")

Автор - krosav4ig
Дата добавления - 25.03.2016 в 18:07
_Boroda_ Дата: Пятница, 25.03.2016, 18:36 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС('Расчет поставки'!A$1:A$41;НАИМЕНЬШИЙ(ЕСЛИ('Расчет поставки'!D$16:H$39*('Расчет поставки'!C$6:G$6=F$2);СТРОКА('Расчет поставки'!A$16:A$39);41);A6))&""

Для В6:В20. В остальных - просто ссылки на В6:В20
К сообщению приложен файл: 1495813_1.xlsx(19Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС('Расчет поставки'!A$1:A$41;НАИМЕНЬШИЙ(ЕСЛИ('Расчет поставки'!D$16:H$39*('Расчет поставки'!C$6:G$6=F$2);СТРОКА('Расчет поставки'!A$16:A$39);41);A6))&""

Для В6:В20. В остальных - просто ссылки на В6:В20

Автор - _Boroda_
Дата добавления - 25.03.2016 в 18:36
zaak88 Дата: Суббота, 26.03.2016, 13:59 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
krosav4ig, спасибо, огромное! а в этом файле можете так сделать, немного формулу не понял.... прошу прощения за назойливость...
К сообщению приложен файл: _-.xlsx(61Kb)
 
Ответить
Сообщениеkrosav4ig, спасибо, огромное! а в этом файле можете так сделать, немного формулу не понял.... прошу прощения за назойливость...

Автор - zaak88
Дата добавления - 26.03.2016 в 13:59
zaak88 Дата: Суббота, 26.03.2016, 14:10 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
_Boroda_, тоже большое Вам спасибо! выручили!!!
 
Ответить
Сообщение_Boroda_, тоже большое Вам спасибо! выручили!!!

Автор - zaak88
Дата добавления - 26.03.2016 в 14:10
zaak88 Дата: Воскресенье, 27.03.2016, 00:21 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
_Boroda_, krosav4ig, в своём файле не работает данная формула, ума не приложу, что не так.... можете мой посмотреть? оригинал, а не пример... если да то какая у Вас электронка? Спасибо. огромное
[moder]Прочитайте внимательно п5о Правил форума!
Урежьте файл (структуру, как в оригинале оставьте) и кладите сюда.[/moder]

Положил... там наверное из-за дат формула не работает...
К сообщению приложен файл: _-__.xlsx(63Kb)


Сообщение отредактировал zaak88 - Воскресенье, 27.03.2016, 07:59
 
Ответить
Сообщение_Boroda_, krosav4ig, в своём файле не работает данная формула, ума не приложу, что не так.... можете мой посмотреть? оригинал, а не пример... если да то какая у Вас электронка? Спасибо. огромное
[moder]Прочитайте внимательно п5о Правил форума!
Урежьте файл (структуру, как в оригинале оставьте) и кладите сюда.[/moder]

Положил... там наверное из-за дат формула не работает...

Автор - zaak88
Дата добавления - 27.03.2016 в 00:21
Nic70y Дата: Воскресенье, 27.03.2016, 09:04 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
В Вашем файле _-__.xlsx не нашел ни одной формулы :(


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеВ Вашем файле _-__.xlsx не нашел ни одной формулы :(

Автор - Nic70y
Дата добавления - 27.03.2016 в 09:04
zaak88 Дата: Воскресенье, 27.03.2016, 09:24 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Nic70y, при подстановке в файл с оригиналом формулы _Boroda_, с протягиваем на весь массив данных, выдаётся НД, вероятно из-за формата даты в некотрых ячейках (я так думаю)... В первом примерно даты удалил, за что извиняюсь, пример некорректный... Если можете подсказать, буду очень благодарен
 
Ответить
СообщениеNic70y, при подстановке в файл с оригиналом формулы _Boroda_, с протягиваем на весь массив данных, выдаётся НД, вероятно из-за формата даты в некотрых ячейках (я так думаю)... В первом примерно даты удалил, за что извиняюсь, пример некорректный... Если можете подсказать, буду очень благодарен

Автор - zaak88
Дата добавления - 27.03.2016 в 09:24
Pelena Дата: Воскресенье, 27.03.2016, 09:29 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9846
Репутация: 2253 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
из-за формата даты в некотрых ячейках

Скорее из-за пустых ячеек
Может, так подойдет
Код
=ИНДЕКС('Расчет поставки'!B$1:B$52;НАИМЕНЬШИЙ(ЕСЛИ('Расчет поставки'!$F$8:$AB$50<>"";ЕСЛИ('Расчет поставки'!$F$8:$AB$50*('Расчет поставки'!E$6:AA$6=F$3);СТРОКА('Расчет поставки'!B$8:B$50);52);52);A7))&""
К сообщению приложен файл: 7160495.xlsx(59Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
из-за формата даты в некотрых ячейках

Скорее из-за пустых ячеек
Может, так подойдет
Код
=ИНДЕКС('Расчет поставки'!B$1:B$52;НАИМЕНЬШИЙ(ЕСЛИ('Расчет поставки'!$F$8:$AB$50<>"";ЕСЛИ('Расчет поставки'!$F$8:$AB$50*('Расчет поставки'!E$6:AA$6=F$3);СТРОКА('Расчет поставки'!B$8:B$50);52);52);A7))&""

Автор - Pelena
Дата добавления - 27.03.2016 в 09:29
zaak88 Дата: Воскресенье, 27.03.2016, 15:52 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Скорее из-за пустых ячеек
Может, так подойдет

Pelena, попробовал сделать на весь массив... и опять Н/Д.... даже в Вашем файле.... а если оставить как есть не всё захватывает... к примеру меняю номер недели на втором листе на 25 - пусто, а там 7 позиций к поставке... Спасибо Вам за помощь и участие!!!!
 
Ответить
СообщениеСкорее из-за пустых ячеек
Может, так подойдет

Pelena, попробовал сделать на весь массив... и опять Н/Д.... даже в Вашем файле.... а если оставить как есть не всё захватывает... к примеру меняю номер недели на втором листе на 25 - пусто, а там 7 позиций к поставке... Спасибо Вам за помощь и участие!!!!

Автор - zaak88
Дата добавления - 27.03.2016 в 15:52
Pelena Дата: Воскресенье, 27.03.2016, 15:59 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9846
Репутация: 2253 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
А, так это я диапазоны уменьшала для отладки, а потом забыла вернуть
К сообщению приложен файл: 6681661.xlsx(64Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА, так это я диапазоны уменьшала для отладки, а потом забыла вернуть

Автор - Pelena
Дата добавления - 27.03.2016 в 15:59
zaak88 Дата: Воскресенье, 27.03.2016, 15:59 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Pelena, спасибо разобрался!!!! в одном месте массив не протянул на весь! очень Вам благодарен!!!!
[moder]Не надо цитировать пост целиком. Это нарушение Правил форума. Удалила цитату[/moder]


Сообщение отредактировал Pelena - Воскресенье, 27.03.2016, 16:01
 
Ответить
СообщениеPelena, спасибо разобрался!!!! в одном месте массив не протянул на весь! очень Вам благодарен!!!!
[moder]Не надо цитировать пост целиком. Это нарушение Правил форума. Удалила цитату[/moder]

Автор - zaak88
Дата добавления - 27.03.2016 в 15:59
_Boroda_ Дата: Воскресенье, 27.03.2016, 16:48 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
_Boroda_, krosav4ig, в своём файле не работает данная формула

Не мог ответить, занят был.
Вот такие варианты
Подлиньше, но пошустрее (немного изменил подход)
Код
=ИНДЕКС('Расчет поставки'!B$1:B$52;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС('Расчет поставки'!F$8:GN$8;(F$3-'Расчет поставки'!E$6)*10+1):ИНДЕКС('Расчет поставки'!F$50:GN$50;(F$3-'Расчет поставки'!E$6)*10+1);СТРОКА('Расчет поставки'!B$8:B$50);52);A7))&""

Покороче, но позадумчивей (логика аналогична моей предыдущей формуле)
Код
=ИНДЕКС('Расчет поставки'!B$1:B$52;НАИМЕНЬШИЙ(ЕСЛИ(('Расчет поставки'!F$8:GN$50>0)*('Расчет поставки'!$E$6:$GM$6=F$3);СТРОКА('Расчет поставки'!B$8:B$50);52);A7))&""
К сообщению приложен файл: 2204682.xlsx(66Kb) · -2.xlsx(64Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
_Boroda_, krosav4ig, в своём файле не работает данная формула

Не мог ответить, занят был.
Вот такие варианты
Подлиньше, но пошустрее (немного изменил подход)
Код
=ИНДЕКС('Расчет поставки'!B$1:B$52;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС('Расчет поставки'!F$8:GN$8;(F$3-'Расчет поставки'!E$6)*10+1):ИНДЕКС('Расчет поставки'!F$50:GN$50;(F$3-'Расчет поставки'!E$6)*10+1);СТРОКА('Расчет поставки'!B$8:B$50);52);A7))&""

Покороче, но позадумчивей (логика аналогична моей предыдущей формуле)
Код
=ИНДЕКС('Расчет поставки'!B$1:B$52;НАИМЕНЬШИЙ(ЕСЛИ(('Расчет поставки'!F$8:GN$50>0)*('Расчет поставки'!$E$6:$GM$6=F$3);СТРОКА('Расчет поставки'!B$8:B$50);52);A7))&""

Автор - _Boroda_
Дата добавления - 27.03.2016 в 16:48
zaak88 Дата: Воскресенье, 27.03.2016, 18:44 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Pelena, _Boroda_, спасибо огромное Вам!!!! приятно, что есть такие достойные и грамотные люди! удачи во всём!!!!
 
Ответить
СообщениеPelena, _Boroda_, спасибо огромное Вам!!!! приятно, что есть такие достойные и грамотные люди! удачи во всём!!!!

Автор - zaak88
Дата добавления - 27.03.2016 в 18:44
zaak88 Дата: Понедельник, 28.03.2016, 14:59 | Сообщение № 15
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
уважаемые друзья... ещё вопрос возник по данному файлу... в табличке проверка (ячейка T11 и ниже) хочется увидеть потребность в конкретную неделю из первого листа по региону (Курск), соответственно изменив номер недели и регион - получить данные... нужна умная формула... пробовал суммеслимн( индекс( строка))... но не выходит... Спасибо, если кто сможет помочь!!!
[moder]Это уже другой вопрос = новая тема.


Сообщение отредактировал _Boroda_ - Понедельник, 28.03.2016, 15:00
 
Ответить
Сообщениеуважаемые друзья... ещё вопрос возник по данному файлу... в табличке проверка (ячейка T11 и ниже) хочется увидеть потребность в конкретную неделю из первого листа по региону (Курск), соответственно изменив номер недели и регион - получить данные... нужна умная формула... пробовал суммеслимн( индекс( строка))... но не выходит... Спасибо, если кто сможет помочь!!!
[moder]Это уже другой вопрос = новая тема.

Автор - zaak88
Дата добавления - 28.03.2016 в 14:59
zaak88 Дата: Понедельник, 28.03.2016, 15:12 | Сообщение № 16
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Это уже другой вопрос = новая тема.

сделал новую!
 
Ответить
Сообщение
Это уже другой вопрос = новая тема.

сделал новую!

Автор - zaak88
Дата добавления - 28.03.2016 в 15:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подбор списка по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!