Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Условие по времени и по положению в строке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условие по времени и по положению в строке (Формулы/Formulas)
Условие по времени и по положению в строке
IgorStorm Дата: Вторник, 05.04.2016, 21:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Всем добрый вечер. Столкнулся на первый взгляд с простой задачей. Дана строка значений времени по дням и рядом строка формул, возвращающая на основе этих значений числа.
В текущем варианте, если значение времени в массиве равно не пусто- возвращается 1 иначе пусто. Но появилось доп условие - если время в последнем для этой сроки дне более или = 17:00, то нужно вернуть 2. С условием по времени справлюсь. Но как формульно определить что это значение именно последнее в строке?.

Пример приложил.
К сообщению приложен файл: 7288026.xlsx(12Kb)
 
Ответить
СообщениеВсем добрый вечер. Столкнулся на первый взгляд с простой задачей. Дана строка значений времени по дням и рядом строка формул, возвращающая на основе этих значений числа.
В текущем варианте, если значение времени в массиве равно не пусто- возвращается 1 иначе пусто. Но появилось доп условие - если время в последнем для этой сроки дне более или = 17:00, то нужно вернуть 2. С условием по времени справлюсь. Но как формульно определить что это значение именно последнее в строке?.

Пример приложил.

Автор - IgorStorm
Дата добавления - 05.04.2016 в 21:08
_Boroda_ Дата: Вторник, 05.04.2016, 21:30 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9365
Репутация: 3939 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(A2="";"";ЕСЛИ((СЧЁТ(A2:$F2)=1)*(A2>=--"17:");2;1))
К сообщению приложен файл: 7288026_1.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(A2="";"";ЕСЛИ((СЧЁТ(A2:$F2)=1)*(A2>=--"17:");2;1))

Автор - _Boroda_
Дата добавления - 05.04.2016 в 21:30
Pelena Дата: Вторник, 05.04.2016, 21:35 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9857
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Или так
Код
=ЕСЛИ(A2="";"";ЕСЛИ(И(A2>=--"17:00";СУММ(A2:$F2)=A2);2;1))
К сообщению приложен файл: 4882031.xlsx(13Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли так
Код
=ЕСЛИ(A2="";"";ЕСЛИ(И(A2>=--"17:00";СУММ(A2:$F2)=A2);2;1))

Автор - Pelena
Дата добавления - 05.04.2016 в 21:35
IgorStorm Дата: Вторник, 05.04.2016, 21:42 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Совсем не страшно :D Спасибо, огромное! hands
 
Ответить
СообщениеСовсем не страшно :D Спасибо, огромное! hands

Автор - IgorStorm
Дата добавления - 05.04.2016 в 21:42
_Boroda_ Дата: Вторник, 05.04.2016, 22:34 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9365
Репутация: 3939 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Совсем не страшно

Да? А так?
Код
=ТЕКСТ(Ч(A2)+(СЧЁТ(A2:$F2)=1)*Ч(A2);"[>1,291]2;[>]1;")
К сообщению приложен файл: 7288026_2.xlsx(16Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Совсем не страшно

Да? А так?
Код
=ТЕКСТ(Ч(A2)+(СЧЁТ(A2:$F2)=1)*Ч(A2);"[>1,291]2;[>]1;")

Автор - _Boroda_
Дата добавления - 05.04.2016 в 22:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условие по времени и по положению в строке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!