Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение с увелечением на 1 через каждые n-строк? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение с увелечением на 1 через каждые n-строк? (Формулы/Formulas)
Автозаполнение с увелечением на 1 через каждые n-строк?
okyrok Дата: Пятница, 08.04.2016, 15:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть ли штатная возможность подобного действа? Спасибо!

т. е. наподобие
1
1
2
2
3
3


Сообщение отредактировал okyrok - Пятница, 08.04.2016, 15:08
 
Ответить
СообщениеЕсть ли штатная возможность подобного действа? Спасибо!

т. е. наподобие
1
1
2
2
3
3

Автор - okyrok
Дата добавления - 08.04.2016 в 15:07
SLAVICK Дата: Пятница, 08.04.2016, 15:11 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
так?
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$2:A2;A2)<$E$1;A2;A2+1)

и еще вариант - пошустрее:
Код
=ЕСЛИ(ОСТАТ(СТРОКА(B1);$E$1);B2;B2+1)

И еще один - покороче:
Код
=C2+1*(ОСТАТ(СТРОКА(C1);$E$1)=0)

Меняйте зеленую ячейку - и смотрите :D
Начальные индексы - синие ячейки можно менять.
К сообщению приложен файл: 9324214-1-1-.xlsx(9Kb)


Иногда все проще чем кажется с первого взгляда.

Сообщение отредактировал SLAVICK - Пятница, 08.04.2016, 15:27
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$2:A2;A2)<$E$1;A2;A2+1)

и еще вариант - пошустрее:
Код
=ЕСЛИ(ОСТАТ(СТРОКА(B1);$E$1);B2;B2+1)

И еще один - покороче:
Код
=C2+1*(ОСТАТ(СТРОКА(C1);$E$1)=0)

Меняйте зеленую ячейку - и смотрите :D
Начальные индексы - синие ячейки можно менять.

Автор - SLAVICK
Дата добавления - 08.04.2016 в 15:11
_Boroda_ Дата: Пятница, 08.04.2016, 15:17 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ИНДЕКС(СТРОКА(B$1:B1);(СТРОКА(B1)-1)/E$1+1)
К сообщению приложен файл: 9324214_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ИНДЕКС(СТРОКА(B$1:B1);(СТРОКА(B1)-1)/E$1+1)

Автор - _Boroda_
Дата добавления - 08.04.2016 в 15:17
pabchek Дата: Пятница, 08.04.2016, 15:21 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Ну и мой вариант, в файл SLAVICK,
Код
=ОКРВВЕРХ((СТРОКА()-1)/E$1;1)

[p.s.]
И еще один - покороче:

а у меня короче hands


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 08.04.2016, 15:27
 
Ответить
СообщениеНу и мой вариант, в файл SLAVICK,
Код
=ОКРВВЕРХ((СТРОКА()-1)/E$1;1)

[p.s.]
И еще один - покороче:

а у меня короче hands

Автор - pabchek
Дата добавления - 08.04.2016 в 15:21
китин Дата: Пятница, 08.04.2016, 15:45 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как у _Boroda_, только длиннее
Код
=ИНДЕКС(СТРОКА($A$1:$A$1000);ЦЕЛОЕ((СТРОКА(A1)-1)/$A$1)+1)
впрочем как всегда hands


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак у _Boroda_, только длиннее
Код
=ИНДЕКС(СТРОКА($A$1:$A$1000);ЦЕЛОЕ((СТРОКА(A1)-1)/$A$1)+1)
впрочем как всегда hands

Автор - китин
Дата добавления - 08.04.2016 в 15:45
SLAVICK Дата: Пятница, 08.04.2016, 15:47 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
а у меня короче

Зато у меня:
Начальные индексы - синие ячейки можно менять.

А чтобы покороче можно еще и так :D :
Код
=ОТБР((СТРОКА()-2)/$E$1)+1


Иногда все проще чем кажется с первого взгляда.

Сообщение отредактировал SLAVICK - Пятница, 08.04.2016, 15:58
 
Ответить
Сообщение
а у меня короче

Зато у меня:
Начальные индексы - синие ячейки можно менять.

А чтобы покороче можно еще и так :D :
Код
=ОТБР((СТРОКА()-2)/$E$1)+1

Автор - SLAVICK
Дата добавления - 08.04.2016 в 15:47
okyrok Дата: Пятница, 08.04.2016, 15:50 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Загибридил всё в 1 файл. Всем спасибо!
К сообщению приложен файл: zap.xlsx(11Kb)
 
Ответить
СообщениеЗагибридил всё в 1 файл. Всем спасибо!

Автор - okyrok
Дата добавления - 08.04.2016 в 15:50
dima_dan2012 Дата: Пятница, 08.04.2016, 16:29 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 7 ±
Замечаний: 0% ±

Excel 2003,2007
А если нужно получить именно 11 22 33 строго то мне такое придумалось
Код
=(ЕСЛИ(Ч(ЕЧЁТН(СТРОКА()));СТРОКА()/2;(СТРОКА()-1)/2))


Сообщение отредактировал dima_dan2012 - Пятница, 08.04.2016, 16:30
 
Ответить
СообщениеА если нужно получить именно 11 22 33 строго то мне такое придумалось
Код
=(ЕСЛИ(Ч(ЕЧЁТН(СТРОКА()));СТРОКА()/2;(СТРОКА()-1)/2))

Автор - dima_dan2012
Дата добавления - 08.04.2016 в 16:29
Russel Дата: Пятница, 08.04.2016, 16:50 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
А еще можно в первой строке 1, во второй ссылка на первую, в третьей ссылка на вторую +1. Выделить вторую и третью ячейки и растянуть сколько надо. ;)


QIWI 9173973973
 
Ответить
СообщениеА еще можно в первой строке 1, во второй ссылка на первую, в третьей ссылка на вторую +1. Выделить вторую и третью ячейки и растянуть сколько надо. ;)

Автор - Russel
Дата добавления - 08.04.2016 в 16:50
Волхв Дата: Пятница, 08.04.2016, 18:09 | Сообщение № 10
Группа: Заблокированные
Ранг: Участник
Сообщений: 70
Репутация: 3 ±
Замечаний: 100% ±

Excel 2010
=C2+1*(ОСТАТ(СТРОКА(C1);$E$1)=0)


видо изменил

Код
=(ОСТАТ(СТРОКА()+1;2)=0)+A1


Плодить темы - это вообще-то предназначение форума ©Serge_007 админа
 
Ответить
Сообщение
=C2+1*(ОСТАТ(СТРОКА(C1);$E$1)=0)


видо изменил

Код
=(ОСТАТ(СТРОКА()+1;2)=0)+A1

Автор - Волхв
Дата добавления - 08.04.2016 в 18:09
Nic70y Дата: Пятница, 08.04.2016, 18:15 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЦЕЛОЕ((СТРОКА()+1)/2)
наверное %)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЦЕЛОЕ((СТРОКА()+1)/2)
наверное %)

Автор - Nic70y
Дата добавления - 08.04.2016 в 18:15
StoTisteg Дата: Суббота, 09.04.2016, 15:25 | Сообщение № 12
Группа: Авторы
Ранг: Ветеран
Сообщений: 541
Репутация: 45 ±
Замечаний: 0% ±

Excel 2010
а у меня короче hands
[offtop]Только программисты могут мериться не у кого длиннее, а у кого короче :D


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
Сообщение
а у меня короче hands
[offtop]Только программисты могут мериться не у кого длиннее, а у кого короче :D

Автор - StoTisteg
Дата добавления - 09.04.2016 в 15:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение с увелечением на 1 через каждые n-строк? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!