Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка из двух таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка из двух таблиц (Формулы/Formulas)
Выборка из двух таблиц
cavstarica Дата: Воскресенье, 10.04.2016, 20:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, уважаемые форумчане! Помогите решить следующую проблему. Сам мучаюсь со вчерашнего дня. У меня есть 2 таблицы, в которых имеется фио и др человека. Лист 1 в данном случае- он эталонный, он наиболее полный. лист 2-это набивали наши операторы. Так вот, нужно чтобы получился лист номер 3 состоящий из людей из листа 1, которых нет в листе 2. ФИО на листе 1 все заглавные, на листе 2 с большой буквы. Буду очень признателен за помощь!
К сообщению приложен файл: 3997618.xlsx(10Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане! Помогите решить следующую проблему. Сам мучаюсь со вчерашнего дня. У меня есть 2 таблицы, в которых имеется фио и др человека. Лист 1 в данном случае- он эталонный, он наиболее полный. лист 2-это набивали наши операторы. Так вот, нужно чтобы получился лист номер 3 состоящий из людей из листа 1, которых нет в листе 2. ФИО на листе 1 все заглавные, на листе 2 с большой буквы. Буду очень признателен за помощь!

Автор - cavstarica
Дата добавления - 10.04.2016 в 20:18
Pelena Дата: Воскресенье, 10.04.2016, 20:36 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Как вариант в доп. столбец формулу
Код
=СЧЁТЕСЛИМН(Лист2!$A$1:$A$6;A1;Лист2!$B$1:$B$6;B1;Лист2!$C$1:$C$6;C1;Лист2!$D$1:$D$6;D1)

и отфильтровать по критерию 0
К сообщению приложен файл: 6054024.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Как вариант в доп. столбец формулу
Код
=СЧЁТЕСЛИМН(Лист2!$A$1:$A$6;A1;Лист2!$B$1:$B$6;B1;Лист2!$C$1:$C$6;C1;Лист2!$D$1:$D$6;D1)

и отфильтровать по критерию 0

Автор - Pelena
Дата добавления - 10.04.2016 в 20:36
gling Дата: Воскресенье, 10.04.2016, 20:46 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Тоже с доп столбцом. Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$1:A$8;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$E$1:$E$8=0;СТРОКА($E$1:$E$8));СТРОКА()));"")
К сообщению приложен файл: 4199983.xlsx(13Kb)
 
Ответить
СообщениеТоже с доп столбцом. Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$1:A$8;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$E$1:$E$8=0;СТРОКА($E$1:$E$8));СТРОКА()));"")

Автор - gling
Дата добавления - 10.04.2016 в 20:46
StoTisteg Дата: Воскресенье, 10.04.2016, 21:48 | Сообщение № 4
Группа: Авторы
Ранг: Ветеран
Сообщений: 541
Репутация: 45 ±
Замечаний: 0% ±

Excel 2010
Без допстолбцов, но только ищет в первом списке тех, кого нет во втором. Формула тоже массивная.
К сообщению приложен файл: 5719228.xlsx(11Kb)


Проверь всё. ThisWorkbook.Save. On Error Resume Next.
 
Ответить
СообщениеБез допстолбцов, но только ищет в первом списке тех, кого нет во втором. Формула тоже массивная.

Автор - StoTisteg
Дата добавления - 10.04.2016 в 21:48
jakim Дата: Понедельник, 11.04.2016, 00:11 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Без формул массива и дополнительных столбцов, но формула "гигант".
К сообщению приложен файл: 4670764.xlsx(12Kb)


Сообщение отредактировал jakim - Понедельник, 11.04.2016, 00:12
 
Ответить
СообщениеБез формул массива и дополнительных столбцов, но формула "гигант".

Автор - jakim
Дата добавления - 11.04.2016 в 00:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка из двух таблиц (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!