Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Данные из массива по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные из массива по условию (Формулы/Formulas)
Данные из массива по условию
denw Дата: Понедельник, 11.04.2016, 17:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Просьба помочь вытащить данные из массива по условию:

Код
=ЕСЛИ(N2<Лист1!$B$2:$B$21;Лист1!$I$2:$I$21*Лист2!E2;"")


среднее, максимальное и минимальное могу вытащить, а как вытащить просто результат, не могу найти решения.
[moder]В файле покажите. И пример нужного результата тоже.


Сообщение отредактировал _Boroda_ - Понедельник, 11.04.2016, 17:52
 
Ответить
СообщениеДобрый день!
Просьба помочь вытащить данные из массива по условию:

Код
=ЕСЛИ(N2<Лист1!$B$2:$B$21;Лист1!$I$2:$I$21*Лист2!E2;"")


среднее, максимальное и минимальное могу вытащить, а как вытащить просто результат, не могу найти решения.
[moder]В файле покажите. И пример нужного результата тоже.

Автор - denw
Дата добавления - 11.04.2016 в 17:48
_Boroda_ Дата: Понедельник, 11.04.2016, 17:57 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
среднее, максимальное и минимальное
- это функции агрегирования - они что-то делают с массивом данных и выводят в одно (чаще всего) значение.
А если Вам нужно данные по условию, то что-то примерно вот так (без файла, как я уже писал в комментарии выше) не совсем ясно, что же Вам нужно
Код
=ЕСЛИ(N2<Лист1!B2;Лист1!I2*E2;"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
среднее, максимальное и минимальное
- это функции агрегирования - они что-то делают с массивом данных и выводят в одно (чаще всего) значение.
А если Вам нужно данные по условию, то что-то примерно вот так (без файла, как я уже писал в комментарии выше) не совсем ясно, что же Вам нужно
Код
=ЕСЛИ(N2<Лист1!B2;Лист1!I2*E2;"")

Автор - _Boroda_
Дата добавления - 11.04.2016 в 17:57
denw Дата: Понедельник, 11.04.2016, 18:03 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да, понял что без примера не обойтись, выкладываю пример.
К сообщению приложен файл: 2000253.xlsx(14Kb)
 
Ответить
СообщениеДа, понял что без примера не обойтись, выкладываю пример.

Автор - denw
Дата добавления - 11.04.2016 в 18:03
Karataev Дата: Понедельник, 11.04.2016, 18:28 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 643
Репутация: 227 ±
Замечаний: 0% ±

Excel
формул массива (вводится Ctrl+Shift+Enter) для E2
Код
=A2*ИНДЕКС($K$2:$K$21;ПОИСКПОЗ(ИСТИНА;$J$2:$J$21>C2;0))

Только у меня формула не учитывает, если C2 = какое-то значение в столбце J. В этом случае нужно брать значение в найденной строке или в следующей строке? Сейчас формула берет в следующей строке.




Сообщение отредактировал Karataev - Понедельник, 11.04.2016, 21:12
 
Ответить
Сообщениеформул массива (вводится Ctrl+Shift+Enter) для E2
Код
=A2*ИНДЕКС($K$2:$K$21;ПОИСКПОЗ(ИСТИНА;$J$2:$J$21>C2;0))

Только у меня формула не учитывает, если C2 = какое-то значение в столбце J. В этом случае нужно брать значение в найденной строке или в следующей строке? Сейчас формула берет в следующей строке.

Автор - Karataev
Дата добавления - 11.04.2016 в 18:28
Pelena Дата: Понедельник, 11.04.2016, 18:44 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
А если можно отсортировать диапазон отклонения по убыванию, то можно обычной формулой
Код
=A2*ИНДЕКС($K$2:$K$21;ПОИСКПОЗ(C2;$J$2:$J$21;-1))
К сообщению приложен файл: 3259739.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА если можно отсортировать диапазон отклонения по убыванию, то можно обычной формулой
Код
=A2*ИНДЕКС($K$2:$K$21;ПОИСКПОЗ(C2;$J$2:$J$21;-1))

Автор - Pelena
Дата добавления - 11.04.2016 в 18:44
_Boroda_ Дата: Понедельник, 11.04.2016, 19:24 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно без пересортировки немассивной формулой
Код
=A2*ИНДЕКС(K$2:K$21;СЧЁТЕСЛИ(J$2:J$21;"<="&C2)+1)
К сообщению приложен файл: 2000253_1.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно без пересортировки немассивной формулой
Код
=A2*ИНДЕКС(K$2:K$21;СЧЁТЕСЛИ(J$2:J$21;"<="&C2)+1)

Автор - _Boroda_
Дата добавления - 11.04.2016 в 19:24
denw Дата: Вторник, 12.04.2016, 07:26 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Благодарю за помощь! Очень помогли.
 
Ответить
СообщениеБлагодарю за помощь! Очень помогли.

Автор - denw
Дата добавления - 12.04.2016 в 07:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Данные из массива по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!