Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/"Связь" между вкладками - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » "Связь" между вкладками (Формулы/Formulas)
"Связь" между вкладками
stroika Дата: Вторник, 12.04.2016, 01:41 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Есть книга, в ней 2 вкладки. 1-вкладка постоянно заполняется вручную ( в ней куча столбцов и строк) и потом автоматически сливается с вордом. 2-вкладка заполняется вручную частично. Необходимо, чтобы при заполнении 1-вкладки, Столбец (Н) автоматически копировался на 2-вкладку в Столбец (В), (чтобы не заполнять вручную хотя бы его). Заранее спасибо.
К сообщению приложен файл: 0945711.xlsx(13Kb)


Сообщение отредактировал stroika - Вторник, 12.04.2016, 02:16
 
Ответить
СообщениеЗдравствуйте. Есть книга, в ней 2 вкладки. 1-вкладка постоянно заполняется вручную ( в ней куча столбцов и строк) и потом автоматически сливается с вордом. 2-вкладка заполняется вручную частично. Необходимо, чтобы при заполнении 1-вкладки, Столбец (Н) автоматически копировался на 2-вкладку в Столбец (В), (чтобы не заполнять вручную хотя бы его). Заранее спасибо.

Автор - stroika
Дата добавления - 12.04.2016 в 01:41
buchlotnik Дата: Вторник, 12.04.2016, 02:35 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так что ли?
Код
=ЕСЛИ(ЕТЕКСТ('1-Вкладка'!H2);'1-Вкладка'!H2;"")
К сообщению приложен файл: 6284739.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак что ли?
Код
=ЕСЛИ(ЕТЕКСТ('1-Вкладка'!H2);'1-Вкладка'!H2;"")

Автор - buchlotnik
Дата добавления - 12.04.2016 в 02:35
stroika Дата: Вторник, 12.04.2016, 02:38 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. Только хотела править вопрос))) Очень помогли с формулой ЕСЛИ. То что доктор прописал.
 
Ответить
СообщениеСпасибо. Только хотела править вопрос))) Очень помогли с формулой ЕСЛИ. То что доктор прописал.

Автор - stroika
Дата добавления - 12.04.2016 в 02:38
buchlotnik Дата: Вторник, 12.04.2016, 02:50 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
кстати, можно просто
Код
='1-Вкладка'!H2
а нули форматом убрать
К сообщению приложен файл: 0945711-1-.xlsx(13Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениекстати, можно просто
Код
='1-Вкладка'!H2
а нули форматом убрать

Автор - buchlotnik
Дата добавления - 12.04.2016 в 02:50
stroika Дата: Вторник, 12.04.2016, 03:03 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Извиняюсь и прошу опять помощи. Эта формула ((((
Код
=ЕСЛИ(ЕТЕКСТ('1-Вкладка'!H2);'1-Вкладка'!H2;"")
Просто замечательная, но теперь возник новый тупик. На 2-Вкладка есть столбец "Дата оформления акта" (Столбец (D)), можно ли как то связать этот столбец (D) с тремя столбцами (P. Q. R) находящихся на 1-Вкладке, но предварительно как-то их сцепить что -ли?
Т.е. на 2-Вкладка в Столбце (D) должна получиться дата собранная из трех столбцов (P. Q. R) находящихся на 1-Вкладка. И не важно как в итоге столбец (D) будет выглядеть в итоге : 09 марта 2016 или 09/04/2016.

Спасибо. Может хоть кто то сможет ответить.


Сообщение отредактировал Manyasha - Вторник, 12.04.2016, 10:18
 
Ответить
СообщениеИзвиняюсь и прошу опять помощи. Эта формула ((((
Код
=ЕСЛИ(ЕТЕКСТ('1-Вкладка'!H2);'1-Вкладка'!H2;"")
Просто замечательная, но теперь возник новый тупик. На 2-Вкладка есть столбец "Дата оформления акта" (Столбец (D)), можно ли как то связать этот столбец (D) с тремя столбцами (P. Q. R) находящихся на 1-Вкладке, но предварительно как-то их сцепить что -ли?
Т.е. на 2-Вкладка в Столбце (D) должна получиться дата собранная из трех столбцов (P. Q. R) находящихся на 1-Вкладка. И не важно как в итоге столбец (D) будет выглядеть в итоге : 09 марта 2016 или 09/04/2016.

Спасибо. Может хоть кто то сможет ответить.

Автор - stroika
Дата добавления - 12.04.2016 в 03:03
китин Дата: Вторник, 12.04.2016, 07:17 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну как то так
Код
=ИНДЕКС('1-Вкладка'!$P$2:$P$12&" "&'1-Вкладка'!$Q$2:$Q$12&" "&'1-Вкладка'!$R$2:$R$12;ПОИСКПОЗ('2-Вкладка'!$B4;'1-Вкладка'!$H$2:$H$12;0))

[p.s.]это если данная дата не будет использоваться в дальнейших расчетах. Если она нужна как число, то будет посложнее малость
[p.s.]и плизззз оформляйте коды тэгами. ну не видать же ничего killed
К сообщению приложен файл: data.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 12.04.2016, 07:39
 
Ответить
Сообщениену как то так
Код
=ИНДЕКС('1-Вкладка'!$P$2:$P$12&" "&'1-Вкладка'!$Q$2:$Q$12&" "&'1-Вкладка'!$R$2:$R$12;ПОИСКПОЗ('2-Вкладка'!$B4;'1-Вкладка'!$H$2:$H$12;0))

[p.s.]это если данная дата не будет использоваться в дальнейших расчетах. Если она нужна как число, то будет посложнее малость
[p.s.]и плизззз оформляйте коды тэгами. ну не видать же ничего killed

Автор - китин
Дата добавления - 12.04.2016 в 07:17
stroika Дата: Вторник, 12.04.2016, 13:52 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. Никогда не видела такой формулы с использованием ИНДЕКС и ПОИСКПОЗ, вообще думала, что эта задача решалось бы через СЦЕПИТЬ и ТЕКСТ, а потом уже перебрасывалась бы на вторую (конечную) вкладку с использованием формулы которой поделился ответчик buchlotnik. Да, и Вы правы, данная дата в дальнейшем использоваться не будет, только распечатываться))) (Я бы и рада поместить формулу красиво тэгам, но я не нашла как Вы это все делаете(( Сори)))))
[moder]В Правилах написано. В п3 есть ссылка с инструкцией.[/moder]


Сообщение отредактировал Manyasha - Вторник, 12.04.2016, 13:57
 
Ответить
СообщениеСпасибо. Никогда не видела такой формулы с использованием ИНДЕКС и ПОИСКПОЗ, вообще думала, что эта задача решалось бы через СЦЕПИТЬ и ТЕКСТ, а потом уже перебрасывалась бы на вторую (конечную) вкладку с использованием формулы которой поделился ответчик buchlotnik. Да, и Вы правы, данная дата в дальнейшем использоваться не будет, только распечатываться))) (Я бы и рада поместить формулу красиво тэгам, но я не нашла как Вы это все делаете(( Сори)))))
[moder]В Правилах написано. В п3 есть ссылка с инструкцией.[/moder]

Автор - stroika
Дата добавления - 12.04.2016 в 13:52
758945 Дата: Четверг, 14.04.2016, 14:45 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
почему не работает формула
Код
=ЕСЛИ(ЕТЕКСТ('1-Вкладка'!H2);'1-Вкладка'!H2;"")

[moder]Оформляйте формулу тегом Fx. На первый раз поправил за Вас.
И что это за вопрос?
Вложите файл - пример.[/moder]


Сообщение отредактировал SLAVICK - Четверг, 14.04.2016, 15:41
 
Ответить
СообщениеДобрый день.
почему не работает формула
Код
=ЕСЛИ(ЕТЕКСТ('1-Вкладка'!H2);'1-Вкладка'!H2;"")

[moder]Оформляйте формулу тегом Fx. На первый раз поправил за Вас.
И что это за вопрос?
Вложите файл - пример.[/moder]

Автор - 758945
Дата добавления - 14.04.2016 в 14:45
китин Дата: Четверг, 14.04.2016, 14:46 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
потому что
и плизззз оформляйте коды тэгами. ну не видать же ничего

и
Модератор:
В Правилах написано. В п3 есть ссылка с инструкцией.


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениепотому что
и плизззз оформляйте коды тэгами. ну не видать же ничего

и
Модератор:
В Правилах написано. В п3 есть ссылка с инструкцией.

Автор - китин
Дата добавления - 14.04.2016 в 14:46
758945 Дата: Четверг, 14.04.2016, 16:52 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Мне необходимо что бы на листе сравнение в столбце "наименование" C13 прописывался текст автоматически когда его набираешь в листе netlab в столбце "наименование" C13 т.к ассортимент большой и не хочется его по десять раз набирать вручную
[moder]Раз уж Вы влезли в чужую тему с якобы уточняющим вопросом, то и файл должен быть из этой темы. если вопрос касается другого файла, то идите читать Правила форума.
К сообщению приложен файл: 11111111.xlsx(51Kb)


Сообщение отредактировал _Boroda_ - Четверг, 14.04.2016, 17:03
 
Ответить
СообщениеМне необходимо что бы на листе сравнение в столбце "наименование" C13 прописывался текст автоматически когда его набираешь в листе netlab в столбце "наименование" C13 т.к ассортимент большой и не хочется его по десять раз набирать вручную
[moder]Раз уж Вы влезли в чужую тему с якобы уточняющим вопросом, то и файл должен быть из этой темы. если вопрос касается другого файла, то идите читать Правила форума.

Автор - 758945
Дата добавления - 14.04.2016 в 16:52
buchlotnik Дата: Четверг, 14.04.2016, 17:04 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ну и что у вас не работает? удалено администрацией, ибо нефиг


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал _Boroda_ - Четверг, 14.04.2016, 17:07
 
Ответить
Сообщениену и что у вас не работает? удалено администрацией, ибо нефиг

Автор - buchlotnik
Дата добавления - 14.04.2016 в 17:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » "Связь" между вкладками (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!