Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос строк таблицы на другой лист при выполнении условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос строк таблицы на другой лист при выполнении условия (Формулы/Formulas)
Перенос строк таблицы на другой лист при выполнении условия
gree Дата: Среда, 13.04.2016, 13:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем привет! В файле создана основная таблица с графиками работы павильонов, необходимо во второй вкладке сделать сводную таблицу с условием если ячейка B4 в первой таблице имеет значение, то вся эта строка переносится в таблицу на второй вкладке. Пример на картинке) Думаю что можно через функцию "если" но самостоятельно реализовать свою я не могу)) (если $B4 не равно 0 тогда строка 4 копируется в лист 2, при этом следующее копирование будет происходить уже на строку ниже)
К сообщению приложен файл: 5757822.xlsx(10Kb)


Сообщение отредактировал Manyasha - Среда, 13.04.2016, 13:17
 
Ответить
СообщениеВсем привет! В файле создана основная таблица с графиками работы павильонов, необходимо во второй вкладке сделать сводную таблицу с условием если ячейка B4 в первой таблице имеет значение, то вся эта строка переносится в таблицу на второй вкладке. Пример на картинке) Думаю что можно через функцию "если" но самостоятельно реализовать свою я не могу)) (если $B4 не равно 0 тогда строка 4 копируется в лист 2, при этом следующее копирование будет происходить уже на строку ниже)

Автор - gree
Дата добавления - 13.04.2016 в 13:07
Russel Дата: Среда, 13.04.2016, 13:17 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
Фильтром выбирать только заполненные строки.


QIWI 9173973973
 
Ответить
СообщениеФильтром выбирать только заполненные строки.

Автор - Russel
Дата добавления - 13.04.2016 в 13:17
Manyasha Дата: Среда, 13.04.2016, 13:53 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1590
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
gree, можно формулой (массивная, вводить через ctrl+shift+enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС('Весь список'!A$2:A$100;НАИМЕНЬШИЙ(ЕСЛИ('Весь список'!$B$2:$B$100<>"";СТРОКА('Весь список'!$B$2:$B$100)-1;"");СТРОКА(A1)));"")


А можно сводной таблицей (на 2-м листе) с фильтром по времени открытия
К сообщению приложен файл: 5757822-1.xlsx(16Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеgree, можно формулой (массивная, вводить через ctrl+shift+enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС('Весь список'!A$2:A$100;НАИМЕНЬШИЙ(ЕСЛИ('Весь список'!$B$2:$B$100<>"";СТРОКА('Весь список'!$B$2:$B$100)-1;"");СТРОКА(A1)));"")


А можно сводной таблицей (на 2-м листе) с фильтром по времени открытия

Автор - Manyasha
Дата добавления - 13.04.2016 в 13:53
jakim Дата: Среда, 13.04.2016, 16:21 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Вариант без формул массива.
К сообщению приложен файл: 1653331.xlsx(11Kb)
 
Ответить
Сообщение
Вариант без формул массива.

Автор - jakim
Дата добавления - 13.04.2016 в 16:21
gree Дата: Четверг, 14.04.2016, 09:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
всем большое спасибо за помощь и ответы :)
 
Ответить
Сообщениевсем большое спасибо за помощь и ответы :)

Автор - gree
Дата добавления - 14.04.2016 в 09:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос строк таблицы на другой лист при выполнении условия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!