Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ссылка на ячейки при сортировке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на ячейки при сортировке (Формулы/Formulas)
Ссылка на ячейки при сортировке
Lunnuk_S Дата: Среда, 13.04.2016, 17:35 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый День! Помогите пожалуйста с проблемой. Во вложеном файле есть лист "Объекты" и "Ведомость зарплаты". Как мне скопировать название обьекта и адрес (ячейка X3 и ячейка Y3) с листа объекты в лист Ведомость зарплаты ( ячейка A10 и ячейка K10 соответственно) формулой. чтобы при сортирове по возрастанию и убыванию листа обьекты, в листе ведомость зарплаты оставались прежние названия.
Пробовал через формулу ='ОБ''ЄКТИ'!X3 значения меняются при сортировке листа объекты.
Такое решение нужно потому что в последующем будет несколько книг в которых должно соответствовать название и адрес объекта, которое может менятся в процессе работы.
Сложность заключается не в лени скопировать названия, а в том чтобы при сортировке листа объкты по мере выполнении объектов я видел в листе ведомость зарплаты по какому ето объекту.
Заранее буду очень благодарен за любую помощь.
К сообщению приложен файл: 3954696.xlsx(46Kb)
 
Ответить
СообщениеДобрый День! Помогите пожалуйста с проблемой. Во вложеном файле есть лист "Объекты" и "Ведомость зарплаты". Как мне скопировать название обьекта и адрес (ячейка X3 и ячейка Y3) с листа объекты в лист Ведомость зарплаты ( ячейка A10 и ячейка K10 соответственно) формулой. чтобы при сортирове по возрастанию и убыванию листа обьекты, в листе ведомость зарплаты оставались прежние названия.
Пробовал через формулу ='ОБ''ЄКТИ'!X3 значения меняются при сортировке листа объекты.
Такое решение нужно потому что в последующем будет несколько книг в которых должно соответствовать название и адрес объекта, которое может менятся в процессе работы.
Сложность заключается не в лени скопировать названия, а в том чтобы при сортировке листа объкты по мере выполнении объектов я видел в листе ведомость зарплаты по какому ето объекту.
Заранее буду очень благодарен за любую помощь.

Автор - Lunnuk_S
Дата добавления - 13.04.2016 в 17:35
Manyasha Дата: Среда, 13.04.2016, 17:57 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
Lunnuk_S, можно так:
Код
=ВПР(1;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)
К сообщению приложен файл: 3954696-1.xlsx(48Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеLunnuk_S, можно так:
Код
=ВПР(1;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)

Автор - Manyasha
Дата добавления - 13.04.2016 в 17:57
Lunnuk_S Дата: Четверг, 14.04.2016, 10:57 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо! Чтобы я без Вас делал)))
 
Ответить
СообщениеСпасибо! Чтобы я без Вас делал)))

Автор - Lunnuk_S
Дата добавления - 14.04.2016 в 10:57
Lunnuk_S Дата: Пятница, 06.05.2016, 13:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Manyasha, Добрый день! Спасибо за предыдущую помощь! Хотел в продолжение этой темы спросить:
Код
=ВПР(1;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)
можно ли как нибудь протягивать эту формулу (в листе отчет выделенное красным) чтобы в каждой не менять 1,2,3...?
[moder]Исправляйте свой пост согласно п.3 Правил форума в части тегов[/moder][moder]Исправлено
К сообщению приложен файл: 0631439.xlsx(47Kb)


Сообщение отредактировал Lunnuk_S - Пятница, 06.05.2016, 15:44
 
Ответить
СообщениеManyasha, Добрый день! Спасибо за предыдущую помощь! Хотел в продолжение этой темы спросить:
Код
=ВПР(1;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)
можно ли как нибудь протягивать эту формулу (в листе отчет выделенное красным) чтобы в каждой не менять 1,2,3...?
[moder]Исправляйте свой пост согласно п.3 Правил форума в части тегов[/moder][moder]Исправлено

Автор - Lunnuk_S
Дата добавления - 06.05.2016 в 13:50
_Boroda_ Дата: Пятница, 06.05.2016, 15:37 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9822
Репутация: 4147 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ВПР(O6;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)
К сообщению приложен файл: 3954696-1_.xlsx(47Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ВПР(O6;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)

Автор - _Boroda_
Дата добавления - 06.05.2016 в 15:37
Lunnuk_S Дата: Пятница, 06.05.2016, 16:02 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, Немножко не то. Мне нужно такую хитрость сделать в листе отчет то что выделенное красным во вложенном файле.
К сообщению приложен файл: 8242839.xlsx(47Kb)
 
Ответить
Сообщение_Boroda_, Немножко не то. Мне нужно такую хитрость сделать в листе отчет то что выделенное красным во вложенном файле.

Автор - Lunnuk_S
Дата добавления - 06.05.2016 в 16:02
_Boroda_ Дата: Пятница, 06.05.2016, 16:08 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9822
Репутация: 4147 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Аналогично
Код
=ВПР(A4;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)

Код
=ВПР(строка(A1);'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)
К сообщению приложен файл: 8242839_1.xlsx(47Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАналогично
Код
=ВПР(A4;'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)

Код
=ВПР(строка(A1);'ОБ''ЄКТИ'!$A$3:$Y$5;24;0)

Автор - _Boroda_
Дата добавления - 06.05.2016 в 16:08
Lunnuk_S Дата: Пятница, 06.05.2016, 16:14 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, То что надо!!! Премного благодарен!!!
 
Ответить
Сообщение_Boroda_, То что надо!!! Премного благодарен!!!

Автор - Lunnuk_S
Дата добавления - 06.05.2016 в 16:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на ячейки при сортировке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!