Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматический ввод месяца по месяцу в другой ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический ввод месяца по месяцу в другой ячейке (Формулы/Formulas)
Автоматический ввод месяца по месяцу в другой ячейке
Nikolay86 Дата: Пятница, 15.04.2016, 08:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
В примере в ячейке А2 указан месяц (январь). Возможно ли реализовать, чтобы в ячейке D2, например, появлялся следующий месяц (типа "=январь+1", выводит февраль) и т.д.? Спасибо.
К сообщению приложен файл: primer.xlsx(9Kb)
 
Ответить
СообщениеВ примере в ячейке А2 указан месяц (январь). Возможно ли реализовать, чтобы в ячейке D2, например, появлялся следующий месяц (типа "=январь+1", выводит февраль) и т.д.? Спасибо.

Автор - Nikolay86
Дата добавления - 15.04.2016 в 08:41
китин Дата: Пятница, 15.04.2016, 08:51 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
если месяца идут по порядку можно так
Код
=ИНДЕКС($A$2:$A$11;СТРОКА(A1)+1)

и в качестве извращения :D месяца могут иттить как хотят =
Код
ТЕКСТ(ВПР(A2;{"январь";"01.01.2016":"февраль";"01.02.2016":"март";"01.03.2016":"апрель";"01.04.2016":"май";"01.05.2016":"июнь";"01.06.2016":"июль";"01.07.2016":"август";"01.08.2016":"сентябрь";"01.09.2016":"октябрь";"01.10.2016":"ноябрь";"01.11.2016":"декабрь";"01.12.2016"};2;0)+40;"ММММ")
К сообщению приложен файл: 9627910.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 15.04.2016, 09:04
 
Ответить
Сообщениеесли месяца идут по порядку можно так
Код
=ИНДЕКС($A$2:$A$11;СТРОКА(A1)+1)

и в качестве извращения :D месяца могут иттить как хотят =
Код
ТЕКСТ(ВПР(A2;{"январь";"01.01.2016":"февраль";"01.02.2016":"март";"01.03.2016":"апрель";"01.04.2016":"май";"01.05.2016":"июнь";"01.06.2016":"июль";"01.07.2016":"август";"01.08.2016":"сентябрь";"01.09.2016":"октябрь";"01.10.2016":"ноябрь";"01.11.2016":"декабрь";"01.12.2016"};2;0)+40;"ММММ")

Автор - китин
Дата добавления - 15.04.2016 в 08:51
Che79 Дата: Пятница, 15.04.2016, 08:54 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
Nikolay86, некогда переключаться с Linuxa на Винду, попробуйте например так для D2:
Код
=ТЕКСТ(A2+1;"ММММ")

файл не смотрел и неправильно сделал pray


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 15.04.2016, 13:57
 
Ответить
СообщениеNikolay86, некогда переключаться с Linuxa на Винду, попробуйте например так для D2:
Код
=ТЕКСТ(A2+1;"ММММ")

файл не смотрел и неправильно сделал pray

Автор - Che79
Дата добавления - 15.04.2016 в 08:54
Pelena Дата: Пятница, 15.04.2016, 08:57 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9867
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант
Код
=ТЕКСТ(ДАТАМЕС(1&A2;1);"ММММ")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант
Код
=ТЕКСТ(ДАТАМЕС(1&A2;1);"ММММ")

Автор - Pelena
Дата добавления - 15.04.2016 в 08:57
китин Дата: Пятница, 15.04.2016, 09:09 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Ещё вариант

1 сцепленная с текстом месяца(январь) дает дату в числовом формате???? честно не знал %)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Ещё вариант

1 сцепленная с текстом месяца(январь) дает дату в числовом формате???? честно не знал %)

Автор - китин
Дата добавления - 15.04.2016 в 09:09
_Boroda_ Дата: Пятница, 15.04.2016, 09:10 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну и еще
Код
=ТЕКСТ((28&A2)+9;"ММММ")

или
Код
=(1&A2)+31
и формат ячеек ММММ
1 сцепленная с текстом месяца(январь) дает дату в числовом формате

Не только один. Любое число, день которого существует. Причем год - по умолчанию текущий
Например, 28&. А вот 29& уже не всегда прокатит - фавраль
К сообщению приложен файл: 7892786.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу и еще
Код
=ТЕКСТ((28&A2)+9;"ММММ")

или
Код
=(1&A2)+31
и формат ячеек ММММ
1 сцепленная с текстом месяца(январь) дает дату в числовом формате

Не только один. Любое число, день которого существует. Причем год - по умолчанию текущий
Например, 28&. А вот 29& уже не всегда прокатит - фавраль

Автор - _Boroda_
Дата добавления - 15.04.2016 в 09:10
китин Дата: Пятница, 15.04.2016, 09:11 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Che79, Алексей
файл не смотрел
а зря.там месяц букавками написан :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 15.04.2016, 09:11
 
Ответить
СообщениеChe79, Алексей
файл не смотрел
а зря.там месяц букавками написан :D

Автор - китин
Дата добавления - 15.04.2016 в 09:11
Nikolay86 Дата: Пятница, 15.04.2016, 10:54 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Работают многие варианты, выбрал этот:
=ТЕКСТ(ДАТАМЕС(1&A2;1);"ММММ")

Понравился. Спасибо.
 
Ответить
СообщениеРаботают многие варианты, выбрал этот:
=ТЕКСТ(ДАТАМЕС(1&A2;1);"ММММ")

Понравился. Спасибо.

Автор - Nikolay86
Дата добавления - 15.04.2016 в 10:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический ввод месяца по месяцу в другой ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!