Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение ячейки с диапазоном - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение ячейки с диапазоном (Формулы/Formulas)
Сравнение ячейки с диапазоном
denisq Дата: Вторник, 19.04.2016, 11:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Уважаемые, прошу помощи. Покажу на конкретном примере

1.Нужно сравнить каждую ячейку из столбца A со столбцом E и при совпадении поставить в столбец B соответсвующее значение из столбца F, а если совпадение не найдено, то как-нибудь написать.
2.По возможности очень прошу помочь решить проблему: сравнивать значения из столбца A со значениями со столбца B должно без учета знаков - + , ! .
К сообщению приложен файл: 6073720.xlsx(10Kb)


Сообщение отредактировал denisq - Вторник, 19.04.2016, 11:11
 
Ответить
СообщениеУважаемые, прошу помощи. Покажу на конкретном примере

1.Нужно сравнить каждую ячейку из столбца A со столбцом E и при совпадении поставить в столбец B соответсвующее значение из столбца F, а если совпадение не найдено, то как-нибудь написать.
2.По возможности очень прошу помочь решить проблему: сравнивать значения из столбца A со значениями со столбца B должно без учета знаков - + , ! .

Автор - denisq
Дата добавления - 19.04.2016 в 11:09
Nic70y Дата: Вторник, 19.04.2016, 11:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
так надо?
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(A2;" ";"*");E$2:F$13;2;);"")
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;" ";"*");"-";"*");"+";"*");"!";"*");E$2:F$13;2;);"")
К сообщению приложен файл: 8885982.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 19.04.2016, 11:21
 
Ответить
Сообщениетак надо?
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(A2;" ";"*");E$2:F$13;2;);"")
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;" ";"*");"-";"*");"+";"*");"!";"*");E$2:F$13;2;);"")

Автор - Nic70y
Дата добавления - 19.04.2016 в 11:16
denisq Дата: Вторник, 19.04.2016, 11:52 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, Да, практически то, что нужно. Я немного видоизменил пример, добавив разные варианты "из жизни" и выделил цветом для наглядности:
1. Не сравнивает название "AdvoCam FD8 Black" с "AdvoCam FD-8 Black" (т.е. я так понял когда перед цифрой стоит знак)
2. Возможно ли сравнить "AdvoCam FD8 Profi Blue" с "AdvoCam FD8 BLUE" (т.е. когда добавлено слово)
3. Возможно ли сравнить "AdvoCam FD8 GPS Blue" с "AdvoCam FD8 BLUE GPS" (т.е. когда слова местами переставлены)
К сообщению приложен файл: 8885982-3-.xlsx(10Kb)
 
Ответить
СообщениеNic70y, Да, практически то, что нужно. Я немного видоизменил пример, добавив разные варианты "из жизни" и выделил цветом для наглядности:
1. Не сравнивает название "AdvoCam FD8 Black" с "AdvoCam FD-8 Black" (т.е. я так понял когда перед цифрой стоит знак)
2. Возможно ли сравнить "AdvoCam FD8 Profi Blue" с "AdvoCam FD8 BLUE" (т.е. когда добавлено слово)
3. Возможно ли сравнить "AdvoCam FD8 GPS Blue" с "AdvoCam FD8 BLUE GPS" (т.е. когда слова местами переставлены)

Автор - denisq
Дата добавления - 19.04.2016 в 11:52
китин Дата: Вторник, 19.04.2016, 12:12 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Почитайте эту тему Это в случае
когда слова местами переставлены

когда добавлено слово


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеПочитайте эту тему Это в случае
когда слова местами переставлены

когда добавлено слово

Автор - китин
Дата добавления - 19.04.2016 в 12:12
denisq Дата: Вторник, 19.04.2016, 12:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, спасибо, но пока что это сложноватый вариант, я думал, что найдется что-то попроще

Осталась проблема:
1. Не сравнивает название "AdvoCam FD8 Black" с "AdvoCam FD-8 Black" (т.е. я так понял когда перед цифрой стоит знак)
 
Ответить
Сообщениекитин, спасибо, но пока что это сложноватый вариант, я думал, что найдется что-то попроще

Осталась проблема:
1. Не сравнивает название "AdvoCam FD8 Black" с "AdvoCam FD-8 Black" (т.е. я так понял когда перед цифрой стоит знак)

Автор - denisq
Дата добавления - 19.04.2016 в 12:29
_Boroda_ Дата: Вторник, 19.04.2016, 12:35 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
AdvoCam FD8 Black" с "AdvoCam FD-8 Black"

Так нужно? Попаразитировал на формуле Николая
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;" ";"*");"-";"*");"+";"*");"!";"*");ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(E$2:F$13;" ";);"-";);"+";);"!";);2;);"")

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: 8885982-3-1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
AdvoCam FD8 Black" с "AdvoCam FD-8 Black"

Так нужно? Попаразитировал на формуле Николая
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;" ";"*");"-";"*");"+";"*");"!";"*");ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(E$2:F$13;" ";);"-";);"+";);"!";);2;);"")

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 19.04.2016 в 12:35
denisq Дата: Вторник, 19.04.2016, 13:09 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо, то, что нужно
Заметил еще одну проблему, в файле выделил желтым цветом
При сравнении "AdvoCam FD Black" и "AdvoCam-FD Black Распродажа" ставит значение, соответсвующее "AdvoCam FD-8 Black"
К сообщению приложен файл: 1974655.xlsx(11Kb)
 
Ответить
Сообщение_Boroda_, спасибо, то, что нужно
Заметил еще одну проблему, в файле выделил желтым цветом
При сравнении "AdvoCam FD Black" и "AdvoCam-FD Black Распродажа" ставит значение, соответсвующее "AdvoCam FD-8 Black"

Автор - denisq
Дата добавления - 19.04.2016 в 13:09
AlexM Дата: Вторник, 19.04.2016, 13:31 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

В формулу Александра добавьте &"*"
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;" ";"*");"-";"*");"+";"*");"!";"*")&"*";ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(E$2:F$13;" ";);"-";);"+";);"!";);2;);"")

PS. Внутри функции ПОДСТАВИТЬ() можно убрать "*"


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 19.04.2016, 13:37
 
Ответить
СообщениеВ формулу Александра добавьте &"*"
Код
=ЕСЛИОШИБКА(ВПР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;" ";"*");"-";"*");"+";"*");"!";"*")&"*";ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(E$2:F$13;" ";);"-";);"+";);"!";);2;);"")

PS. Внутри функции ПОДСТАВИТЬ() можно убрать "*"

Автор - AlexM
Дата добавления - 19.04.2016 в 13:31
denisq Дата: Вторник, 19.04.2016, 14:13 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
AlexM, да, спасибо, вроде все работает.
пока что буду проверять в ручную, наверняка еще проблемы вылезут
[moder]При Вашем раскладе по-любому 100% верно формулами у Вас не получится. Обязательно будет шанс на ошибку.


Сообщение отредактировал _Boroda_ - Вторник, 19.04.2016, 14:17
 
Ответить
СообщениеAlexM, да, спасибо, вроде все работает.
пока что буду проверять в ручную, наверняка еще проблемы вылезут
[moder]При Вашем раскладе по-любому 100% верно формулами у Вас не получится. Обязательно будет шанс на ошибку.

Автор - denisq
Дата добавления - 19.04.2016 в 14:13
AlexM Дата: Вторник, 19.04.2016, 15:33 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Вариант с функцией
К сообщению приложен файл: 1974655_1.xls(37Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВариант с функцией

Автор - AlexM
Дата добавления - 19.04.2016 в 15:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение ячейки с диапазоном (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!