Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/таблицу с данными преобразовать в столбец - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » таблицу с данными преобразовать в столбец (Формулы/Formulas)
таблицу с данными преобразовать в столбец
АЛЕКСАНДР1986 Дата: Вторник, 19.04.2016, 18:46 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
всем добрый вечер!
есть таблица с данными (с учетом пустых строк ниже) с 1 по 50 строки
как эту таблицу преобразовать в столбец с данными и вставить чуть правее таблицы в красный столбец
К сообщению приложен файл: 11111.xlsx(15Kb)


Сообщение отредактировал АЛЕКСАНДР1986 - Вторник, 19.04.2016, 19:01
 
Ответить
Сообщениевсем добрый вечер!
есть таблица с данными (с учетом пустых строк ниже) с 1 по 50 строки
как эту таблицу преобразовать в столбец с данными и вставить чуть правее таблицы в красный столбец

Автор - АЛЕКСАНДР1986
Дата добавления - 19.04.2016 в 18:46
Nic70y Дата: Вторник, 19.04.2016, 18:58 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3481
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
файл точно тот?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениефайл точно тот?

Автор - Nic70y
Дата добавления - 19.04.2016 в 18:58
АЛЕКСАНДР1986 Дата: Вторник, 19.04.2016, 19:02 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
перевыложил извиняюсь!
 
Ответить
Сообщениеперевыложил извиняюсь!

Автор - АЛЕКСАНДР1986
Дата добавления - 19.04.2016 в 19:02
Nic70y Дата: Вторник, 19.04.2016, 19:09 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3481
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
не понял как оно должно выглядеть в итоге, может так:
Код
=ИНДЕКС(B$1:AA$50;ОСТАТ(СТРОКА()-1;50)+1;ОКРУГЛВВЕРХ(СТРОКА()/50;))
К сообщению приложен файл: 8211667.xlsx(19Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениене понял как оно должно выглядеть в итоге, может так:
Код
=ИНДЕКС(B$1:AA$50;ОСТАТ(СТРОКА()-1;50)+1;ОКРУГЛВВЕРХ(СТРОКА()/50;))

Автор - Nic70y
Дата добавления - 19.04.2016 в 19:09
АЛЕКСАНДР1986 Дата: Вторник, 19.04.2016, 19:16 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
да просто все значения из таблицы преобразовать в столбец!
да то что надо спс!
 
Ответить
Сообщениеда просто все значения из таблицы преобразовать в столбец!
да то что надо спс!

Автор - АЛЕКСАНДР1986
Дата добавления - 19.04.2016 в 19:16
_Boroda_ Дата: Вторник, 19.04.2016, 20:21 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9371
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще похоже
Код
=ИНДЕКС(B$2:AA$25;ОСТАТ(СТРОКА()-2;24)+1;СТРОКА()/26+1)

В общем случае можно так написать
Код
=ИНДЕКС(B$2:AA$25;ОСТАТ(СТРОКА(A1)-СТРОКА(A$1);ЧСТРОК(B$2:AA$25))+1;СТРОКА()/ЧИСЛСТОЛБ(B$2:AA$25)+1)
К сообщению приложен файл: 8211667_1.xlsx(28Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще похоже
Код
=ИНДЕКС(B$2:AA$25;ОСТАТ(СТРОКА()-2;24)+1;СТРОКА()/26+1)

В общем случае можно так написать
Код
=ИНДЕКС(B$2:AA$25;ОСТАТ(СТРОКА(A1)-СТРОКА(A$1);ЧСТРОК(B$2:AA$25))+1;СТРОКА()/ЧИСЛСТОЛБ(B$2:AA$25)+1)

Автор - _Boroda_
Дата добавления - 19.04.2016 в 20:21
АЛЕКСАНДР1986 Дата: Пятница, 07.10.2016, 20:40 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем добрый вечер!
не подскажите как можно подправить формулу в данном варианте чтобы она работала?
Код
=ЕСЛИОШИБКА(ИНДЕКС(I$17:AK$40;ОСТАТ(СТРОКА(H1)-СТРОКА(H$1);ЧСТРОК(I$17:AK$40))+1;СТРОКА()/ЧИСЛСТОЛБ(I$17:AK$40)+1);"")
К сообщению приложен файл: 5447768.xlsx(50Kb)


Сообщение отредактировал АЛЕКСАНДР1986 - Пятница, 07.10.2016, 20:40
 
Ответить
СообщениеВсем добрый вечер!
не подскажите как можно подправить формулу в данном варианте чтобы она работала?
Код
=ЕСЛИОШИБКА(ИНДЕКС(I$17:AK$40;ОСТАТ(СТРОКА(H1)-СТРОКА(H$1);ЧСТРОК(I$17:AK$40))+1;СТРОКА()/ЧИСЛСТОЛБ(I$17:AK$40)+1);"")

Автор - АЛЕКСАНДР1986
Дата добавления - 07.10.2016 в 20:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » таблицу с данными преобразовать в столбец (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!