Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование в Excel по 2 и более условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование в Excel по 2 и более условию (Формулы/Formulas)
Суммирование в Excel по 2 и более условию
SergBudko Дата: Вторник, 19.04.2016, 22:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет. Нужна помощь. нужно подсчитать сумму затрат по месяцам по нескольким критериям...
Я использовал следующую формулу когда был один критерий:
Код
=СУММЕСЛИ($A$3:$A$100;1;$J$3:$J$100)
. Данную формулу я применял в промежутке n2:Y2 в столбике А - указан порядковый номер месяца; Цифра 1 - порядковый номер месяца; в столбце J - затраты;
Мне нужно чтобы учитывался еще один критерий из столбца С. искомую формулу я хочу реализовать в массиве n3:y6. Чтобы узнать затраты в нужный месяц по определенной машине.

заодно может подскажете как уйти от столбика А. в нем я через формулу выясняю порядковый номер месяца, который после с=использую в формулах промежутка n2:Y2

Заранее спасибо!
К сообщению приложен файл: _Microsoft_Exce.xls(32Kb)


Сообщение отредактировал SergBudko - Вторник, 19.04.2016, 22:08
 
Ответить
СообщениеВсем привет. Нужна помощь. нужно подсчитать сумму затрат по месяцам по нескольким критериям...
Я использовал следующую формулу когда был один критерий:
Код
=СУММЕСЛИ($A$3:$A$100;1;$J$3:$J$100)
. Данную формулу я применял в промежутке n2:Y2 в столбике А - указан порядковый номер месяца; Цифра 1 - порядковый номер месяца; в столбце J - затраты;
Мне нужно чтобы учитывался еще один критерий из столбца С. искомую формулу я хочу реализовать в массиве n3:y6. Чтобы узнать затраты в нужный месяц по определенной машине.

заодно может подскажете как уйти от столбика А. в нем я через формулу выясняю порядковый номер месяца, который после с=использую в формулах промежутка n2:Y2

Заранее спасибо!

Автор - SergBudko
Дата добавления - 19.04.2016 в 22:02
sgkorolew Дата: Вторник, 19.04.2016, 22:20 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Может так?
Код
=СУММЕСЛИМН($G$3:$G$17;$A$3:$A$17;СТОЛБЕЦ(A1);$C$3:$C$17;$M3)
К сообщению приложен файл: 1846275.xlsx(13Kb)


Сообщение отредактировал sgkorolew - Вторник, 19.04.2016, 22:22
 
Ответить
СообщениеЗдравствуйте!
Может так?
Код
=СУММЕСЛИМН($G$3:$G$17;$A$3:$A$17;СТОЛБЕЦ(A1);$C$3:$C$17;$M3)

Автор - sgkorolew
Дата добавления - 19.04.2016 в 22:20
buchlotnik Дата: Вторник, 19.04.2016, 22:32 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
или без допстолбца
Код
=СУММПРОИЗВ((ТЕКСТ($B$3:$B$17;"ММММ")=N$1)*($C$3:$C$17=$M3)*$J$3:$J$17)
К сообщению приложен файл: 9173694.xls(32Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеили без допстолбца
Код
=СУММПРОИЗВ((ТЕКСТ($B$3:$B$17;"ММММ")=N$1)*($C$3:$C$17=$M3)*$J$3:$J$17)

Автор - buchlotnik
Дата добавления - 19.04.2016 в 22:32
_Boroda_ Дата: Среда, 20.04.2016, 07:52 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9376
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А я бы еще год добавил, не зря же он в М2 указан
Код
=СУММПРОИЗВ((ТЕКСТ($B$3:$B$17;"ММММГГГ")=N$1&$M$2)*($C$3:$C$17=$M3)*$J$3:$J$17)
К сообщению приложен файл: 618176871_1.xls(34Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА я бы еще год добавил, не зря же он в М2 указан
Код
=СУММПРОИЗВ((ТЕКСТ($B$3:$B$17;"ММММГГГ")=N$1&$M$2)*($C$3:$C$17=$M3)*$J$3:$J$17)

Автор - _Boroda_
Дата добавления - 20.04.2016 в 07:52
SergBudko Дата: Среда, 20.04.2016, 11:00 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо за ответы!
sgkorolew - ответ подходит
buchlotnik и _Boroda_ - ответ подходит,

_Boroda_ опередил своим ответом назревший у меня вопрос. За что ему отдельное спасибо!!!
к своей таблице применил формулу из примера Бороды.
 
Ответить
СообщениеСпасибо за ответы!
sgkorolew - ответ подходит
buchlotnik и _Boroda_ - ответ подходит,

_Boroda_ опередил своим ответом назревший у меня вопрос. За что ему отдельное спасибо!!!
к своей таблице применил формулу из примера Бороды.

Автор - SergBudko
Дата добавления - 20.04.2016 в 11:00
SergBudko Дата: Среда, 20.04.2016, 12:28 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А я бы еще год добавил, не зря же он в М2 указан
Спасибо большое. Уже переделал все! очень помогло!
 
Ответить
Сообщение
А я бы еще год добавил, не зря же он в М2 указан
Спасибо большое. Уже переделал все! очень помогло!

Автор - SergBudko
Дата добавления - 20.04.2016 в 12:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование в Excel по 2 и более условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!