Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчитать количество исх. плюс вх. звонков - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать количество исх. плюс вх. звонков (Формулы/Formulas)
Подсчитать количество исх. плюс вх. звонков
Evgen84 Дата: Вторник, 26.04.2016, 09:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Подскажите пожалуйста, как посчитать количество исх. + вх. звонков при условии, что клиенту звонили несколько раз и возможно в одной строке наличие, как исх. так и вх. звонков. В примере указал, что бы хотелось получить. Заранее хочу сказать, что отобрать необходимо не только те моменты когда присутствуют в одной строчке оба условия но и когда они в разных строчках. Смог отобрать отдельно эти звонки, а вот чтоб учесть их вместе с этим проблема((. Если можно формулу пишите в ответе.
 
Ответить
СообщениеПодскажите пожалуйста, как посчитать количество исх. + вх. звонков при условии, что клиенту звонили несколько раз и возможно в одной строке наличие, как исх. так и вх. звонков. В примере указал, что бы хотелось получить. Заранее хочу сказать, что отобрать необходимо не только те моменты когда присутствуют в одной строчке оба условия но и когда они в разных строчках. Смог отобрать отдельно эти звонки, а вот чтоб учесть их вместе с этим проблема((. Если можно формулу пишите в ответе.

Автор - Evgen84
Дата добавления - 26.04.2016 в 09:56
Nic70y Дата: Вторник, 26.04.2016, 10:01 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
В примере указал
в каком?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
В примере указал
в каком?

Автор - Nic70y
Дата добавления - 26.04.2016 в 10:01
Evgen84 Дата: Вторник, 26.04.2016, 10:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Извиняюсь видимо не подкрепился файл. Прикрепил.
[moder]Где?
max 100kb


Сообщение отредактировал _Boroda_ - Вторник, 26.04.2016, 10:12
 
Ответить
СообщениеИзвиняюсь видимо не подкрепился файл. Прикрепил.
[moder]Где?
max 100kb

Автор - Evgen84
Дата добавления - 26.04.2016 в 10:09
Evgen84 Дата: Вторник, 26.04.2016, 10:13 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Пример
К сообщению приложен файл: 0649220.xlsx(65Kb)
 
Ответить
СообщениеПример

Автор - Evgen84
Дата добавления - 26.04.2016 в 10:13
Nic70y Дата: Вторник, 26.04.2016, 10:24 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
в ячейках всегда 1?
если да, то наверное, может быть так:
Код
=СУММПРОИЗВ((A3:A$999=A3)*МАКС(B3:B$999;C3:C$999))
не так:(


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 26.04.2016, 10:40
 
Ответить
Сообщениев ячейках всегда 1?
если да, то наверное, может быть так:
Код
=СУММПРОИЗВ((A3:A$999=A3)*МАКС(B3:B$999;C3:C$999))
не так:(

Автор - Nic70y
Дата добавления - 26.04.2016 в 10:24
_Boroda_ Дата: Вторник, 26.04.2016, 10:24 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А почему для 1010 = 3, а не 4?
Так нужно?
Код
=СУММПРОИЗВ((A$2:A$999=A3)*B$2:C$999)

Хотя ...
Не знаю, верно ли я понял задачу
К сообщению приложен файл: 0649220_1.xlsx(60Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА почему для 1010 = 3, а не 4?
Так нужно?
Код
=СУММПРОИЗВ((A$2:A$999=A3)*B$2:C$999)

Хотя ...
Не знаю, верно ли я понял задачу

Автор - _Boroda_
Дата добавления - 26.04.2016 в 10:24
Evgen84 Дата: Вторник, 26.04.2016, 10:25 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
в каком?

Выше приложил. Файл был большой.
 
Ответить
Сообщение
в каком?

Выше приложил. Файл был большой.

Автор - Evgen84
Дата добавления - 26.04.2016 в 10:25
Evgen84 Дата: Вторник, 26.04.2016, 10:28 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А почему для 1010 = 3, а не 4?

Надо именно, чтоб как в примере. Необходимо посчитать все эти звонки по клиенту как один звонок.
 
Ответить
Сообщение
А почему для 1010 = 3, а не 4?

Надо именно, чтоб как в примере. Необходимо посчитать все эти звонки по клиенту как один звонок.

Автор - Evgen84
Дата добавления - 26.04.2016 в 10:28
Evgen84 Дата: Вторник, 26.04.2016, 10:36 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
в ячейках всегда 1?

Нет не всегда.
 
Ответить
Сообщение
в ячейках всегда 1?

Нет не всегда.

Автор - Evgen84
Дата добавления - 26.04.2016 в 10:36
_Boroda_ Дата: Вторник, 26.04.2016, 10:36 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=СУММПРОИЗВ((A3:A$999=A3)*ОКРУГЛ((B3:B$999+C3:C$999)/2;0))
К сообщению приложен файл: 0649220_2.xlsx(60Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=СУММПРОИЗВ((A3:A$999=A3)*ОКРУГЛ((B3:B$999+C3:C$999)/2;0))

Автор - _Boroda_
Дата добавления - 26.04.2016 в 10:36
Nic70y Дата: Вторник, 26.04.2016, 10:39 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))))
не всегда
и что тогда?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 26.04.2016, 10:39
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))))
не всегда
и что тогда?

Автор - Nic70y
Дата добавления - 26.04.2016 в 10:39
Evgen84 Дата: Вторник, 26.04.2016, 10:41 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
если да, то наверное, может быть так:

=СУММПРОИЗВ((A3:A$999=A3)*МАКС(B3:B$999;C3:C$999))

В принципе то, что необходимо но хотелось бы еще, чтоб нулевые или пустые не учитывались. Например строчки 32 и 33 в одной есть звонок, а во второй пусто и в таком случае необходимо, чтоб в 32 стояло "1", а в 33 стоял "0" или иное заначение не равное "1"
 
Ответить
Сообщение
если да, то наверное, может быть так:

=СУММПРОИЗВ((A3:A$999=A3)*МАКС(B3:B$999;C3:C$999))

В принципе то, что необходимо но хотелось бы еще, чтоб нулевые или пустые не учитывались. Например строчки 32 и 33 в одной есть звонок, а во второй пусто и в таком случае необходимо, чтоб в 32 стояло "1", а в 33 стоял "0" или иное заначение не равное "1"

Автор - Evgen84
Дата добавления - 26.04.2016 в 10:41
Evgen84 Дата: Вторник, 26.04.2016, 10:49 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))))

100% то, что надо. Спасибо!
 
Ответить
Сообщение
=СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))))

100% то, что надо. Спасибо!

Автор - Evgen84
Дата добавления - 26.04.2016 в 10:49
Evgen84 Дата: Вторник, 26.04.2016, 11:12 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Сразу не заметил, что если при посторении в нескольких строках из которых содержиться значение только в одной, а в остальных пусто то везде выходит "1", как сделать, чтоб в пустых выходил "0"? В примере красным отмечено, как вышло, а желтым, как хотелось бы.
[moder]При исправлении замечания можератора само замечание удалять не нужно.
К сообщению приложен файл: 9433981.xlsx(91Kb)


Сообщение отредактировал _Boroda_ - Вторник, 26.04.2016, 11:23
 
Ответить
СообщениеСразу не заметил, что если при посторении в нескольких строках из которых содержиться значение только в одной, а в остальных пусто то везде выходит "1", как сделать, чтоб в пустых выходил "0"? В примере красным отмечено, как вышло, а желтым, как хотелось бы.
[moder]При исправлении замечания можератора само замечание удалять не нужно.

Автор - Evgen84
Дата добавления - 26.04.2016 в 11:12
Nic70y Дата: Вторник, 26.04.2016, 11:19 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
удалено администрацией
[moder]Не исправлено замечание модератора в пред. посте[/moder][moder]Исправлено. Теперь можно класть ответ[/moder]
Код
=ЕСЛИ(СУММ(B3:C3);СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))));0)
вдруг правильно


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 26.04.2016, 11:33
 
Ответить
Сообщениеудалено администрацией
[moder]Не исправлено замечание модератора в пред. посте[/moder][moder]Исправлено. Теперь можно класть ответ[/moder]
Код
=ЕСЛИ(СУММ(B3:C3);СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))));0)
вдруг правильно

Автор - Nic70y
Дата добавления - 26.04.2016 в 11:19
Evgen84 Дата: Вторник, 26.04.2016, 11:44 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ЕСЛИ(СУММ(B3:C3);СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))));0)

если столбцы "исх." и "вх." стоят не рядом то формула немного не корректно считает пришлось между ("В3" и "С3") поставить "+".


Сообщение отредактировал Evgen84 - Вторник, 26.04.2016, 15:50
 
Ответить
Сообщение
=ЕСЛИ(СУММ(B3:C3);СУММПРОИЗВ(СЧЁТ(1/((A3:A$999=A3)*(B3:B$999+C3:C$999))));0)

если столбцы "исх." и "вх." стоят не рядом то формула немного не корректно считает пришлось между ("В3" и "С3") поставить "+".

Автор - Evgen84
Дата добавления - 26.04.2016 в 11:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать количество исх. плюс вх. звонков (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!