Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если в столбце есть дата, то вывести строку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в столбце есть дата, то вывести строку (Формулы/Formulas)
Если в столбце есть дата, то вывести строку
Chertyozhnik Дата: Вторник, 26.04.2016, 19:50 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 74
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Снова здравствуйте )

Подскажите пожалуйста, как решить следующую задачу.
Есть 2 листа с таблицами. Необходимо данными из одной таблицы заполнить ячейки второй таблицы, при условии, что в столбце первой таблицы дата совпадает с необходимой нам.
К сообщению приложен файл: 5183140.xlsx(10Kb)
 
Ответить
СообщениеСнова здравствуйте )

Подскажите пожалуйста, как решить следующую задачу.
Есть 2 листа с таблицами. Необходимо данными из одной таблицы заполнить ячейки второй таблицы, при условии, что в столбце первой таблицы дата совпадает с необходимой нам.

Автор - Chertyozhnik
Дата добавления - 26.04.2016 в 19:50
Pelena Дата: Вторник, 26.04.2016, 20:07 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9889
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица!$A$2:$A$6;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$A$2=Таблица!$D$2:$D$6;СТРОКА(Таблица!$A$2:$A$6)-1);СТРОКА(A1)));"")
К сообщению приложен файл: 8673057.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица!$A$2:$A$6;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$A$2=Таблица!$D$2:$D$6;СТРОКА(Таблица!$A$2:$A$6)-1);СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 26.04.2016 в 20:07
gling Дата: Вторник, 26.04.2016, 20:12 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Топорно с доп столбцом и ВПР.
К сообщению приложен файл: 3077362.xlsx(11Kb)
 
Ответить
СообщениеТопорно с доп столбцом и ВПР.

Автор - gling
Дата добавления - 26.04.2016 в 20:12
Karataev Дата: Вторник, 26.04.2016, 20:16 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 643
Репутация: 227 ±
Замечаний: 0% ±

Excel
Реализовал с помощью допстолбца и формулы массива.
На листе Таблица просматривается 5 тыс. строк.
Формула массива вставлена на лист1 в столбец K. Формула вставлена так: сначала я выделил фрагмент K2:K100, а затем вставил одну формулу.
Формула массива вставляется сочетанием Ctrl+Shift+Enter.
В столбцах B, D и I обычные формулы, использующие данные из допстолбца.

Формула массива (вводится Ctrl+Shift+Enter):
Код
=НАИМЕНЬШИЙ(ЕСЛИ(Таблица!D2:D5000=A2;СТРОКА(Таблица!D2:D5000);"");СТРОКА()-1)

P.S. чтобы удалить формулы массива из столбца K, сначала нужно выделить фрагмент K2:K100, а затему только удалять.
К сообщению приложен файл: formulas.xlsx(13Kb)


 
Ответить
СообщениеРеализовал с помощью допстолбца и формулы массива.
На листе Таблица просматривается 5 тыс. строк.
Формула массива вставлена на лист1 в столбец K. Формула вставлена так: сначала я выделил фрагмент K2:K100, а затем вставил одну формулу.
Формула массива вставляется сочетанием Ctrl+Shift+Enter.
В столбцах B, D и I обычные формулы, использующие данные из допстолбца.

Формула массива (вводится Ctrl+Shift+Enter):
Код
=НАИМЕНЬШИЙ(ЕСЛИ(Таблица!D2:D5000=A2;СТРОКА(Таблица!D2:D5000);"");СТРОКА()-1)

P.S. чтобы удалить формулы массива из столбца K, сначала нужно выделить фрагмент K2:K100, а затему только удалять.

Автор - Karataev
Дата добавления - 26.04.2016 в 20:16
Chertyozhnik Дата: Вторник, 26.04.2016, 21:13 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 74
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Жесть... Всем спасибо... Пошел разбираться и подгонять под реальную таблицу ).
Честно говоря, не понимаю, как вы это все делаете... обычно просто подгоняю под данную вами формулу. Спасибо огромное )
 
Ответить
СообщениеЖесть... Всем спасибо... Пошел разбираться и подгонять под реальную таблицу ).
Честно говоря, не понимаю, как вы это все делаете... обычно просто подгоняю под данную вами формулу. Спасибо огромное )

Автор - Chertyozhnik
Дата добавления - 26.04.2016 в 21:13
Nic70y Дата: Четверг, 28.04.2016, 08:59 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3493
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013
вариант - обычными формулами, без доп. столбцов
(в соот с примером ес-но)
К сообщению приложен файл: 3498325.xlsx(11Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 28.04.2016, 09:10
 
Ответить
Сообщениевариант - обычными формулами, без доп. столбцов
(в соот с примером ес-но)

Автор - Nic70y
Дата добавления - 28.04.2016 в 08:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в столбце есть дата, то вывести строку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!