Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/транспонировать массив данных формулы ПРОСМОТР ИНДЕКС ПОИСКП - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » транспонировать массив данных формулы ПРОСМОТР ИНДЕКС ПОИСКП (Формулы/Formulas)
транспонировать массив данных формулы ПРОСМОТР ИНДЕКС ПОИСКП
kaurov Дата: Среда, 27.04.2016, 04:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Помогите транспонировать массив данных формулы ПРОСМОТР ИНДЕКС и ПОИСКПОЗ

Фаил в приложении - 1 вкладка где все работает и вторая где не работает (поля выделены желтым) - мне нужно будет вставлять значений много и для удобства нужно столбцом. И не могу понять логику работы формулы, а сделать нужно "вчера".

Заранее спасибо.
К сообщению приложен файл: excelworld_exam.xls(38Kb)
 
Ответить
СообщениеПомогите транспонировать массив данных формулы ПРОСМОТР ИНДЕКС и ПОИСКПОЗ

Фаил в приложении - 1 вкладка где все работает и вторая где не работает (поля выделены желтым) - мне нужно будет вставлять значений много и для удобства нужно столбцом. И не могу понять логику работы формулы, а сделать нужно "вчера".

Заранее спасибо.

Автор - kaurov
Дата добавления - 27.04.2016 в 04:21
buchlotnik Дата: Среда, 27.04.2016, 07:28 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ПРОСМОТР(K24;ИНДЕКС($P$4:$T$7;;ПОИСКПОЗ(C24;$P$3:$T$3;1));$O$4:$O$7%)
К сообщению приложен файл: 7207339.xls(36Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ПРОСМОТР(K24;ИНДЕКС($P$4:$T$7;;ПОИСКПОЗ(C24;$P$3:$T$3;1));$O$4:$O$7%)

Автор - buchlotnik
Дата добавления - 27.04.2016 в 07:28
kaurov Дата: Среда, 27.04.2016, 09:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо - первая формула заработала как надо. Хотя я так и не понял смысл доп. точки с запятой и замены 0 на единицы.

Пожалуйста посмотрите еще формулу выделенную оканжевым.

Суть такова - чем выше скорость оплаты в столбце I тем выше коэффициент бонуса в графе H3 - H16 - максимум 2 минимум 0.7
К сообщению приложен файл: excelworld_2.xls(36Kb)
 
Ответить
СообщениеСпасибо - первая формула заработала как надо. Хотя я так и не понял смысл доп. точки с запятой и замены 0 на единицы.

Пожалуйста посмотрите еще формулу выделенную оканжевым.

Суть такова - чем выше скорость оплаты в столбце I тем выше коэффициент бонуса в графе H3 - H16 - максимум 2 минимум 0.7

Автор - kaurov
Дата добавления - 27.04.2016 в 09:31
_Boroda_ Дата: Среда, 27.04.2016, 09:48 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вы переделали файл. Вернее, большую таблицу. Раньше у Вас значения были по убыванию, а теперь по возрастанию. Это в корне меняет дело и позволяет использовать формулу Михаила из первого поста
Код
=ЕСЛИОШИБКА(ПРОСМОТР(I24;ИНДЕКС(I$3:M$16;;ПОИСКПОЗ(C24;I$2:M$2));H$3:H$16);)

смысл доп. точки с запятой и замены 0 на единицы.

У ИНДЕКСа есть параметры строк и столбцов ИНДЕКС(диапазон;строка;столбец). Когда 2 или 3 параметр равен 0, ИНДЕКС дает весь столбец [ИНДЕКС(диап;0;столбец)] или строку [ИНДЕКС(диап;строка;0)]. 0 можно не писать, прокатывает и такая запись [ИНДЕКС(диап;;столбец)] ; [ИНДЕКС(диап;строка)]

1 не нужна (вернее, не обязательна). Справка -
Цитата
1 или опущен - Функция ПОИСКПОЗ находит наибольшее значение, которое меньше или равно значению аргумента искомое_значение. Просматриваемый_массив должен быть упорядочен по возрастанию: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА.
Кстати, это не замена, там совсем не оттуда ноль был - обратите внимание на скобки (у Вас единица четвертым аргументом ИНДЕКСа, а у Михаила - третьим аргументом ПОИСКПОЗа - и то, и другое для этой конкретной формулы не обязательно, но и не мешает)
К сообщению приложен файл: excelworld_3.xls(38Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Среда, 27.04.2016, 10:13
 
Ответить
СообщениеВы переделали файл. Вернее, большую таблицу. Раньше у Вас значения были по убыванию, а теперь по возрастанию. Это в корне меняет дело и позволяет использовать формулу Михаила из первого поста
Код
=ЕСЛИОШИБКА(ПРОСМОТР(I24;ИНДЕКС(I$3:M$16;;ПОИСКПОЗ(C24;I$2:M$2));H$3:H$16);)

смысл доп. точки с запятой и замены 0 на единицы.

У ИНДЕКСа есть параметры строк и столбцов ИНДЕКС(диапазон;строка;столбец). Когда 2 или 3 параметр равен 0, ИНДЕКС дает весь столбец [ИНДЕКС(диап;0;столбец)] или строку [ИНДЕКС(диап;строка;0)]. 0 можно не писать, прокатывает и такая запись [ИНДЕКС(диап;;столбец)] ; [ИНДЕКС(диап;строка)]

1 не нужна (вернее, не обязательна). Справка -
Цитата
1 или опущен - Функция ПОИСКПОЗ находит наибольшее значение, которое меньше или равно значению аргумента искомое_значение. Просматриваемый_массив должен быть упорядочен по возрастанию: ..., -2, -1, 0, 1, 2, ..., A-Z, ЛОЖЬ, ИСТИНА.
Кстати, это не замена, там совсем не оттуда ноль был - обратите внимание на скобки (у Вас единица четвертым аргументом ИНДЕКСа, а у Михаила - третьим аргументом ПОИСКПОЗа - и то, и другое для этой конкретной формулы не обязательно, но и не мешает)

Автор - _Boroda_
Дата добавления - 27.04.2016 в 09:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » транспонировать массив данных формулы ПРОСМОТР ИНДЕКС ПОИСКП (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!