Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Допилить ВПР+ДВССЫЛ для поиска по всем листам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Допилить ВПР+ДВССЫЛ для поиска по всем листам (Формулы/Formulas)
Допилить ВПР+ДВССЫЛ для поиска по всем листам
oeei Дата: Четверг, 28.04.2016, 20:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Вечер добрый!
Прошу помощи в доработке формулы для того, чтобы подбирала значения со всех листов книги с заданным наименованием столбца.
В текущем состоянии формула работает только для определенного столбца
Код
=ВПР($B2;ДВССЫЛ(C$1&"!B3:F22");5;)
К сообщению приложен файл: oeei2.xlsx(19Kb)
 
Ответить
СообщениеВечер добрый!
Прошу помощи в доработке формулы для того, чтобы подбирала значения со всех листов книги с заданным наименованием столбца.
В текущем состоянии формула работает только для определенного столбца
Код
=ВПР($B2;ДВССЫЛ(C$1&"!B3:F22");5;)

Автор - oeei
Дата добавления - 28.04.2016 в 20:15
gling Дата: Четверг, 28.04.2016, 20:54 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Не стал особо заморачиваться.
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:Q22");ПОИСКПОЗ($B$1;ДВССЫЛ(C$1&"!B1:Q1");););"")
В В1 надо выбирать.
К сообщению приложен файл: 1139107.xlsx(22Kb)
 
Ответить
СообщениеНе стал особо заморачиваться.
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:Q22");ПОИСКПОЗ($B$1;ДВССЫЛ(C$1&"!B1:Q1");););"")
В В1 надо выбирать.

Автор - gling
Дата добавления - 28.04.2016 в 20:54
Roman777 Дата: Четверг, 28.04.2016, 20:55 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 75 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
oeei, хотябы так:
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:H22");ПОИСКПОЗ($B2;ДВССЫЛ(C$1&"!1:1")););"")

Ну это при учёте, что на всех листах наименование Тип1, 2... будут в 1й строке...(у Вас в файле на 2м листе оно почему-то во 2й строке, но даже в этом случае можно сделать).
Оба, опередили...)


Много чего не знаю!!!!

Сообщение отредактировал Roman777 - Четверг, 28.04.2016, 20:56
 
Ответить
Сообщениеoeei, хотябы так:
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:H22");ПОИСКПОЗ($B2;ДВССЫЛ(C$1&"!1:1")););"")

Ну это при учёте, что на всех листах наименование Тип1, 2... будут в 1й строке...(у Вас в файле на 2м листе оно почему-то во 2й строке, но даже в этом случае можно сделать).
Оба, опередили...)

Автор - Roman777
Дата добавления - 28.04.2016 в 20:55
oeei Дата: Пятница, 29.04.2016, 10:18 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
gling Извиняйте, я немного ошибся в исходных условиях - все объекты разные.

Roman777 thumb Спасибо большое, на примере заработало, как надо, а в рабочем файле выдает какую-то х-ню shock
Подскажите, где туплю)
К сообщению приложен файл: oeei3.xlsx(17Kb)
 
Ответить
Сообщениеgling Извиняйте, я немного ошибся в исходных условиях - все объекты разные.

Roman777 thumb Спасибо большое, на примере заработало, как надо, а в рабочем файле выдает какую-то х-ню shock
Подскажите, где туплю)

Автор - oeei
Дата добавления - 29.04.2016 в 10:18
Roman777 Дата: Пятница, 29.04.2016, 10:39 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 75 ±
Замечаний: 0% ±

Excel 2007, Excel 2013
oeei, Приношу извинения, неправильная ф-ла в сообщении №3.
д.б.
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:H22");ПОИСКПОЗ(C$1;ДВССЫЛ(C$1&"!1:1");0)-1;);"")


а в Вашем новом варианте
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:H22");ПОИСКПОЗ(C$1;ДВССЫЛ(C$1&"!1:1");0)-1;0);"")


собственно, идентичные ф-лы)
поправил, ато поторопился...)


Много чего не знаю!!!!

Сообщение отредактировал Roman777 - Пятница, 29.04.2016, 10:53
 
Ответить
Сообщениеoeei, Приношу извинения, неправильная ф-ла в сообщении №3.
д.б.
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:H22");ПОИСКПОЗ(C$1;ДВССЫЛ(C$1&"!1:1");0)-1;);"")


а в Вашем новом варианте
Код
=ЕСЛИОШИБКА(ВПР($B2;ДВССЫЛ(C$1&"!B2:H22");ПОИСКПОЗ(C$1;ДВССЫЛ(C$1&"!1:1");0)-1;0);"")


собственно, идентичные ф-лы)
поправил, ато поторопился...)

Автор - Roman777
Дата добавления - 29.04.2016 в 10:39
oeei Дата: Пятница, 29.04.2016, 11:50 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 40% ±

Excel 2013
Roman777, премного благодарен!
 
Ответить
СообщениеRoman777, премного благодарен!

Автор - oeei
Дата добавления - 29.04.2016 в 11:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Допилить ВПР+ДВССЫЛ для поиска по всем листам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!