Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/применение в таблице ИНДЕКС И ПОИСКПОЗ по условию ЕСЛИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » применение в таблице ИНДЕКС И ПОИСКПОЗ по условию ЕСЛИ (Формулы/Formulas)
применение в таблице ИНДЕКС И ПОИСКПОЗ по условию ЕСЛИ
ElenaA Дата: Понедельник, 16.05.2016, 20:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу помочь применить формулу для оптимизации отчета.
Если в столбце С содержится определенное значение столбца В то сумма столбца М(OODR) равна сумме столбца О(OOCR).
например
значение В2 (60323810000000005430) содержится в столбце С 142(РВП на 60323810000000005430 АТМ 155238), то сумма столбца М=О(сумма 800000.00)
Файл приложен.Буду очень благодарна за помощь.
К сообщению приложен файл: ot.xlsx(36Kb)


Сообщение отредактировал ElenaA - Понедельник, 16.05.2016, 20:49
 
Ответить
СообщениеПрошу помочь применить формулу для оптимизации отчета.
Если в столбце С содержится определенное значение столбца В то сумма столбца М(OODR) равна сумме столбца О(OOCR).
например
значение В2 (60323810000000005430) содержится в столбце С 142(РВП на 60323810000000005430 АТМ 155238), то сумма столбца М=О(сумма 800000.00)
Файл приложен.Буду очень благодарна за помощь.

Автор - ElenaA
Дата добавления - 16.05.2016 в 20:46
китин Дата: Вторник, 17.05.2016, 07:49 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам здравствуйте :D Проверяйте. Как понял
Код
=ЕСЛИОШИБКА(ИНДЕКС($O$2:$O$171;ПОИСКПОЗ("*"&B2&"*";$C$2:$C$149;0));L2)
в зеленом столбце
К сообщению приложен файл: ot-2.xlsx(40Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеИ вам здравствуйте :D Проверяйте. Как понял
Код
=ЕСЛИОШИБКА(ИНДЕКС($O$2:$O$171;ПОИСКПОЗ("*"&B2&"*";$C$2:$C$149;0));L2)
в зеленом столбце

Автор - китин
Дата добавления - 17.05.2016 в 07:49
ElenaA Дата: Вторник, 17.05.2016, 11:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Возможно я неверно объяснила суть.Счета Столбца С и В должны составлять пару(60323 и 60324-ПАРА).И суммы в этих парах должны быть равны друг другу.
Например
Счет из столбца В(EAN) содержится в столбце С(NMN).Они составляют пару.
Поэтому их суммы из столбца М и О должны быть равны.Каждый счет из столбца В должен найти свою пару из столбца С и соот-но если нет ошибки суммы должны совпасть.
OODR OOCR
0,00 800000,00
800000,00

800000,00 0,00

60323810000000000000 Недостача, нереальная для выскания АТМ 155238от 02.12.15 по факту хищ.денеж.средств
60324810700000004293 РВП на 60323810000000005430 АТМ 155238
 
Ответить
СообщениеВозможно я неверно объяснила суть.Счета Столбца С и В должны составлять пару(60323 и 60324-ПАРА).И суммы в этих парах должны быть равны друг другу.
Например
Счет из столбца В(EAN) содержится в столбце С(NMN).Они составляют пару.
Поэтому их суммы из столбца М и О должны быть равны.Каждый счет из столбца В должен найти свою пару из столбца С и соот-но если нет ошибки суммы должны совпасть.
OODR OOCR
0,00 800000,00
800000,00

800000,00 0,00

60323810000000000000 Недостача, нереальная для выскания АТМ 155238от 02.12.15 по факту хищ.денеж.средств
60324810700000004293 РВП на 60323810000000005430 АТМ 155238

Автор - ElenaA
Дата добавления - 17.05.2016 в 11:02
китин Дата: Вторник, 17.05.2016, 11:04 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
killed я ничего не понял

оставьте пару десятков строк и покажите ручками что вам надо


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 17.05.2016, 11:05
 
Ответить
Сообщениеkilled я ничего не понял

оставьте пару десятков строк и покажите ручками что вам надо

Автор - китин
Дата добавления - 17.05.2016 в 11:04
ElenaA Дата: Вторник, 17.05.2016, 12:13 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Напримере 3 счетов я сделала что нужно.
К сообщению приложен файл: ot-1-.xlsx(16Kb)
 
Ответить
СообщениеНапримере 3 счетов я сделала что нужно.

Автор - ElenaA
Дата добавления - 17.05.2016 в 12:13
pabchek Дата: Вторник, 17.05.2016, 12:58 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! Я тоже не сильно понял. Но... смотрите вариант. В синей колонке возвращаются значения из желтой при совпадении. (Вот только там все ноли в совпадающих строках)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(B2;C$2:C$171);M$2:M$171);0)

Вроде понял. Щас.
Файл перезалил. В последней колонке подтягиваются значения из синей колонки при совпадении. Так надо?
Есть глюк. В ячейке В2 значение само устанавливается на 60323810000000000000. В чём причина не разбирался

Разобрался с глюком. Число слишком большое. Нужно сохранить как текст и исправить уже в текстовом формате (перезалил)
К сообщению приложен файл: ot-3.xlsx(41Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 17.05.2016, 13:18
 
Ответить
СообщениеЗдравствуйте! Я тоже не сильно понял. Но... смотрите вариант. В синей колонке возвращаются значения из желтой при совпадении. (Вот только там все ноли в совпадающих строках)
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(B2;C$2:C$171);M$2:M$171);0)

Вроде понял. Щас.
Файл перезалил. В последней колонке подтягиваются значения из синей колонки при совпадении. Так надо?
Есть глюк. В ячейке В2 значение само устанавливается на 60323810000000000000. В чём причина не разбирался

Разобрался с глюком. Число слишком большое. Нужно сохранить как текст и исправить уже в текстовом формате (перезалил)

Автор - pabchek
Дата добавления - 17.05.2016 в 12:58
ElenaA Дата: Вторник, 17.05.2016, 15:36 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Возможно я плохо объясняю.Я приложила на примере 3 счетов.Пож-та помогите,очень сложно проверять соответствие сумм по огромному ко-ву отделений.Файл выгружается из программы АБС каждый день новый.Проверка занимает много времени.Суммы счетов в паре 60323 и 60324 должны быть равны.И каждому счету 60324 из столбца В должен быть найдет соответствующий счет 60324 из столбца С.
К сообщению приложен файл: 8034991.xlsx(16Kb)


Сообщение отредактировал ElenaA - Вторник, 17.05.2016, 15:38
 
Ответить
СообщениеВозможно я плохо объясняю.Я приложила на примере 3 счетов.Пож-та помогите,очень сложно проверять соответствие сумм по огромному ко-ву отделений.Файл выгружается из программы АБС каждый день новый.Проверка занимает много времени.Суммы счетов в паре 60323 и 60324 должны быть равны.И каждому счету 60324 из столбца В должен быть найдет соответствующий счет 60324 из столбца С.

Автор - ElenaA
Дата добавления - 17.05.2016 в 15:36
_Boroda_ Дата: Вторник, 17.05.2016, 16:05 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В чём причина

В том, что Excel автоматически съедает только 15 символов числа. Остальные делает нулем. А вот если перевести все в текстовый формат, то нормально. Но не всегда - внутри некоторых формул Excel все равно самоуправствует - например, формула
Код
=СЧЁТЕСЛИ(B2:B7;B3)
для текстового формата должна дать 1, а она даст 5. Почему? потому, что в диапазоне B2:B7 все длинные числа (пусть даже они и текстом записаны) обнулятся после 15 знака и вместо 60323810000040003544 получится 60323810000040000000, а таких значений действительно 5


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
В чём причина

В том, что Excel автоматически съедает только 15 символов числа. Остальные делает нулем. А вот если перевести все в текстовый формат, то нормально. Но не всегда - внутри некоторых формул Excel все равно самоуправствует - например, формула
Код
=СЧЁТЕСЛИ(B2:B7;B3)
для текстового формата должна дать 1, а она даст 5. Почему? потому, что в диапазоне B2:B7 все длинные числа (пусть даже они и текстом записаны) обнулятся после 15 знака и вместо 60323810000040003544 получится 60323810000040000000, а таких значений действительно 5

Автор - _Boroda_
Дата добавления - 17.05.2016 в 16:05
pabchek Дата: Вторник, 17.05.2016, 17:25 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Может так?
Код
=СУММ(ЕСЛИ(--ЛЕВБ(B$2:B$7;5)=B10;D$2:D$7))
формула массива вводится одновременным нажатием (Шифт+Кнтрл+Ентер)
добавил формулы в "большой" файл. Так?
К сообщению приложен файл: 0696141.xlsx(16Kb) · 9791281.xlsx(42Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 17.05.2016, 17:36
 
Ответить
СообщениеМожет так?
Код
=СУММ(ЕСЛИ(--ЛЕВБ(B$2:B$7;5)=B10;D$2:D$7))
формула массива вводится одновременным нажатием (Шифт+Кнтрл+Ентер)
добавил формулы в "большой" файл. Так?

Автор - pabchek
Дата добавления - 17.05.2016 в 17:25
ElenaA Дата: Вторник, 17.05.2016, 17:58 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо!
Только это к сожалению не решило моей задачи.ТК в случае неравенства сумм по счету 60323 и 60324 приходится вручную сравнивать суммы и искать расхождения


Сообщение отредактировал ElenaA - Вторник, 17.05.2016, 17:59
 
Ответить
Сообщениеспасибо!
Только это к сожалению не решило моей задачи.ТК в случае неравенства сумм по счету 60323 и 60324 приходится вручную сравнивать суммы и искать расхождения

Автор - ElenaA
Дата добавления - 17.05.2016 в 17:58
pabchek Дата: Вторник, 17.05.2016, 18:01 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
добавив разницу в формулу, расхождения можно находить применяя фильтр в колонке АС
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(B2;C$2:C$171);O$2:O$171);0)-M2
К сообщению приложен файл: 7024785.xlsx(41Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщениедобавив разницу в формулу, расхождения можно находить применяя фильтр в колонке АС
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(B2;C$2:C$171);O$2:O$171);0)-M2

Автор - pabchek
Дата добавления - 17.05.2016 в 18:01
pabchek Дата: Вторник, 17.05.2016, 18:23 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Ну или если совсем уж... Фильтром убираете ноли и остаются только несовпадающие строки
К сообщению приложен файл: ot-4.xlsx(44Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеНу или если совсем уж... Фильтром убираете ноли и остаются только несовпадающие строки

Автор - pabchek
Дата добавления - 17.05.2016 в 18:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » применение в таблице ИНДЕКС И ПОИСКПОЗ по условию ЕСЛИ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!