Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Рассчитать среднее по 2-м значениям в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитать среднее по 2-м значениям в таблице (Формулы/Formulas)
Рассчитать среднее по 2-м значениям в таблице
GP75 Дата: Среда, 18.05.2016, 00:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте уважаемые знатоки EXCEL. Как то вы помогли мне с выбором функции ПОИСКПОЗ. Теперь задача усложнилось. Нужно не только найти по двум искомым значениям, но рассчитать среднее . Такое возможно в формуле? Пример и пояснение - в прикреплениис
[moder]Вам что сделать нужно? Рассчитать среднее по 2-м что-то там ...
Так и назовите тему, а ПОИСКПОЗ не приплетайте - это просто один из способов решения
К сообщению приложен файл: primer11.xls(48Kb)


Сообщение отредактировал GP75 - Среда, 18.05.2016, 09:41
 
Ответить
СообщениеЗдравствуйте уважаемые знатоки EXCEL. Как то вы помогли мне с выбором функции ПОИСКПОЗ. Теперь задача усложнилось. Нужно не только найти по двум искомым значениям, но рассчитать среднее . Такое возможно в формуле? Пример и пояснение - в прикреплениис
[moder]Вам что сделать нужно? Рассчитать среднее по 2-м что-то там ...
Так и назовите тему, а ПОИСКПОЗ не приплетайте - это просто один из способов решения

Автор - GP75
Дата добавления - 18.05.2016 в 00:19
abtextime Дата: Среда, 18.05.2016, 13:04 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС($B$10:$G$13;$A$2;$A$3)+ЕСЛИ(ИНДЕКС($A$10:$A$13;$B$2)=ИНДЕКС($A$10:$A$13;$A$2);0;(ИНДЕКС($B$10:$G$13;$A$2;$A$3)-ИНДЕКС($B$10:$G$13;$A$2;$A$3))*(C1-ИНДЕКС($A$10:$A$13;$A$2))/(ИНДЕКС($A$10:$A$13;$B$2)-ИНДЕКС($A$10:$A$13;$A$2)))+ЕСЛИ(ИНДЕКС($B$9:$G$9;$A$3)=ИНДЕКС($B$9:$G$9;$B$3);0;(ИНДЕКС($B$10:$G$13;$A$2;$B$3)-ИНДЕКС($B$10:$G$13;$A$2;$A$3))*(B1-ИНДЕКС($B$9:$G$9;$A$3))/(ИНДЕКС($B$9:$G$9;$B$3)-ИНДЕКС($B$9:$G$9;$A$3)))


Вот намонструозил. Но в файле есть расшифровка. Если всё ОК, промежуточные ячейки можно стереть

UPD. Черт, еще А2, А3, B3, B3 надо "раскрыть". Может, проще оставить расчет в "красной" ячейке as is) ...

Короче, смотрите, сам алгоритм еще проверьте.

Ну, и конечно, возможны и приятны взгляду короткие и элегантные решения, ну а мы так - по рабоче-крестьянски
К сообщению приложен файл: _primer11.xls(32Kb)


Сообщение отредактировал abtextime - Среда, 18.05.2016, 13:10
 
Ответить
Сообщение
Код
=ИНДЕКС($B$10:$G$13;$A$2;$A$3)+ЕСЛИ(ИНДЕКС($A$10:$A$13;$B$2)=ИНДЕКС($A$10:$A$13;$A$2);0;(ИНДЕКС($B$10:$G$13;$A$2;$A$3)-ИНДЕКС($B$10:$G$13;$A$2;$A$3))*(C1-ИНДЕКС($A$10:$A$13;$A$2))/(ИНДЕКС($A$10:$A$13;$B$2)-ИНДЕКС($A$10:$A$13;$A$2)))+ЕСЛИ(ИНДЕКС($B$9:$G$9;$A$3)=ИНДЕКС($B$9:$G$9;$B$3);0;(ИНДЕКС($B$10:$G$13;$A$2;$B$3)-ИНДЕКС($B$10:$G$13;$A$2;$A$3))*(B1-ИНДЕКС($B$9:$G$9;$A$3))/(ИНДЕКС($B$9:$G$9;$B$3)-ИНДЕКС($B$9:$G$9;$A$3)))


Вот намонструозил. Но в файле есть расшифровка. Если всё ОК, промежуточные ячейки можно стереть

UPD. Черт, еще А2, А3, B3, B3 надо "раскрыть". Может, проще оставить расчет в "красной" ячейке as is) ...

Короче, смотрите, сам алгоритм еще проверьте.

Ну, и конечно, возможны и приятны взгляду короткие и элегантные решения, ну а мы так - по рабоче-крестьянски

Автор - abtextime
Дата добавления - 18.05.2016 в 13:04
_Boroda_ Дата: Среда, 18.05.2016, 16:14 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ПРЕДСКАЗ(B1;--ИНДЕКС(A10:H13;ПОИСКПОЗ(C1;A10:A13;););ЕСЛИ(-ТЕКСТ(СТОЛБЕЦ(A:H)-ПОИСКПОЗ(B1;A9:H9);"[<0]1;[>1]1;\0");"";A9:H9))

Попаразитировал на файле abtextime. Синяя ячейка.
Но обе формулы с учетом того, что у зеленых совпадение точное. Если это не так, то тоже можно одной формулой сделать, но она посложнее получится.
К сообщению приложен файл: _primer11_1.xls(46Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ПРЕДСКАЗ(B1;--ИНДЕКС(A10:H13;ПОИСКПОЗ(C1;A10:A13;););ЕСЛИ(-ТЕКСТ(СТОЛБЕЦ(A:H)-ПОИСКПОЗ(B1;A9:H9);"[<0]1;[>1]1;\0");"";A9:H9))

Попаразитировал на файле abtextime. Синяя ячейка.
Но обе формулы с учетом того, что у зеленых совпадение точное. Если это не так, то тоже можно одной формулой сделать, но она посложнее получится.

Автор - _Boroda_
Дата добавления - 18.05.2016 в 16:14
Russel Дата: Среда, 18.05.2016, 16:24 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
[offtop]Не проще выяснить формулу расчета параметра в зависимости от давления и температуры?[/offtop]


QIWI 9173973973
 
Ответить
Сообщение[offtop]Не проще выяснить формулу расчета параметра в зависимости от давления и температуры?[/offtop]

Автор - Russel
Дата добавления - 18.05.2016 в 16:24
abtextime Дата: Среда, 18.05.2016, 16:29 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Russel, тоже об этом подумал. Но возможно, что как таковой алгебраической формулы нет, есть лишь усредненная статистика.

Но подход Ваш методически правильный


Сообщение отредактировал abtextime - Среда, 18.05.2016, 16:30
 
Ответить
СообщениеRussel, тоже об этом подумал. Но возможно, что как таковой алгебраической формулы нет, есть лишь усредненная статистика.

Но подход Ваш методически правильный

Автор - abtextime
Дата добавления - 18.05.2016 в 16:29
jakim Дата: Среда, 18.05.2016, 16:51 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Ещё один вариант с дополнительной строкой, в которой проделана интерполяция по давлению на все столбцы, а потом эта строка проинтеполирована по температуре.
К сообщению приложен файл: 1418179.xlsx(12Kb)


Сообщение отредактировал jakim - Среда, 18.05.2016, 16:53
 
Ответить
Сообщение
Ещё один вариант с дополнительной строкой, в которой проделана интерполяция по давлению на все столбцы, а потом эта строка проинтеполирована по температуре.

Автор - jakim
Дата добавления - 18.05.2016 в 16:51
GP75 Дата: Среда, 18.05.2016, 21:20 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Всем от души спасибо!
 
Ответить
СообщениеВсем от души спасибо!

Автор - GP75
Дата добавления - 18.05.2016 в 21:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитать среднее по 2-м значениям в таблице (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!