Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/отделение в другую ячейку значения перед последней запятой. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » отделение в другую ячейку значения перед последней запятой. (Формулы/Formulas)
отделение в другую ячейку значения перед последней запятой.
Goblinax Дата: Пятница, 20.05.2016, 01:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
добрый день!

В каждой ячейки столбика через запятую перечислено различное количество количество значений. Нужно отделить именно последние значение после запятой в новую ячейку.
Заранее спасибо за помощь
К сообщению приложен файл: 0434143.xlsx(8Kb)


Сообщение отредактировал Goblinax - Пятница, 20.05.2016, 01:12
 
Ответить
Сообщениедобрый день!

В каждой ячейки столбика через запятую перечислено различное количество количество значений. Нужно отделить именно последние значение после запятой в новую ячейку.
Заранее спасибо за помощь

Автор - Goblinax
Дата добавления - 20.05.2016 в 01:09
Michael_S Дата: Пятница, 20.05.2016, 02:27 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Код
=СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(A2;",";ПОВТОР(" ";100));100))
К сообщению приложен файл: Goblinax.xlsx(9Kb)


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщение
Код
=СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(A2;",";ПОВТОР(" ";100));100))

Автор - Michael_S
Дата добавления - 20.05.2016 в 02:27
Goblinax Дата: Пятница, 20.05.2016, 19:33 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо большое, очень помогли!

А не подскажете еще как можно сделать что бы отделять последнее значение перед запятой, но только то которое содержит определенный набор символов. (В моем случае это (495) и (499) - нужно отделить последние домашние телефоны из масива данных.)
[moder]Почему Вы сразу об этом не написали?[/moder]
- только сейчас осознал)
[moder]Так кладите пример нормальный[/moder]


Сообщение отредактировал Goblinax - Пятница, 20.05.2016, 22:46
 
Ответить
СообщениеСпасибо большое, очень помогли!

А не подскажете еще как можно сделать что бы отделять последнее значение перед запятой, но только то которое содержит определенный набор символов. (В моем случае это (495) и (499) - нужно отделить последние домашние телефоны из масива данных.)
[moder]Почему Вы сразу об этом не написали?[/moder]
- только сейчас осознал)
[moder]Так кладите пример нормальный[/moder]

Автор - Goblinax
Дата добавления - 20.05.2016 в 19:33
Goblinax Дата: Пятница, 20.05.2016, 23:39 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вот еще пример!
К сообщению приложен файл: 7078823.xlsx(8Kb)
 
Ответить
Сообщениевот еще пример!

Автор - Goblinax
Дата добавления - 20.05.2016 в 23:39
Michael_S Дата: Пятница, 20.05.2016, 23:47 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
как можно сделать
Макросом можно (или UDF, что, в принципе, одно и тоже).
Вариант с UDF:
[vba]
Код
Function МосковскийТелефон(S$) As String
Dim a, i&
a = Split(S, ",")
For i = UBound(a) To 0 Step -1
    If a(i) Like "*(495)*" Or a(i) Like "*(499)*" Then
        МосковскийТелефон = a(i)
        Exit Function
    End If
Next
End Function
[/vba]
К сообщению приложен файл: Goblinax.xlsm(14Kb)


ЯД: 41001136675053
WM: R389613894253


Сообщение отредактировал Michael_S - Суббота, 21.05.2016, 00:17
 
Ответить
Сообщение
как можно сделать
Макросом можно (или UDF, что, в принципе, одно и тоже).
Вариант с UDF:
[vba]
Код
Function МосковскийТелефон(S$) As String
Dim a, i&
a = Split(S, ",")
For i = UBound(a) To 0 Step -1
    If a(i) Like "*(495)*" Or a(i) Like "*(499)*" Then
        МосковскийТелефон = a(i)
        Exit Function
    End If
Next
End Function
[/vba]

Автор - Michael_S
Дата добавления - 20.05.2016 в 23:47
Goblinax Дата: Суббота, 21.05.2016, 00:04 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо!
В Вашем примере 4я строчка не правильно сделалась
 
Ответить
СообщениеСпасибо!
В Вашем примере 4я строчка не правильно сделалась

Автор - Goblinax
Дата добавления - 21.05.2016 в 00:04
_Boroda_ Дата: Суббота, 21.05.2016, 00:09 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
нужно отделить последние домашние телефоны из масива данных

А зачем Вам тогда запятая? Вот так можно (даже немассивная)
Код
=ЕСЛИОШИБКА(ПСТР(A2;ПРОСМОТР(;-ПОИСКПОЗ(ПСТР(A2;СТРОКА($1:$99);5);{"(495)":"(499)"};);СТРОКА($1:$99))-1;13);"")
К сообщению приложен файл: 7078823_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
нужно отделить последние домашние телефоны из масива данных

А зачем Вам тогда запятая? Вот так можно (даже немассивная)
Код
=ЕСЛИОШИБКА(ПСТР(A2;ПРОСМОТР(;-ПОИСКПОЗ(ПСТР(A2;СТРОКА($1:$99);5);{"(495)":"(499)"};);СТРОКА($1:$99))-1;13);"")

Автор - _Boroda_
Дата добавления - 21.05.2016 в 00:09
Michael_S Дата: Суббота, 21.05.2016, 00:18 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
В Вашем примере 4я строчка не правильно сделалась

Да, точно, была техническая оЧеПятка...
заменил. исправил.


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщение
В Вашем примере 4я строчка не правильно сделалась

Да, точно, была техническая оЧеПятка...
заменил. исправил.

Автор - Michael_S
Дата добавления - 21.05.2016 в 00:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » отделение в другую ячейку значения перед последней запятой. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!