Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать количество единиц между двумя значениями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать количество единиц между двумя значениями (Формулы/Formulas)
Посчитать количество единиц между двумя значениями
dorik Дата: Пятница, 20.05.2016, 11:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прикрепил фаил.. В первом столбце цифровые данные. Во втором столбце как должна считать формула, вбил результат вручную. Тоесть нужно посчитать сколько единиц идет подряд до слова STOP (тоесть цифры 2). К примеру между двумя стопами 5 единиц, и нужно отнять 1 , получиться 4.
К сообщению приложен файл: 1231.xlsx(8Kb)
 
Ответить
СообщениеПрикрепил фаил.. В первом столбце цифровые данные. Во втором столбце как должна считать формула, вбил результат вручную. Тоесть нужно посчитать сколько единиц идет подряд до слова STOP (тоесть цифры 2). К примеру между двумя стопами 5 единиц, и нужно отнять 1 , получиться 4.

Автор - dorik
Дата добавления - 20.05.2016 в 11:03
_Boroda_ Дата: Пятница, 20.05.2016, 11:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(A2=2;СУММ(A1:ИНДЕКС(A:A;ПРОСМОТР(;-1/(A$1:A1>1);СТРОКА(A$1:A1))+1))-1;"")

Только шапку еще в таблицу добавьте (я предположил, что она и так в реальной таблице уже есть)

Добавлено.
Немного неполная формула. Не учтен случай с двумя двойками подряд. Вот так
Код
=ЕСЛИ(A2=2;(A1<>2)*(СУММ(A1:ИНДЕКС(A:A;ПРОСМОТР(;-1/(A$1:A1>1);СТРОКА(A$1:A1))+1))-1);"")

Файл перевложил
К сообщению приложен файл: 1231_2.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Пятница, 20.05.2016, 11:51
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(A2=2;СУММ(A1:ИНДЕКС(A:A;ПРОСМОТР(;-1/(A$1:A1>1);СТРОКА(A$1:A1))+1))-1;"")

Только шапку еще в таблицу добавьте (я предположил, что она и так в реальной таблице уже есть)

Добавлено.
Немного неполная формула. Не учтен случай с двумя двойками подряд. Вот так
Код
=ЕСЛИ(A2=2;(A1<>2)*(СУММ(A1:ИНДЕКС(A:A;ПРОСМОТР(;-1/(A$1:A1>1);СТРОКА(A$1:A1))+1))-1);"")

Файл перевложил

Автор - _Boroda_
Дата добавления - 20.05.2016 в 11:14
buchlotnik Дата: Пятница, 20.05.2016, 11:27 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так вышло:
Код
=ЕСЛИ(A2=2;СЧЁТЕСЛИ($A$1:A2;1)-СУММ($D$1:D1)-СЧЁТ($D$1:D1)-1;"")

UPD файл перевлил, шапку добавил
[moder]Михаил, что-то с файлом. Почему-то мой скачивается. Перевложешь? Только назови как-нибудь иначе, возможно, заглючило что-то.
К сообщению приложен файл: 123.xlsx(9Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 20.05.2016, 11:47
 
Ответить
Сообщениетак вышло:
Код
=ЕСЛИ(A2=2;СЧЁТЕСЛИ($A$1:A2;1)-СУММ($D$1:D1)-СЧЁТ($D$1:D1)-1;"")

UPD файл перевлил, шапку добавил
[moder]Михаил, что-то с файлом. Почему-то мой скачивается. Перевложешь? Только назови как-нибудь иначе, возможно, заглючило что-то.

Автор - buchlotnik
Дата добавления - 20.05.2016 в 11:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать количество единиц между двумя значениями (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!