Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование данных с нескольких ячеек и страниц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных с нескольких ячеек и страниц (Формулы/Formulas)
Суммирование данных с нескольких ячеек и страниц
mabika Дата: Вторник, 24.05.2016, 14:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем привет. Нужна помощь. Запуталась в выборе правильной функций и формул для обработки данных. Хотя бы подсказка, что использовать было бы великолено, не говоря уже об готовой фопмуле.

Если не лень просмотрите прикреплённый файл.
К сообщению приложен файл: 5069705.xlsx(12Kb)
 
Ответить
СообщениеВсем привет. Нужна помощь. Запуталась в выборе правильной функций и формул для обработки данных. Хотя бы подсказка, что использовать было бы великолено, не говоря уже об готовой фопмуле.

Если не лень просмотрите прикреплённый файл.

Автор - mabika
Дата добавления - 24.05.2016 в 14:44
_Boroda_ Дата: Вторник, 24.05.2016, 14:57 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? Для любого месяца
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/('1'!B$2:B$999=ЛЕВСИМВ('1'!B$2;8)&ТЕКСТ(СТРОКА(A1);"00"));'1'!E$2:E$999)-A3;)


Добавлено
И переписал Вам еще формулу для листа 1. Теперь она одинаковая для любого Тотала, не нужно менять диапазоны
Код
=СУММЕСЛИ($B$1:$B28;$B29;E$1:E28)
Файл перевложил

Еще добавлено
Там все проще -
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ДЕНЬ('1'!B$2:B$999)=СТРОКА(A1));'1'!E$2:E$999)-A3;)
Файл перевложил
Или (при отсутствии такого дня даст минус)
Код
=СУММПРОИЗВ((ДЕНЬ('1'!B$2:B$999)=СТРОКА(A1))*'1'!E$2:E$999)/2-A3
К сообщению приложен файл: 5069705_3.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? Для любого месяца
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/('1'!B$2:B$999=ЛЕВСИМВ('1'!B$2;8)&ТЕКСТ(СТРОКА(A1);"00"));'1'!E$2:E$999)-A3;)


Добавлено
И переписал Вам еще формулу для листа 1. Теперь она одинаковая для любого Тотала, не нужно менять диапазоны
Код
=СУММЕСЛИ($B$1:$B28;$B29;E$1:E28)
Файл перевложил

Еще добавлено
Там все проще -
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ДЕНЬ('1'!B$2:B$999)=СТРОКА(A1));'1'!E$2:E$999)-A3;)
Файл перевложил
Или (при отсутствии такого дня даст минус)
Код
=СУММПРОИЗВ((ДЕНЬ('1'!B$2:B$999)=СТРОКА(A1))*'1'!E$2:E$999)/2-A3

Автор - _Boroda_
Дата добавления - 24.05.2016 в 14:57
китин Дата: Вторник, 24.05.2016, 15:01 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам не хворать! :D так надо? формула массива (вводится Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС('1'!$E$2:$E$61;НАИМЕНЬШИЙ(ЕСЛИ('1'!$C$2:$C$61="Total:";СТРОКА('1'!$E$2:$E$61)-1);СТРОКА(A1)))-A3;"")
К сообщению приложен файл: 069705.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам не хворать! :D так надо? формула массива (вводится Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС('1'!$E$2:$E$61;НАИМЕНЬШИЙ(ЕСЛИ('1'!$C$2:$C$61="Total:";СТРОКА('1'!$E$2:$E$61)-1);СТРОКА(A1)))-A3;"")

Автор - китин
Дата добавления - 24.05.2016 в 15:01
mabika Дата: Вторник, 24.05.2016, 15:09 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Огромное спасибо за помощь. Для меня они почти, что универсальны, смогу их применить к моим 12 листовым огромным файлам, где все данные переплетенны и взаимосвязанны.

:hands: hands hands specool

Решенно, надо уроки по-екселлу брать. lol


Сообщение отредактировал mabika - Вторник, 24.05.2016, 15:14
 
Ответить
СообщениеОгромное спасибо за помощь. Для меня они почти, что универсальны, смогу их применить к моим 12 листовым огромным файлам, где все данные переплетенны и взаимосвязанны.

:hands: hands hands specool

Решенно, надо уроки по-екселлу брать. lol

Автор - mabika
Дата добавления - 24.05.2016 в 15:09
mabika Дата: Вторник, 24.05.2016, 15:41 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Boroda, огромное спасило за решение проблемы. <_<


Сообщение отредактировал mabika - Вторник, 24.05.2016, 15:44
 
Ответить
СообщениеBoroda, огромное спасило за решение проблемы. <_<

Автор - mabika
Дата добавления - 24.05.2016 в 15:41
mabika Дата: Среда, 25.05.2016, 11:53 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день.

Это опять я. Зашла в тупик с корректировкой формулы. Подсчёт по наименовию ни как не хояет подсчитаться.

Заранее большое спасибо. :)
[moder]Кто как, а я ничего не понял[/moder]
К сообщению приложен файл: 8392552.xlsx(19Kb)


Сообщение отредактировал _Boroda_ - Среда, 25.05.2016, 12:00
 
Ответить
СообщениеДобрый день.

Это опять я. Зашла в тупик с корректировкой формулы. Подсчёт по наименовию ни как не хояет подсчитаться.

Заранее большое спасибо. :)
[moder]Кто как, а я ничего не понял[/moder]

Автор - mabika
Дата добавления - 25.05.2016 в 11:53
mabika Дата: Среда, 25.05.2016, 18:15 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Извините если не ясно выразилась.

В столбце А перечисленны товары разного наименования, в столбце В цена,в столбце С нужно суммировать продукт одного наименования. Ни как не смогла прописать до конца формулу.

Ещё раз извините и спасибо огромное. :)
К сообщению приложен файл: 0907111.xlsx(19Kb)


Сообщение отредактировал mabika - Среда, 25.05.2016, 18:32
 
Ответить
СообщениеИзвините если не ясно выразилась.

В столбце А перечисленны товары разного наименования, в столбце В цена,в столбце С нужно суммировать продукт одного наименования. Ни как не смогла прописать до конца формулу.

Ещё раз извините и спасибо огромное. :)

Автор - mabika
Дата добавления - 25.05.2016 в 18:15
gling Дата: Среда, 25.05.2016, 19:16 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Здравствуйте. Может так?
Код
=СУММЕСЛИ('1'!D2:D29;"membership";'1'!E2:E28)
 
Ответить
СообщениеЗдравствуйте. Может так?
Код
=СУММЕСЛИ('1'!D2:D29;"membership";'1'!E2:E28)

Автор - gling
Дата добавления - 25.05.2016 в 19:16
mabika Дата: Четверг, 26.05.2016, 11:10 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, спасибо, что откликнулись.
Формула работает только для указанного диапазона. Таблица отоброжает продажи целого месяца и каждый день есть "membership". Возможно ли, прописать формулу так, чтобы она в каждой отдельной ячейке суммировала, например только "membership" каждого дня?

Столбец А дата, Столбец В наименование продукции. Столбец С сумма, Столбец Д = ячейке из Столбца С если та же ячейка в столбце В "membership".

Спасибо огромное :)


Сообщение отредактировал mabika - Четверг, 26.05.2016, 11:14
 
Ответить
СообщениеЗдравствуйте, спасибо, что откликнулись.
Формула работает только для указанного диапазона. Таблица отоброжает продажи целого месяца и каждый день есть "membership". Возможно ли, прописать формулу так, чтобы она в каждой отдельной ячейке суммировала, например только "membership" каждого дня?

Столбец А дата, Столбец В наименование продукции. Столбец С сумма, Столбец Д = ячейке из Столбца С если та же ячейка в столбце В "membership".

Спасибо огромное :)

Автор - mabika
Дата добавления - 26.05.2016 в 11:10
_Boroda_ Дата: Четверг, 26.05.2016, 12:59 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((ДЕНЬ('1'!B$2:B$999)=СТРОКА(A1))*('1'!D$2:D$999="Membership")*'1'!E$2:E$999)
К сообщению приложен файл: 0907111_1.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((ДЕНЬ('1'!B$2:B$999)=СТРОКА(A1))*('1'!D$2:D$999="Membership")*'1'!E$2:E$999)

Автор - _Boroda_
Дата добавления - 26.05.2016 в 12:59
mabika Дата: Четверг, 26.05.2016, 13:51 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Огромная благодарность за помощь, за Ваше время и ваше терпение.

Извините за беспокойство. Отдельно задавала вопросы надеясь в остольном самой разобраться. К сожалению знания не хватает.
Помогите если можете разобраться, что я делаю не правильно. :)
К сообщению приложен файл: sample_for_sumi.xlsx(22Kb)


Сообщение отредактировал mabika - Четверг, 26.05.2016, 13:55
 
Ответить
СообщениеОгромная благодарность за помощь, за Ваше время и ваше терпение.

Извините за беспокойство. Отдельно задавала вопросы надеясь в остольном самой разобраться. К сожалению знания не хватает.
Помогите если можете разобраться, что я делаю не правильно. :)

Автор - mabika
Дата добавления - 26.05.2016 в 13:51
_Boroda_ Дата: Четверг, 26.05.2016, 14:06 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну если у Вас там теперь даты есть, то зачем огород городить?
Код
=СУММПРОИЗВ(('1'!B$2:B$999=A3)*('1'!C$2:C$999="Total:")*'1'!E$2:E$999)

Даже так можно
Код
=СУММЕСЛИ('1'!B$2:B$999;A3;'1'!E$2:E$999)/2

А для TOTAL Bar что Вам нужно - я не понял.
И эту фразу тоже не понял
Цитата
Мне бы формулу без указания маршутов (как в этой ячейкп ссылка на фаил), так чтобы смогла копировать формулы в любой другой фаил.
К сообщению приложен файл: 1556855.xlsx(23Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу если у Вас там теперь даты есть, то зачем огород городить?
Код
=СУММПРОИЗВ(('1'!B$2:B$999=A3)*('1'!C$2:C$999="Total:")*'1'!E$2:E$999)

Даже так можно
Код
=СУММЕСЛИ('1'!B$2:B$999;A3;'1'!E$2:E$999)/2

А для TOTAL Bar что Вам нужно - я не понял.
И эту фразу тоже не понял
Цитата
Мне бы формулу без указания маршутов (как в этой ячейкп ссылка на фаил), так чтобы смогла копировать формулы в любой другой фаил.

Автор - _Boroda_
Дата добавления - 26.05.2016 в 14:06
mabika Дата: Четверг, 26.05.2016, 14:28 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо :)

В прикрепленном файле формулы работают замечательно. Одна проблема, когда я их копирую в другой файл, тогда она выглядит так:

Код
=SUMPRODUCT(('[1556855.xlsx]1'!B$2:B$999=A3)*('[1556855.xlsx]1'!C$2:C$999="Total:")*'[1556855.xlsx]1'!E$2:E$999)
-

"[1556855.xlsx]" - это имело в виду, говоря об "Мне бы формулу без указания маршутов (как в этой ячейкп ссылка на фаил), так чтобы смогла копировать формулы в любой другой фаил."

Извини Ворода, намучалься ты со смной.
[moder]Для формул используйте теги - кнопка fx. Поправил Вам[/moder]


Сообщение отредактировал _Boroda_ - Четверг, 26.05.2016, 14:31
 
Ответить
СообщениеСпасибо :)

В прикрепленном файле формулы работают замечательно. Одна проблема, когда я их копирую в другой файл, тогда она выглядит так:

Код
=SUMPRODUCT(('[1556855.xlsx]1'!B$2:B$999=A3)*('[1556855.xlsx]1'!C$2:C$999="Total:")*'[1556855.xlsx]1'!E$2:E$999)
-

"[1556855.xlsx]" - это имело в виду, говоря об "Мне бы формулу без указания маршутов (как в этой ячейкп ссылка на фаил), так чтобы смогла копировать формулы в любой другой фаил."

Извини Ворода, намучалься ты со смной.
[moder]Для формул используйте теги - кнопка fx. Поправил Вам[/moder]

Автор - mabika
Дата добавления - 26.05.2016 в 14:28
mabika Дата: Четверг, 26.05.2016, 14:58 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
hands hands hands

Огромнейшее спасибо.

respect
 
Ответить
Сообщениеhands hands hands

Огромнейшее спасибо.

respect

Автор - mabika
Дата добавления - 26.05.2016 в 14:58
mabika Дата: Понедельник, 30.05.2016, 14:52 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Привет опять, :)

Извините за беспокойство, но никак не могу подкоректировать формулу.

Код
=SUMPRODUCT((DAY('1'!B$2:B$999)=ROW(B2))*('1'!D$2:D$999="Membership")*'1'!E$2:E$999)


ПОжалуйста, помогите разобраться, что деляю не правильно.
Намучалась очень.

Спасибо заранее. <_<
К сообщению приложен файл: 05.2016_items.xlsx(46Kb)


Сообщение отредактировал mabika - Понедельник, 30.05.2016, 17:46
 
Ответить
СообщениеПривет опять, :)

Извините за беспокойство, но никак не могу подкоректировать формулу.

Код
=SUMPRODUCT((DAY('1'!B$2:B$999)=ROW(B2))*('1'!D$2:D$999="Membership")*'1'!E$2:E$999)


ПОжалуйста, помогите разобраться, что деляю не правильно.
Намучалась очень.

Спасибо заранее. <_<

Автор - mabika
Дата добавления - 30.05.2016 в 14:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных с нескольких ячеек и страниц (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!