Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных из таблиц только заполненных строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из таблиц только заполненных строк (Формулы/Formulas)
Перенос данных из таблиц только заполненных строк
andreika21 Дата: Пятница, 03.06.2016, 11:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

Здравствуйте.
Есть таблица на месяц, надо данные из этой таблицы перенести в другую по возрастании дат только заполненные строчки. Помогите пожалуйста решить эту проблемку.
К сообщению приложен файл: 2016-06-03.xls(28Kb)
 
Ответить
СообщениеЗдравствуйте.
Есть таблица на месяц, надо данные из этой таблицы перенести в другую по возрастании дат только заполненные строчки. Помогите пожалуйста решить эту проблемку.

Автор - andreika21
Дата добавления - 03.06.2016 в 11:22
китин Дата: Пятница, 03.06.2016, 11:31 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Здравствуйте .так надо? масс ивная формула
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$34;НАИМЕНЬШИЙ(ЕСЛИ($C$4:$C$34<>"";СТРОКА(B$4:B$34)-3);СТРОКА(A1)));"")
К сообщению приложен файл: _2016-06-03.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 03.06.2016, 11:32
 
Ответить
СообщениеЗдравствуйте .так надо? масс ивная формула
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$4:B$34;НАИМЕНЬШИЙ(ЕСЛИ($C$4:$C$34<>"";СТРОКА(B$4:B$34)-3);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 03.06.2016 в 11:31
andreika21 Дата: Пятница, 03.06.2016, 11:44 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

китин, Спасибо большое, на один столбец работает попробую на другие переделать, у вас в формуле запятая надо " ; "
 
Ответить
Сообщениекитин, Спасибо большое, на один столбец работает попробую на другие переделать, у вас в формуле запятая надо " ; "

Автор - andreika21
Дата добавления - 03.06.2016 в 11:44
andreika21 Дата: Пятница, 03.06.2016, 11:53 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

китин, Спасибо за файл, разобрался формула работала у меня формат не тот был.
 
Ответить
Сообщениекитин, Спасибо за файл, разобрался формула работала у меня формат не тот был.

Автор - andreika21
Дата добавления - 03.06.2016 в 11:53
_Boroda_ Дата: Пятница, 03.06.2016, 16:20 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А у Вас за одну дату несколько одинаковых городов не бывает? И, вроде, Вам по возрастанию дат нужно было?
Предлагаю сводную таблицу. В файле сделал на 9999 строк. Для обновления - прав. кн. мыши на ней - Обновить.
К сообщению приложен файл: 2016-06-03_2.xlsx(16Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА у Вас за одну дату несколько одинаковых городов не бывает? И, вроде, Вам по возрастанию дат нужно было?
Предлагаю сводную таблицу. В файле сделал на 9999 строк. Для обновления - прав. кн. мыши на ней - Обновить.

Автор - _Boroda_
Дата добавления - 03.06.2016 в 16:20
jakim Дата: Пятница, 03.06.2016, 18:32 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Предлагаю вариант для ексель 2010+.
К сообщению приложен файл: of_2016-06-03.xlsx(12Kb)
 
Ответить
Сообщение
Предлагаю вариант для ексель 2010+.

Автор - jakim
Дата добавления - 03.06.2016 в 18:32
andreika21 Дата: Понедельник, 06.06.2016, 08:01 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 99
Репутация: 1 ±
Замечаний: 0% ±

_Boroda_, jakim, Спасибо за помощь, тема закрыта.
 
Ответить
Сообщение_Boroda_, jakim, Спасибо за помощь, тема закрыта.

Автор - andreika21
Дата добавления - 06.06.2016 в 08:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из таблиц только заполненных строк (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!