Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как отсортировать данные в столбце по ключевым словам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как отсортировать данные в столбце по ключевым словам (Формулы/Formulas)
Как отсортировать данные в столбце по ключевым словам
vermut Дата: Вторник, 07.06.2016, 09:49 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Уважаемые профи, есть столбец ктр содержит наименования причем в ячейке может быть и слово и цифра совместно, как отсортировать эти данные по ключевым словам в соседние столбцы?
Пример прикладываю
К сообщению приложен файл: 4591911.xlsx(14Kb)
 
Ответить
СообщениеУважаемые профи, есть столбец ктр содержит наименования причем в ячейке может быть и слово и цифра совместно, как отсортировать эти данные по ключевым словам в соседние столбцы?
Пример прикладываю

Автор - vermut
Дата добавления - 07.06.2016 в 09:49
китин Дата: Вторник, 07.06.2016, 10:06 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо? массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$3:$E$11;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$2;$E$3:$E$11));СТРОКА($E$3:$E$11)-2);СТРОКА(A1)));"")
К сообщению приложен файл: 1911.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак надо? массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$3:$E$11;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$2;$E$3:$E$11));СТРОКА($E$3:$E$11)-2);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 07.06.2016 в 10:06
vermut Дата: Вторник, 07.06.2016, 10:19 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
а как протянуть формулу чтобы могла добавлять новые позиции?
[moder]Не нужно цитировать весь пост - это нарушение Правил форума. Удалил.
К сообщению приложен файл: 1911-2-.xlsx(15Kb)


Сообщение отредактировал _Boroda_ - Вторник, 07.06.2016, 10:30
 
Ответить
Сообщениеа как протянуть формулу чтобы могла добавлять новые позиции?
[moder]Не нужно цитировать весь пост - это нарушение Правил форума. Удалил.

Автор - vermut
Дата добавления - 07.06.2016 в 10:19
китин Дата: Вторник, 07.06.2016, 10:32 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а просто в формуле все $E$11 замените на нужную вам цифру( вместо 11 поставьте 1000 к примеру)
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$3:$E$1000;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$2;$E$3:$E$1000));СТРОКА($E$3:$E$1000)-2);СТРОКА(A1)));"")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа просто в формуле все $E$11 замените на нужную вам цифру( вместо 11 поставьте 1000 к примеру)
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$3:$E$1000;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$2;$E$3:$E$1000));СТРОКА($E$3:$E$1000)-2);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 07.06.2016 в 10:32
_Boroda_ Дата: Вторник, 07.06.2016, 10:37 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И не забудьте, что это формула массива - она вводится одновременным нажатием Контрл Шифт Ентер
Еще вариант обычной формулой, но значения пишутся снизу вверх
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2;$E$3:$E$999)/ЕНД(ПОИСКПОЗ($E$3:$E$999;F$2:F2;));$E$3:$E$999);"")

Кстати, там заодно еще и уникальные значения будут
К сообщению приложен файл: 1911-2-1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ не забудьте, что это формула массива - она вводится одновременным нажатием Контрл Шифт Ентер
Еще вариант обычной формулой, но значения пишутся снизу вверх
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2;$E$3:$E$999)/ЕНД(ПОИСКПОЗ($E$3:$E$999;F$2:F2;));$E$3:$E$999);"")

Кстати, там заодно еще и уникальные значения будут

Автор - _Boroda_
Дата добавления - 07.06.2016 в 10:37
vermut Дата: Вторник, 07.06.2016, 10:51 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Еще вариант обычной формулой,

а как мне добавить формулу для нового ключевого слова, пробую не получается
К сообщению приложен файл: 1911-2-8.xlsx(15Kb)
 
Ответить
Сообщение
Еще вариант обычной формулой,

а как мне добавить формулу для нового ключевого слова, пробую не получается

Автор - vermut
Дата добавления - 07.06.2016 в 10:51
vermut Дата: Вторник, 07.06.2016, 11:01 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Спасибо все разобралась!
 
Ответить
СообщениеСпасибо все разобралась!

Автор - vermut
Дата добавления - 07.06.2016 в 11:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как отсортировать данные в столбце по ключевым словам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!