Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменение суммы взависимости от даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение суммы взависимости от даты (Формулы/Formulas)
Изменение суммы взависимости от даты
lenacia Дата: Четверг, 09.06.2016, 10:58 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Помогите мне в написании формулы. Есть склад А и склад В. В таблицу регулярно заносятся данные. Так вот, мне необходимо, что б в зависимости от даты в ячейке В3 проставлялись суммы по складам в ячейках Е2 иЕ3
То есть если дата 08.06.2016 по в ячейке по склад А сумма будет 93 165,10, а по склад В 116 648,00
Ну и так далее, суммы меняются, когда ставлю определенную дату.
К сообщению приложен файл: 7824731.xls(48Kb)
 
Ответить
СообщениеДобрый день. Помогите мне в написании формулы. Есть склад А и склад В. В таблицу регулярно заносятся данные. Так вот, мне необходимо, что б в зависимости от даты в ячейке В3 проставлялись суммы по складам в ячейках Е2 иЕ3
То есть если дата 08.06.2016 по в ячейке по склад А сумма будет 93 165,10, а по склад В 116 648,00
Ну и так далее, суммы меняются, когда ставлю определенную дату.

Автор - lenacia
Дата добавления - 09.06.2016 в 10:58
Manyasha Дата: Четверг, 09.06.2016, 11:09 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
lenacia, можно так:
Код
=СУММЕСЛИМН($G$7:$G$15;$A$7:$A$15;"А";$D$7:$D$15;$B$3)
К сообщению приложен файл: 7824731-1.xls(48Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеlenacia, можно так:
Код
=СУММЕСЛИМН($G$7:$G$15;$A$7:$A$15;"А";$D$7:$D$15;$B$3)

Автор - Manyasha
Дата добавления - 09.06.2016 в 11:09
_Boroda_ Дата: Четверг, 09.06.2016, 11:10 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИМН(G7:G99;A7:A99;"А";D7:D99;B3)

Марина, :D
Тогда еще
Код
=СУММПРОИЗВ(G7:G99*(A7:A99="А")*(D7:D99=B3))
К сообщению приложен файл: 7824731_1.xls(50Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИМН(G7:G99;A7:A99;"А";D7:D99;B3)

Марина, :D
Тогда еще
Код
=СУММПРОИЗВ(G7:G99*(A7:A99="А")*(D7:D99=B3))

Автор - _Boroda_
Дата добавления - 09.06.2016 в 11:10
lenacia Дата: Четверг, 09.06.2016, 11:36 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо большое! Работает. Меня в принципе два варианта устраивают!
 
Ответить
СообщениеСпасибо большое! Работает. Меня в принципе два варианта устраивают!

Автор - lenacia
Дата добавления - 09.06.2016 в 11:36
lenacia Дата: Четверг, 09.06.2016, 15:23 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Коллеги, разрешите еще раз побеспокоить. У меня тут появились новые вводные. Нельзя ли еще раз доработать мою таблицу?
Остается все тоже самое, только мне еще нужно дополнительные графы. Сумму по не принятым товарам. Принцип тот же, только отсеивать графу где проставлено значение "принято" (графа F).
Таким образом, если брать 08.06.2016, то в ячейке L2 по складу А должна появится сумму 6 585,10. Ну и так далее в зависимости от изменения даты.
К сообщению приложен файл: 0583790.xls(50Kb)
 
Ответить
СообщениеКоллеги, разрешите еще раз побеспокоить. У меня тут появились новые вводные. Нельзя ли еще раз доработать мою таблицу?
Остается все тоже самое, только мне еще нужно дополнительные графы. Сумму по не принятым товарам. Принцип тот же, только отсеивать графу где проставлено значение "принято" (графа F).
Таким образом, если брать 08.06.2016, то в ячейке L2 по складу А должна появится сумму 6 585,10. Ну и так далее в зависимости от изменения даты.

Автор - lenacia
Дата добавления - 09.06.2016 в 15:23
_Boroda_ Дата: Четверг, 09.06.2016, 15:41 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Аналогично
Код
=СУММЕСЛИМН(G7:G99;A7:A99;"А";D7:D99;B3;F7:F99;"<>принят")

И не путайте русские и английские буквы
Добавил Вам проверку данных в зеленые ячейки (Данные - Проверка)
И еще не стОит делать СУММЕСЛИМН на 11115 строк. Это довольно задумчивая функция.
К сообщению приложен файл: 0583790_1.xls(52Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАналогично
Код
=СУММЕСЛИМН(G7:G99;A7:A99;"А";D7:D99;B3;F7:F99;"<>принят")

И не путайте русские и английские буквы
Добавил Вам проверку данных в зеленые ячейки (Данные - Проверка)
И еще не стОит делать СУММЕСЛИМН на 11115 строк. Это довольно задумчивая функция.

Автор - _Boroda_
Дата добавления - 09.06.2016 в 15:41
lenacia Дата: Четверг, 09.06.2016, 16:09 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Спасибо.
я в принципе к формуле так и добавляла "<>принят", только почему то не выходило, вылезало окошко со справкой и формулу не принимало.

А почему нежелательно на 11115 строк? У меня таблица очень большая.
 
Ответить
Сообщение_Boroda_, Спасибо.
я в принципе к формуле так и добавляла "<>принят", только почему то не выходило, вылезало окошко со справкой и формулу не принимало.

А почему нежелательно на 11115 строк? У меня таблица очень большая.

Автор - lenacia
Дата добавления - 09.06.2016 в 16:09
_Boroda_ Дата: Четверг, 09.06.2016, 16:12 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
почему нежелательно на 11115 строк?

Это довольно задумчивая функция.
Впрочем, если СУММЕСЛИМН у Вас всего в нескольких ячейках, то терпимо.

формулу не принимало
Скорее всего с запятыми или с кавычками напутали


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
почему нежелательно на 11115 строк?

Это довольно задумчивая функция.
Впрочем, если СУММЕСЛИМН у Вас всего в нескольких ячейках, то терпимо.

формулу не принимало
Скорее всего с запятыми или с кавычками напутали

Автор - _Boroda_
Дата добавления - 09.06.2016 в 16:12
lenacia Дата: Четверг, 09.06.2016, 16:27 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, еще разочек помучаю. А если по не принятым не делать привязку к дате, т.е. все суммы у которых нет признака принят заносились по складам в ячейки L2 и L3. То как должна быть формула?
К сообщению приложен файл: 2411277.xls(50Kb)
 
Ответить
Сообщение_Boroda_, еще разочек помучаю. А если по не принятым не делать привязку к дате, т.е. все суммы у которых нет признака принят заносились по складам в ячейки L2 и L3. То как должна быть формула?

Автор - lenacia
Дата добавления - 09.06.2016 в 16:27
_Boroda_ Дата: Четверг, 09.06.2016, 16:35 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Елена, попробуйте порассуждать логически.
Код
СУММЕСЛИМН(ЧтоСуммируем;СтолбецСкладов;Склад;СтолбецДат;Дата;СтолбецСистем;Система)
Какие 2 аргумента нужно убрать из формулы, чтобы исключить даты?

И еще раз обращаю Ваше внимание
не путайте русские и английские буквы


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕлена, попробуйте порассуждать логически.
Код
СУММЕСЛИМН(ЧтоСуммируем;СтолбецСкладов;Склад;СтолбецДат;Дата;СтолбецСистем;Система)
Какие 2 аргумента нужно убрать из формулы, чтобы исключить даты?

И еще раз обращаю Ваше внимание
не путайте русские и английские буквы

Автор - _Boroda_
Дата добавления - 09.06.2016 в 16:35
lenacia Дата: Пятница, 10.06.2016, 08:45 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Добрый день!
С буквами разобралась, поставила англ.
Я хочу что б по складам А и В те суммы которые не приняты, т.е. не стоит обозначение принят суммировались.
Я по аналогии прописываю формулу, только удаляю из него B3, что бы дата не участвовала, т,е не принятые склады должны посчитаться не только за 08.06 но и за 06.06 и 07.06. Но думаю что это неправильно, т.к мне выдает ошибку.
Вот какую формулу я прописываю в ячейку L3:

Код
=СУММЕСЛИМН(G7:G99;A7:A99;"B";D7:D99;F7:F99;"<>принят")
К сообщению приложен файл: 3390575.xls(50Kb)
 
Ответить
Сообщение_Boroda_, Добрый день!
С буквами разобралась, поставила англ.
Я хочу что б по складам А и В те суммы которые не приняты, т.е. не стоит обозначение принят суммировались.
Я по аналогии прописываю формулу, только удаляю из него B3, что бы дата не участвовала, т,е не принятые склады должны посчитаться не только за 08.06 но и за 06.06 и 07.06. Но думаю что это неправильно, т.к мне выдает ошибку.
Вот какую формулу я прописываю в ячейку L3:

Код
=СУММЕСЛИМН(G7:G99;A7:A99;"B";D7:D99;F7:F99;"<>принят")

Автор - lenacia
Дата добавления - 10.06.2016 в 08:45
Pelena Дата: Пятница, 10.06.2016, 08:53 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 10421
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
только удаляю из него B3

и диапазон с датами надо удалить
Код
=СУММЕСЛИМН(G7:G99;A7:A99;"B";F7:F99;"<>принят")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
только удаляю из него B3

и диапазон с датами надо удалить
Код
=СУММЕСЛИМН(G7:G99;A7:A99;"B";F7:F99;"<>принят")

Автор - Pelena
Дата добавления - 10.06.2016 в 08:53
_Boroda_ Дата: Пятница, 10.06.2016, 09:11 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не, я ж писал
СУММЕСЛИМН(ЧтоСуммируем;СтолбецСкладов;Склад;СтолбецДат;Дата;СтолбецСистем;Система)
Какие 2 аргумента нужно убрать из формулы, чтобы исключить даты?

Первый - СтолбецДат = D7:D99
Второй - Дата = B3
Остаться должно
Код
СУММЕСЛИМН(ЧтоСуммируем;СтолбецСкладов;Склад;СтолбецСистем;Система)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе, я ж писал
СУММЕСЛИМН(ЧтоСуммируем;СтолбецСкладов;Склад;СтолбецДат;Дата;СтолбецСистем;Система)
Какие 2 аргумента нужно убрать из формулы, чтобы исключить даты?

Первый - СтолбецДат = D7:D99
Второй - Дата = B3
Остаться должно
Код
СУММЕСЛИМН(ЧтоСуммируем;СтолбецСкладов;Склад;СтолбецСистем;Система)

Автор - _Boroda_
Дата добавления - 10.06.2016 в 09:11
lenacia Дата: Пятница, 10.06.2016, 09:53 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Pelena, простите меня неуча! У меня получилось!!!! НЕ без вашей помощи !
Огромное Вам спасибо!
 
Ответить
Сообщение_Boroda_, Pelena, простите меня неуча! У меня получилось!!!! НЕ без вашей помощи !
Огромное Вам спасибо!

Автор - lenacia
Дата добавления - 10.06.2016 в 09:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение суммы взависимости от даты (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!