Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перенести значения из списка значений в таблицу(шахматку) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенести значения из списка значений в таблицу(шахматку) (Формулы/Formulas)
перенести значения из списка значений в таблицу(шахматку)
champ Дата: Воскресенье, 10.07.2016, 19:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу помочь, кто знает как перенести значения в таблицу на лист2 с помощью формулы или формул.
К сообщению приложен файл: 0955825.xlsx(9Kb)
 
Ответить
СообщениеПрошу помочь, кто знает как перенести значения в таблицу на лист2 с помощью формулы или формул.

Автор - champ
Дата добавления - 10.07.2016 в 19:56
buchlotnik Дата: Понедельник, 11.07.2016, 02:07 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
что-то страшное соорудил %)
Код
=ЕСЛИ($A8=B$7;"###";ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ($A8&B$7;Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;0));ИНДЕКС(Лист1!$C$1:$D$6;ПОИСКПОЗ(B$7&$A8;Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;0);3-СЧЁТЕСЛИ($B$7:B$7;B$7));ИНДЕКС(Лист1!$C$1:$D$6;ПОИСКПОЗ($A8&B$7;Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;0);СЧЁТЕСЛИ($B$7:B$7;B$7))))
(массивка)
К сообщению приложен файл: 2095102.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениечто-то страшное соорудил %)
Код
=ЕСЛИ($A8=B$7;"###";ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ($A8&B$7;Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;0));ИНДЕКС(Лист1!$C$1:$D$6;ПОИСКПОЗ(B$7&$A8;Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;0);3-СЧЁТЕСЛИ($B$7:B$7;B$7));ИНДЕКС(Лист1!$C$1:$D$6;ПОИСКПОЗ($A8&B$7;Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;0);СЧЁТЕСЛИ($B$7:B$7;B$7))))
(массивка)

Автор - buchlotnik
Дата добавления - 11.07.2016 в 02:07
krosav4ig Дата: Понедельник, 11.07.2016, 02:27 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1342
Репутация: 536 ±
Замечаний: 0% ±

Excel 2007, 2013
еще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$C:$D;ПОИСКПОЗ(1;ПОИСК(Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;$A2&B$1&$A2)^0;);НОД(ПРОСМОТР(2;ПОИСК(Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;$A2&B$1&$A2))+ЕНЕЧЁТ(СТОЛБЕЦ());2));"###")
К сообщению приложен файл: 0687597.xlsx(10Kb)


(_)Õvõ(_)
 
Ответить
Сообщениееще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$C:$D;ПОИСКПОЗ(1;ПОИСК(Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;$A2&B$1&$A2)^0;);НОД(ПРОСМОТР(2;ПОИСК(Лист1!$A$1:$A$6&Лист1!$B$1:$B$6;$A2&B$1&$A2))+ЕНЕЧЁТ(СТОЛБЕЦ());2));"###")

Автор - krosav4ig
Дата добавления - 11.07.2016 в 02:27
champ Дата: Понедельник, 11.07.2016, 11:22 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, krosav4ig, спасибо все так. буду разбираться как работают формулы.
 
Ответить
Сообщениеbuchlotnik, krosav4ig, спасибо все так. буду разбираться как работают формулы.

Автор - champ
Дата добавления - 11.07.2016 в 11:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перенести значения из списка значений в таблицу(шахматку) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!