Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если в столбце находим 1, то в другой (но другу строку)стави - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в столбце находим 1, то в другой (но другу строку)стави (Формулы/Formulas)
Если в столбце находим 1, то в другой (но другу строку)стави
vladislaf Дата: Вторник, 12.07.2016, 19:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте!
Помогите с формулой пожалуйста.
Файлик в приложении. В столбец E надо поставить 1, если на строках ниже до пустой ячейки, но в столбце Q находим 1. Если не находим 1, то ставим 0.
Я сделал как должно быть. Как формулу такую составить?
Заранее благодарен за ответы!
К сообщению приложен файл: 5524998.xlsx(20Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите с формулой пожалуйста.
Файлик в приложении. В столбец E надо поставить 1, если на строках ниже до пустой ячейки, но в столбце Q находим 1. Если не находим 1, то ставим 0.
Я сделал как должно быть. Как формулу такую составить?
Заранее благодарен за ответы!

Автор - vladislaf
Дата добавления - 12.07.2016 в 19:24
krosav4ig Дата: Вторник, 12.07.2016, 19:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1342
Репутация: 536 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте.
Так нужно?
Код
=ЕСЛИ(Q2;"";Ч(МУМНОЖ(ПОИСКПОЗ({0;1};--Q3:Q$23;);{1:-1})>0))
К сообщению приложен файл: 0695890.xlsx(21Kb)


(_)Õvõ(_)
 
Ответить
СообщениеЗдравствуйте.
Так нужно?
Код
=ЕСЛИ(Q2;"";Ч(МУМНОЖ(ПОИСКПОЗ({0;1};--Q3:Q$23;);{1:-1})>0))

Автор - krosav4ig
Дата добавления - 12.07.2016 в 19:37
Pelena Дата: Вторник, 12.07.2016, 19:45 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9848
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант формулы массива
Код
=ЕСЛИ(Q2="";--ИЛИ(Q3:ИНДЕКС(Q3:$Q$999;ПОИСКПОЗ(ИСТИНА;ЕПУСТО(Q3:$Q$999);0))=1);"")
К сообщению приложен файл: 2492876.xlsx(21Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант формулы массива
Код
=ЕСЛИ(Q2="";--ИЛИ(Q3:ИНДЕКС(Q3:$Q$999;ПОИСКПОЗ(ИСТИНА;ЕПУСТО(Q3:$Q$999);0))=1);"")

Автор - Pelena
Дата добавления - 12.07.2016 в 19:45
_Boroda_ Дата: Вторник, 12.07.2016, 20:09 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня тоже формула массива
Код
=ЕСЛИ(Q2;"";--(СУММ(ЕСЛИОШИБКА(ПОИСКПОЗ({1;0};--Q3:Q99;);99)*{1;-1})<0))


Добавлено
[p.s.]Андрей, классная формула, похожим путем шли, только я намного дольше, но чуть доработать нужно - поставь в Q20 не единицу
К сообщению приложен файл: 5524998_1.xlsx(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Вторник, 12.07.2016, 20:11
 
Ответить
СообщениеУ меня тоже формула массива
Код
=ЕСЛИ(Q2;"";--(СУММ(ЕСЛИОШИБКА(ПОИСКПОЗ({1;0};--Q3:Q99;);99)*{1;-1})<0))


Добавлено
[p.s.]Андрей, классная формула, похожим путем шли, только я намного дольше, но чуть доработать нужно - поставь в Q20 не единицу

Автор - _Boroda_
Дата добавления - 12.07.2016 в 20:09
Nic70y Дата: Вторник, 12.07.2016, 20:09 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
В чем разница?
таже формула, что по ссылке:
Код
=ЕСЛИ(A2<>"";--ЕЧИСЛО(ПОИСКПОЗ(1;Q2:ИНДЕКС(Q$1:Q$34;ЕСЛИОШИБКА(ПОИСКПОЗ("*";A3:A$34;)+СТРОКА();34));));"")
со смещением на 1 строку


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 12.07.2016, 20:20
 
Ответить
СообщениеВ чем разница?
таже формула, что по ссылке:
Код
=ЕСЛИ(A2<>"";--ЕЧИСЛО(ПОИСКПОЗ(1;Q2:ИНДЕКС(Q$1:Q$34;ЕСЛИОШИБКА(ПОИСКПОЗ("*";A3:A$34;)+СТРОКА();34));));"")
со смещением на 1 строку

Автор - Nic70y
Дата добавления - 12.07.2016 в 20:09
_Boroda_ Дата: Вторник, 12.07.2016, 20:38 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А больше всего мне формула Ленина понравилась. Только я почему-то испытываю непреодолимое желание ее помучать. Формулу.
Результат мучений
Код
=ЕСЛИ(Q2;"";1-И(Q3:ИНДЕКС(Q3:Q99;ПОИСКПОЗ(;-Q3:Q99;))-1))
К сообщению приложен файл: 2492876_2.xlsx(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА больше всего мне формула Ленина понравилась. Только я почему-то испытываю непреодолимое желание ее помучать. Формулу.
Результат мучений
Код
=ЕСЛИ(Q2;"";1-И(Q3:ИНДЕКС(Q3:Q99;ПОИСКПОЗ(;-Q3:Q99;))-1))

Автор - _Boroda_
Дата добавления - 12.07.2016 в 20:38
vladislaf Дата: Вторник, 12.07.2016, 22:06 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо Nic70y. В прошлый раз не получилось, поэтому еще одну тему создал. Сейчас вышло с вашей. С остальными формулами не получилось, как начинаю растягивать, пропадают значки {} и ошибку выдает, видимо что-то не так делаю.
 
Ответить
СообщениеСпасибо Nic70y. В прошлый раз не получилось, поэтому еще одну тему создал. Сейчас вышло с вашей. С остальными формулами не получилось, как начинаю растягивать, пропадают значки {} и ошибку выдает, видимо что-то не так делаю.

Автор - vladislaf
Дата добавления - 12.07.2016 в 22:06
Pelena Дата: Вторник, 12.07.2016, 22:18 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9848
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Формула массива вводится сочетанием клавиш Ctrl+Shift+Enter


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива вводится сочетанием клавиш Ctrl+Shift+Enter

Автор - Pelena
Дата добавления - 12.07.2016 в 22:18
vladislaf Дата: Вторник, 12.07.2016, 22:27 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Есть, спасибо!
 
Ответить
СообщениеЕсть, спасибо!

Автор - vladislaf
Дата добавления - 12.07.2016 в 22:27
krosav4ig Дата: Среда, 13.07.2016, 02:19 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1342
Репутация: 536 ±
Замечаний: 0% ±

Excel 2007, 2013
классная формула

пасяба :)
поставь в Q20 не единицу

ну тогда
Код
=ЕСЛИ(Q2;"";СЧЁТ((СУММ(ПОИСКПОЗ({0;1};--Q3:Q$23;)*{1;-1})>0)^0))


(_)Õvõ(_)
 
Ответить
Сообщение
классная формула

пасяба :)
поставь в Q20 не единицу

ну тогда
Код
=ЕСЛИ(Q2;"";СЧЁТ((СУММ(ПОИСКПОЗ({0;1};--Q3:Q$23;)*{1;-1})>0)^0))

Автор - krosav4ig
Дата добавления - 13.07.2016 в 02:19
китин Дата: Среда, 13.07.2016, 07:24 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3423
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула Ленина

:D :D :D %)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
формула Ленина

:D :D :D %)

Автор - китин
Дата добавления - 13.07.2016 в 07:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в столбце находим 1, то в другой (но другу строку)стави (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!