Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отображение "0" в формуле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение "0" в формуле (Формулы/Formulas)
Отображение "0" в формуле
migo Дата: Четверг, 14.07.2016, 09:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Всем привет!

Подскажите плз, как решить проблему:
При сцепке данных из трех ячеек, в получаемом значении "0" не проставляются, а именно:
сцепляем
Код
=СЦЕПИТЬ(A2;" ";B2;" ";C2)
три ячейки со значениями "77" "АА" "0123" и получаем "77 АА 123", вместо "77 АА 0123"
При этом, в настройках отображение нулей активировано, а в ячейке со значением "0123" данные указаны в формате "0###".
[moder]Формулу следует оформлять тегами (кнопка Fx)[/moder]
К сообщению приложен файл: -1.xlsx(61Kb)


Сообщение отредактировал Pelena - Четверг, 14.07.2016, 09:46
 
Ответить
СообщениеВсем привет!

Подскажите плз, как решить проблему:
При сцепке данных из трех ячеек, в получаемом значении "0" не проставляются, а именно:
сцепляем
Код
=СЦЕПИТЬ(A2;" ";B2;" ";C2)
три ячейки со значениями "77" "АА" "0123" и получаем "77 АА 123", вместо "77 АА 0123"
При этом, в настройках отображение нулей активировано, а в ячейке со значением "0123" данные указаны в формате "0###".
[moder]Формулу следует оформлять тегами (кнопка Fx)[/moder]

Автор - migo
Дата добавления - 14.07.2016 в 09:14
_Boroda_ Дата: Четверг, 14.07.2016, 09:16 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СЦЕПИТЬ(A2;" ";B2;" ";ТЕКСТ(C2;"0000"))

Настройки - они для ячейки целиком, а Вам нужно отнастроить только кусок из ячейки. Кстати, когда Вы сцепляете что-то, то результатом является текстовое значение, для которого форматы типа #### неприменимы (вернее, применимы, но не будут работать так, как хотелось бы).
А вместо СЦЕПИТЬ можно использовать амперсанд. Кому как, а мне, например, так удобнее
Код
=ТЕКСТ(A2;"00\ ")&B2&ТЕКСТ(C2;" 0000")

Заодно и первое число сделал минимум 2 знака. Если не нужно, то так
Код
=A2&" "&B2&ТЕКСТ(C2;" 0000")
К сообщению приложен файл: -1-1-1.xlsx(75Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СЦЕПИТЬ(A2;" ";B2;" ";ТЕКСТ(C2;"0000"))

Настройки - они для ячейки целиком, а Вам нужно отнастроить только кусок из ячейки. Кстати, когда Вы сцепляете что-то, то результатом является текстовое значение, для которого форматы типа #### неприменимы (вернее, применимы, но не будут работать так, как хотелось бы).
А вместо СЦЕПИТЬ можно использовать амперсанд. Кому как, а мне, например, так удобнее
Код
=ТЕКСТ(A2;"00\ ")&B2&ТЕКСТ(C2;" 0000")

Заодно и первое число сделал минимум 2 знака. Если не нужно, то так
Код
=A2&" "&B2&ТЕКСТ(C2;" 0000")

Автор - _Boroda_
Дата добавления - 14.07.2016 в 09:16
migo Дата: Четверг, 14.07.2016, 09:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Да, спасибо! То, что нужно.
Так все просто оказалось :specool:

Тогда можно еще вопрос в продолжение этой темы:

Если в ячейках (не формула) одного из столбцов данные с разным количеством цифр (но не более четырех) и таких срок более 20 000

4567
7894
78
7
778
4870

можно ли автоматически дополнять "0" в начале ячейки так, чтоб значение в ней из 4 цифр отображалось

4567
7894
0078
0007
0778
4870


Сообщение отредактировал migo - Четверг, 14.07.2016, 09:24
 
Ответить
СообщениеДа, спасибо! То, что нужно.
Так все просто оказалось :specool:

Тогда можно еще вопрос в продолжение этой темы:

Если в ячейках (не формула) одного из столбцов данные с разным количеством цифр (но не более четырех) и таких срок более 20 000

4567
7894
78
7
778
4870

можно ли автоматически дополнять "0" в начале ячейки так, чтоб значение в ней из 4 цифр отображалось

4567
7894
0078
0007
0778
4870

Автор - migo
Дата добавления - 14.07.2016 в 09:23
_Boroda_ Дата: Четверг, 14.07.2016, 09:25 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормат ячейки
0000
Читайте здесь
http://www.excelworld.ru/publ/hacks/formatting/format_user/63-1-0-141
http://www.excelworld.ru/publ....-1-0-92

Автор - _Boroda_
Дата добавления - 14.07.2016 в 09:25
buchlotnik Дата: Четверг, 14.07.2016, 09:26 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
формат ячеек 0000


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеформат ячеек 0000

Автор - buchlotnik
Дата добавления - 14.07.2016 в 09:26
migo Дата: Четверг, 14.07.2016, 09:34 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо, все получилось!

Как всегда, вы очень помогли =)
 
Ответить
СообщениеСпасибо, все получилось!

Как всегда, вы очень помогли =)

Автор - migo
Дата добавления - 14.07.2016 в 09:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение "0" в формуле (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!