Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как "Убрать" округление (при расчете отпуска) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как "Убрать" округление (при расчете отпуска) (Формулы/Formulas)
Как "Убрать" округление (при расчете отпуска)
мозг Дата: Пятница, 15.07.2016, 15:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Подскажите, пожалуйста, как убрать округление при подсчете дней отпуска. И возможно ли указать строку "период закрыт" после того, как работник отгулял весь отпуск за рабочий период.

Файл прилагается.

Спасибо.
К сообщению приложен файл: 2257057.xlsx(13Kb)
 
Ответить
СообщениеДобрый день.
Подскажите, пожалуйста, как убрать округление при подсчете дней отпуска. И возможно ли указать строку "период закрыт" после того, как работник отгулял весь отпуск за рабочий период.

Файл прилагается.

Спасибо.

Автор - мозг
Дата добавления - 15.07.2016 в 15:06
китин Дата: Пятница, 15.07.2016, 15:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
во монстр получился
Код
=ОКРУГЛ(28*ЦЕЛОЕ(ДОЛЯГОДА(C4;C3))+(28/12)*ЦЕЛОЕ((ДОЛЯГОДА(C4;C3)-ЦЕЛОЕ(ДОЛЯГОДА(C4;C3)))*12);2)

а
указать строку "период закрыт" после того, как работник отгулял

это другой вопрос-другая тема
К сообщению приложен файл: 98741.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениево монстр получился
Код
=ОКРУГЛ(28*ЦЕЛОЕ(ДОЛЯГОДА(C4;C3))+(28/12)*ЦЕЛОЕ((ДОЛЯГОДА(C4;C3)-ЦЕЛОЕ(ДОЛЯГОДА(C4;C3)))*12);2)

а
указать строку "период закрыт" после того, как работник отгулял

это другой вопрос-другая тема

Автор - китин
Дата добавления - 15.07.2016 в 15:54
pabchek Дата: Пятница, 15.07.2016, 16:05 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Вот и мой вариант (если правильно понял)

Добавил
Формула для "период закрыт"
Код
=ЕСЛИ(ОТБР(СУММ(E$14:E14)/28)-СЧЁТЕСЛИ(H$13:H13;"период закрыт")=1;"период закрыт";"")
К сообщению приложен файл: 1599384.xlsx(14Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 15.07.2016, 16:17
 
Ответить
СообщениеЗдравствуйте!
Вот и мой вариант (если правильно понял)

Добавил
Формула для "период закрыт"
Код
=ЕСЛИ(ОТБР(СУММ(E$14:E14)/28)-СЧЁТЕСЛИ(H$13:H13;"период закрыт")=1;"период закрыт";"")

Автор - pabchek
Дата добавления - 15.07.2016 в 16:05
pabchek Дата: Пятница, 15.07.2016, 16:16 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Игорь, во ты накрутил))) попробуй поставить вместо 01/12/13 либо, скажем, 03/12/13, либо 29/11/13. Получим те же 72,33. Я так думаю, если уж отпуск начисляется до 2-го знака после запятой, то и долю нужно брать "прямую". Или я ошибаюсь?


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 15.07.2016, 16:30
 
Ответить
СообщениеИгорь, во ты накрутил))) попробуй поставить вместо 01/12/13 либо, скажем, 03/12/13, либо 29/11/13. Получим те же 72,33. Я так думаю, если уж отпуск начисляется до 2-го знака после запятой, то и долю нужно брать "прямую". Или я ошибаюсь?

Автор - pabchek
Дата добавления - 15.07.2016 в 16:16
китин Дата: Пятница, 15.07.2016, 16:20 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Витя в делах ОК я полный ноль. Посчитал по методике ТСа. ну а ОКРУГЛ можно и убрать. тогда будет 72,333333333 :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеВитя в делах ОК я полный ноль. Посчитал по методике ТСа. ну а ОКРУГЛ можно и убрать. тогда будет 72,333333333 :D

Автор - китин
Дата добавления - 15.07.2016 в 16:20
pabchek Дата: Пятница, 15.07.2016, 16:29 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Кстати...
Код
=ДОЛЯГОДА(C3;C4)*28


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеКстати...
Код
=ДОЛЯГОДА(C3;C4)*28

Автор - pabchek
Дата добавления - 15.07.2016 в 16:29
мозг Дата: Понедельник, 18.07.2016, 08:26 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Урааааааааааааааааааааааааааааааа!!!

Вы меня просто спасли! СПАСИБО огромное-преогромное.
Это то, что нужно!!!!!!
 
Ответить
СообщениеУрааааааааааааааааааааааааааааааа!!!

Вы меня просто спасли! СПАСИБО огромное-преогромное.
Это то, что нужно!!!!!!

Автор - мозг
Дата добавления - 18.07.2016 в 08:26
китин Дата: Понедельник, 18.07.2016, 08:32 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Кстати...

Витя это ты к чему?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Кстати...

Витя это ты к чему?

Автор - китин
Дата добавления - 18.07.2016 в 08:32
pabchek Дата: Понедельник, 18.07.2016, 08:58 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
к чему?

Так вроде считает то, что нужно))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
Сообщение
к чему?

Так вроде считает то, что нужно))

Автор - pabchek
Дата добавления - 18.07.2016 в 08:58
_Boroda_ Дата: Понедельник, 18.07.2016, 10:13 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если дата приема 01.01.2016, текущая дата 30.06.2016, то нескладушки получаются. Должно быть ровно 6 месяцев и, следовательно, 28/12*6=14. Да и високосные года криво считаются.
Предлагаю такую формулу
Код
=(РАЗНДАТ(C3;C4+1;"m")/12+(РАЗНДАТ(C3;C4+1;"md")))*28


А для Период закрыт еще такие варианты
Код
=ЕСЛИ(ОТБР(СУММ(E$13:E14)/28)>ОТБР(СУММ(E$13:E13)/28);"Период закрыт";"")
или
Код
=ТЕКСТ(ОТБР(СУММ(E$13:E14)/28)-ОТБР(СУММ(E$13:E13)/28);"Перио\д закрыт;;")


И Условное форматирование окончания периода
Код
=ОТБР(СУММ(E$13:E14)/28)>ОТБР(СУММ(E$13:E13)/28)
и начала периода
Код
=ОТБР(СУММ(E$13:E13)/28)>ОТБР(СУММ(E12:E$13)/28)-ЕТЕКСТ(E13)
К сообщению приложен файл: 1599384_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА если дата приема 01.01.2016, текущая дата 30.06.2016, то нескладушки получаются. Должно быть ровно 6 месяцев и, следовательно, 28/12*6=14. Да и високосные года криво считаются.
Предлагаю такую формулу
Код
=(РАЗНДАТ(C3;C4+1;"m")/12+(РАЗНДАТ(C3;C4+1;"md")))*28


А для Период закрыт еще такие варианты
Код
=ЕСЛИ(ОТБР(СУММ(E$13:E14)/28)>ОТБР(СУММ(E$13:E13)/28);"Период закрыт";"")
или
Код
=ТЕКСТ(ОТБР(СУММ(E$13:E14)/28)-ОТБР(СУММ(E$13:E13)/28);"Перио\д закрыт;;")


И Условное форматирование окончания периода
Код
=ОТБР(СУММ(E$13:E14)/28)>ОТБР(СУММ(E$13:E13)/28)
и начала периода
Код
=ОТБР(СУММ(E$13:E13)/28)>ОТБР(СУММ(E12:E$13)/28)-ЕТЕКСТ(E13)

Автор - _Boroda_
Дата добавления - 18.07.2016 в 10:13
мозг Дата: Понедельник, 18.07.2016, 19:10 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное!!!
 
Ответить
СообщениеСпасибо огромное!!!

Автор - мозг
Дата добавления - 18.07.2016 в 19:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как "Убрать" округление (при расчете отпуска) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!