Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула отказывается суммировать (-/+) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула отказывается суммировать (-/+) (Формулы/Formulas)
Формула отказывается суммировать (-/+)
Dgerri Дата: Пятница, 22.07.2016, 09:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте гуру!
Нужна помощь, а именно мозгов не хватает как заставить суммировать (-) и (+)
++ суммирует, а вот (-) и (+) отказывается....

Код
=ЕСЛИОШИБКА(ЕСЛИ(СУММЕСЛИМН('09.07.2016'!R2C7:R3989C7;'09.07.2016'!R2C1:R3989C1;RC1;'09.07.2016'!R2C4:R3989C4;R3C);СУММЕСЛИМН('09.07.2016'!R2C7:R3989C7;'09.07.2016'!R2C1:R3989C1;RC1;'09.07.2016'!R2C4:R3989C4;R3C);ПРОСМОТР(;-1/(RC1='09.07.2016'!R2C1:R3989C1)/(R3C='09.07.2016'!R2C4:R3989C4);'09.07.2016'!R2C7:R3989C7));)


Сообщение отредактировал Dgerri - Пятница, 22.07.2016, 10:03
 
Ответить
СообщениеЗдравствуйте гуру!
Нужна помощь, а именно мозгов не хватает как заставить суммировать (-) и (+)
++ суммирует, а вот (-) и (+) отказывается....

Код
=ЕСЛИОШИБКА(ЕСЛИ(СУММЕСЛИМН('09.07.2016'!R2C7:R3989C7;'09.07.2016'!R2C1:R3989C1;RC1;'09.07.2016'!R2C4:R3989C4;R3C);СУММЕСЛИМН('09.07.2016'!R2C7:R3989C7;'09.07.2016'!R2C1:R3989C1;RC1;'09.07.2016'!R2C4:R3989C4;R3C);ПРОСМОТР(;-1/(RC1='09.07.2016'!R2C1:R3989C1)/(R3C='09.07.2016'!R2C4:R3989C4);'09.07.2016'!R2C7:R3989C7));)

Автор - Dgerri
Дата добавления - 22.07.2016 в 09:42
Dgerri Дата: Пятница, 22.07.2016, 09:43 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
данные находятся на одном листе, а суммирование проходит на втором, по наименованию
 
Ответить
Сообщениеданные находятся на одном листе, а суммирование проходит на втором, по наименованию

Автор - Dgerri
Дата добавления - 22.07.2016 в 09:43
китин Дата: Пятница, 22.07.2016, 09:44 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Сообщений: 24

???? файл хде? и формулы в тэги цитата не включают


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Сообщений: 24

???? файл хде? и формулы в тэги цитата не включают

Автор - китин
Дата добавления - 22.07.2016 в 09:44
Dgerri Дата: Пятница, 22.07.2016, 09:47 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
файл огромный, сейчас попробую сократить
 
Ответить
Сообщениефайл огромный, сейчас попробую сократить

Автор - Dgerri
Дата добавления - 22.07.2016 в 09:47
Dgerri Дата: Пятница, 22.07.2016, 09:53 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
сам файл
К сообщению приложен файл: 7190627.xlsx(16Kb)
 
Ответить
Сообщениесам файл

Автор - Dgerri
Дата добавления - 22.07.2016 в 09:53
_Boroda_ Дата: Пятница, 22.07.2016, 10:29 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А Вы чего получить хотите? Введите вручную в столбец Е. И где у Вас дата на листе Сравнение?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА Вы чего получить хотите? Введите вручную в столбец Е. И где у Вас дата на листе Сравнение?

Автор - _Boroda_
Дата добавления - 22.07.2016 в 10:29
Dgerri Дата: Пятница, 22.07.2016, 10:58 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Прошу прощения не тот файл приложила
К сообщению приложен файл: 5832742.xlsx(16Kb)
 
Ответить
СообщениеПрошу прощения не тот файл приложила

Автор - Dgerri
Дата добавления - 22.07.2016 в 10:58
китин Дата: Пятница, 22.07.2016, 11:01 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и что вы хотите во второй строке получить? у вас в А5 пусто. вы и ищете пусто в заполненном столбце :D
К сообщению приложен файл: 9266976.gif(42Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 22.07.2016, 11:02
 
Ответить
Сообщениеи что вы хотите во второй строке получить? у вас в А5 пусто. вы и ищете пусто в заполненном столбце :D

Автор - китин
Дата добавления - 22.07.2016 в 11:01
китин Дата: Пятница, 22.07.2016, 11:06 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Попробуйте лучше вот так
Код
=СУММПРОИЗВ('09.04.2016'!$G$2:$G$3*(A4&B4='09.04.2016'!$A$2:$A$3&'09.04.2016'!$B$2:$B$3))

правда для этого надо все штрихкоды распространить на все строчки
К сообщению приложен файл: 666666666.xlsx(16Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 22.07.2016, 11:07
 
Ответить
СообщениеПопробуйте лучше вот так
Код
=СУММПРОИЗВ('09.04.2016'!$G$2:$G$3*(A4&B4='09.04.2016'!$A$2:$A$3&'09.04.2016'!$B$2:$B$3))

правда для этого надо все штрихкоды распространить на все строчки

Автор - китин
Дата добавления - 22.07.2016 в 11:06
Dgerri Дата: Пятница, 22.07.2016, 13:55 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо за помощь но увы ...
цель стояла убрать "шумы" по артикулярному пересорту, с помощью формул вывести одно число напротив штрих-кода.

Спасибо всем, задача решена.
Решение выглядит так:
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН('09.04.2016'!R2C7:R3989C7;'09.04.2016'!R2C1:R3989C1;RC1;'09.04.2016'!R2C4:R3989C4;R3C);)
 
Ответить
СообщениеСпасибо за помощь но увы ...
цель стояла убрать "шумы" по артикулярному пересорту, с помощью формул вывести одно число напротив штрих-кода.

Спасибо всем, задача решена.
Решение выглядит так:
Код
=ЕСЛИОШИБКА(СУММЕСЛИМН('09.04.2016'!R2C7:R3989C7;'09.04.2016'!R2C1:R3989C1;RC1;'09.04.2016'!R2C4:R3989C4;R3C);)

Автор - Dgerri
Дата добавления - 22.07.2016 в 13:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула отказывается суммировать (-/+) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!