Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение строк столбца строками из др.столбца последовател - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение строк столбца строками из др.столбца последовател (Формулы/Formulas)
Заполнение строк столбца строками из др.столбца последовател
Chertyozhnik Дата: Воскресенье, 24.07.2016, 15:08 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Помогите пожалуйста решить задачу...

Имеется таблица из трех столбцов. Первый столбец - нужно заполнить данными из других столбцов (то есть в первый столбец нужно вставить формулу...)
Смысл следующий. Если во втором столбце есть данные, то мы их подтягиваем в первый столбец - это просто. Но, если во втором столбце данных нет, то мы подтягиваем из третьего столбца их. Только в третьем столбце несколько строк. И нужно сделать так, чтобы, если 1 строка уже подтягивалась ранее, то подтягивать вторую. Если была вторая, то подтягивать третью и так далее. И чтобы это потом еще по кругу начиналось.
К сообщению приложен файл: _Microsoft_Exce.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите пожалуйста решить задачу...

Имеется таблица из трех столбцов. Первый столбец - нужно заполнить данными из других столбцов (то есть в первый столбец нужно вставить формулу...)
Смысл следующий. Если во втором столбце есть данные, то мы их подтягиваем в первый столбец - это просто. Но, если во втором столбце данных нет, то мы подтягиваем из третьего столбца их. Только в третьем столбце несколько строк. И нужно сделать так, чтобы, если 1 строка уже подтягивалась ранее, то подтягивать вторую. Если была вторая, то подтягивать третью и так далее. И чтобы это потом еще по кругу начиналось.

Автор - Chertyozhnik
Дата добавления - 24.07.2016 в 15:08
Pelena Дата: Воскресенье, 24.07.2016, 15:22 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Код
=ЕСЛИ(B2="";ИНДЕКС($E$2:$E$7;ОСТАТ(СУММПРОИЗВ(СЧЁТЕСЛИ($A$1:A1;$E$2:$E$7));6)+1);B2)
К сообщению приложен файл: 8905461.xlsx(9Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(B2="";ИНДЕКС($E$2:$E$7;ОСТАТ(СУММПРОИЗВ(СЧЁТЕСЛИ($A$1:A1;$E$2:$E$7));6)+1);B2)

Автор - Pelena
Дата добавления - 24.07.2016 в 15:22
Serge_007 Дата: Воскресенье, 24.07.2016, 15:31 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13075
Репутация: ±
Замечаний: ±

Excel 2010
Здравствуйте

Что бы не сдвигать табличку:
Код
=ЕСЛИ(ЕПУСТО(B1);ИНДЕКС(E$1:E$6;ОСТАТ(СЧИТАТЬПУСТОТЫ(B$1:B1);СЧЁТЗ(E$1:E$6))+(СЧИТАТЬПУСТОТЫ(B$1:B1)=СЧЁТЗ(E$1:E$6))*6);B1)


Можно сократить ;)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Что бы не сдвигать табличку:
Код
=ЕСЛИ(ЕПУСТО(B1);ИНДЕКС(E$1:E$6;ОСТАТ(СЧИТАТЬПУСТОТЫ(B$1:B1);СЧЁТЗ(E$1:E$6))+(СЧИТАТЬПУСТОТЫ(B$1:B1)=СЧЁТЗ(E$1:E$6))*6);B1)


Можно сократить ;)

Автор - Serge_007
Дата добавления - 24.07.2016 в 15:31
Nic70y Дата: Воскресенье, 24.07.2016, 16:41 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3473
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Еще вариант
Код
=ЕСЛИ(B1<>"";B1;ИНДЕКС(E$1:E1;ОСТАТ(СЧИТАТЬПУСТОТЫ(B$1:B1)-1;СЧЁТЗ(E$1:E$12))+1))
К сообщению приложен файл: 5566680.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(B1<>"";B1;ИНДЕКС(E$1:E1;ОСТАТ(СЧИТАТЬПУСТОТЫ(B$1:B1)-1;СЧЁТЗ(E$1:E$12))+1))

Автор - Nic70y
Дата добавления - 24.07.2016 в 16:41
Chertyozhnik Дата: Воскресенье, 24.07.2016, 17:46 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное ). Все работает )
 
Ответить
СообщениеСпасибо огромное ). Все работает )

Автор - Chertyozhnik
Дата добавления - 24.07.2016 в 17:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение строк столбца строками из др.столбца последовател (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!