Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение наибольшего числа в ячейке с командой ЕСЛИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение наибольшего числа в ячейке с командой ЕСЛИ (Формулы/Formulas)
Нахождение наибольшего числа в ячейке с командой ЕСЛИ
Bordoran Дата: Понедельник, 01.08.2016, 10:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте, прошу помочь мне доделать формулу
в 1-ой ячейки допустим есть "Трубки теплоизоляционные ST 13х89" во второй ячейке
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("1";C3));"1";ЕСЛИ(ЕЧИСЛО(ПОИСК("2";C3));"2";ЕСЛИ(ЕЧИСЛО(ПОИСК("3";C3));"3"
и так до 99
И мне нужно чтобы в 1-ой ячейке нашло и вставило в 2-ую ячейку(где коамнда =ЕСЛИ(ЕЧИСЛО...... наибольшее число т.е. 89. Можно разбить на два столбца ячейки с формулой ЕСЛИ один для 1-9 и второй для 10-99, По возможности можно было бы не разбивать столбцы а чтобы как то искал именно двухзначные цифры, но это не обязательно.

Спасибо, буду ждать ответа.


Сообщение отредактировал Pelena - Понедельник, 01.08.2016, 11:43
 
Ответить
СообщениеЗдравствуйте, прошу помочь мне доделать формулу
в 1-ой ячейки допустим есть "Трубки теплоизоляционные ST 13х89" во второй ячейке
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("1";C3));"1";ЕСЛИ(ЕЧИСЛО(ПОИСК("2";C3));"2";ЕСЛИ(ЕЧИСЛО(ПОИСК("3";C3));"3"
и так до 99
И мне нужно чтобы в 1-ой ячейке нашло и вставило в 2-ую ячейку(где коамнда =ЕСЛИ(ЕЧИСЛО...... наибольшее число т.е. 89. Можно разбить на два столбца ячейки с формулой ЕСЛИ один для 1-9 и второй для 10-99, По возможности можно было бы не разбивать столбцы а чтобы как то искал именно двухзначные цифры, но это не обязательно.

Спасибо, буду ждать ответа.

Автор - Bordoran
Дата добавления - 01.08.2016 в 10:12
buchlotnik Дата: Понедельник, 01.08.2016, 10:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Bordoran, файл будет?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеBordoran, файл будет?

Автор - buchlotnik
Дата добавления - 01.08.2016 в 10:16
Bordoran Дата: Понедельник, 01.08.2016, 10:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
buchlotnik,
К сообщению приложен файл: 3060850.xlsx(17Kb)
 
Ответить
Сообщениеbuchlotnik,

Автор - Bordoran
Дата добавления - 01.08.2016 в 10:25
BobroEJ Дата: Понедельник, 01.08.2016, 10:34 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Bordoran, то есть, если в первой ячейке будет и "труба" и "трубк", то вам нужно, чтобы вставилось "200", а не "100"? Всё так? Если так, то вам достаточно ту же формулу набить в обратном порядке, т.е. начав с больших чисел.


Сообщение отредактировал BobroEJ - Понедельник, 01.08.2016, 10:37
 
Ответить
СообщениеBordoran, то есть, если в первой ячейке будет и "труба" и "трубк", то вам нужно, чтобы вставилось "200", а не "100"? Всё так? Если так, то вам достаточно ту же формулу набить в обратном порядке, т.е. начав с больших чисел.

Автор - BobroEJ
Дата добавления - 01.08.2016 в 10:34
Bordoran Дата: Понедельник, 01.08.2016, 10:48 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
BobroEJ, Хм... спасибо, Сейчас попробую
 
Ответить
СообщениеBobroEJ, Хм... спасибо, Сейчас попробую

Автор - Bordoran
Дата добавления - 01.08.2016 в 10:48
buchlotnik Дата: Понедельник, 01.08.2016, 11:00 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
формула для оборудования:
Код
=ПРОСМОТР(;-ПОИСК($J$3:$J$38;C3);$K$3:$K$38)

не ясно, что вынимать из Водный раствор пропиленгликоля 40%; или Предохранительный клапан для систем водоснабжения VT.1831.N.06
К сообщению приложен файл: 0535683.xlsx(19Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 01.08.2016, 11:03
 
Ответить
Сообщениеформула для оборудования:
Код
=ПРОСМОТР(;-ПОИСК($J$3:$J$38;C3);$K$3:$K$38)

не ясно, что вынимать из Водный раствор пропиленгликоля 40%; или Предохранительный клапан для систем водоснабжения VT.1831.N.06

Автор - buchlotnik
Дата добавления - 01.08.2016 в 11:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение наибольшего числа в ячейке с командой ЕСЛИ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!