Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение значений из таблицы по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение значений из таблицы по нескольким условиям (Формулы/Formulas)
Заполнение значений из таблицы по нескольким условиям
optimist Дата: Среда, 17.08.2016, 09:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Так как в формулах совсем новичок очень нужна помощь.
Есть книга в которой 2 листа: день и месяц.
На листе месяц в первой колонке таблицы (задачи) мы проставляем текстовое значение и далее задаем для него периодичность и важность (из четырех ранее определенных типов) . При этом в зависимости от выбранного значения важности ячейки закрашиваются нужным цветом.
Требуется при вводе даты на листе День заполнить имеющуюся таблицу по категориям важности значениями из Листа месяц на выбранную дату.
К сообщению приложен файл: project.xlsx(13Kb)


Сообщение отредактировал optimist - Среда, 17.08.2016, 09:55
 
Ответить
СообщениеДобрый день.
Так как в формулах совсем новичок очень нужна помощь.
Есть книга в которой 2 листа: день и месяц.
На листе месяц в первой колонке таблицы (задачи) мы проставляем текстовое значение и далее задаем для него периодичность и важность (из четырех ранее определенных типов) . При этом в зависимости от выбранного значения важности ячейки закрашиваются нужным цветом.
Требуется при вводе даты на листе День заполнить имеющуюся таблицу по категориям важности значениями из Листа месяц на выбранную дату.

Автор - optimist
Дата добавления - 17.08.2016 в 09:51
buchlotnik Дата: Среда, 17.08.2016, 10:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
вариант (массивка)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Месяц!$A$1:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Месяц!$B$4:$AF$16;;ПОИСКПОЗ($B$2;Месяц!$B$1:$AF$1;0))=$B$4;СТРОКА(ИНДЕКС(Месяц!$B$4:$AF$16;;ПОИСКПОЗ($B$2;Месяц!$B$1:$AF$1;0)));"");СТРОКА(A1)));"")


поправил формулу
К сообщению приложен файл: 173.xlsx(15Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 17.08.2016, 10:26
 
Ответить
Сообщениевариант (массивка)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Месяц!$A$1:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Месяц!$B$4:$AF$16;;ПОИСКПОЗ($B$2;Месяц!$B$1:$AF$1;0))=$B$4;СТРОКА(ИНДЕКС(Месяц!$B$4:$AF$16;;ПОИСКПОЗ($B$2;Месяц!$B$1:$AF$1;0)));"");СТРОКА(A1)));"")


поправил формулу

Автор - buchlotnik
Дата добавления - 17.08.2016 в 10:12
optimist Дата: Среда, 17.08.2016, 10:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
вариант (массивка)


ммм, как-то некорректно отрабатывает.
Например: я вбил на листе месяц дату 1.8 - должен был получить значение "Пример 2" в секторе НН, а получаем "Пример 5" в секторе "НН"
При дате 28.8 должен был получить "Пример 6" в секторе ВС, а по факту "Пример 9" в секторе ВС
 
Ответить
Сообщение
вариант (массивка)


ммм, как-то некорректно отрабатывает.
Например: я вбил на листе месяц дату 1.8 - должен был получить значение "Пример 2" в секторе НН, а получаем "Пример 5" в секторе "НН"
При дате 28.8 должен был получить "Пример 6" в секторе ВС, а по факту "Пример 9" в секторе ВС

Автор - optimist
Дата добавления - 17.08.2016 в 10:23
Pelena Дата: Среда, 17.08.2016, 10:25 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9873
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Похожий вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Месяц!$A$4:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Месяц!$B$4:$AF$16;;ПОИСКПОЗ($B$2;Месяц!$B$1:$AF$1;0))=$B$4;СТРОКА(Месяц!$A$4:$A$16)-3;"");СТРОКА(A1)));"")
К сообщению приложен файл: 5438412.xlsx(15Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПохожий вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Месяц!$A$4:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Месяц!$B$4:$AF$16;;ПОИСКПОЗ($B$2;Месяц!$B$1:$AF$1;0))=$B$4;СТРОКА(Месяц!$A$4:$A$16)-3;"");СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 17.08.2016 в 10:25
buchlotnik Дата: Среда, 17.08.2016, 10:28 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
optimist, исправил (см. пост выше)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеoptimist, исправил (см. пост выше)

Автор - buchlotnik
Дата добавления - 17.08.2016 в 10:28
optimist Дата: Среда, 17.08.2016, 10:32 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
optimist, исправил (см. пост выше)


Ребята вы гуру Exel !!! Огромное Спасибо.
 
Ответить
Сообщение
optimist, исправил (см. пост выше)


Ребята вы гуру Exel !!! Огромное Спасибо.

Автор - optimist
Дата добавления - 17.08.2016 в 10:32
AlexM Дата: Среда, 17.08.2016, 10:42 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Формула для С6 может быть такая
Код
=ЕСЛИОШИБКА(ИНДЕКС(Месяц!$A$1:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(ГПР($B$2;Месяц!$B$1:$AF$16;СТРОКА(A$4:A$16))=$B$4;СТРОКА(A$4:A$16));СТРОКА(A1)));"")
Так же массивная


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 17.08.2016, 10:52
 
Ответить
СообщениеФормула для С6 может быть такая
Код
=ЕСЛИОШИБКА(ИНДЕКС(Месяц!$A$1:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(ГПР($B$2;Месяц!$B$1:$AF$16;СТРОКА(A$4:A$16))=$B$4;СТРОКА(A$4:A$16));СТРОКА(A1)));"")
Так же массивная

Автор - AlexM
Дата добавления - 17.08.2016 в 10:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение значений из таблицы по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!