Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разнесение значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разнесение значений (Формулы/Formulas)
Разнесение значений
Sega2016 Дата: Четверг, 18.08.2016, 09:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Форумчане, добрый день!
Прошу помочь вот с каким вопросом:
Есть табличка с данными - "Данные поставщика", которая заполняется вручную. Есть табличка "Данные заказчика" - которая должна рассчитывается автоматически. Но, при расчете данной таблички есть условия: 1. По показателям 1 и 2 не должно по поставщикам не должно быть данных менее 2.8. 2. В то же время, тотал по данной табличке должен быть равен желтой табличке с названием "Должно быть"по обоим показателям и разницы быть не должно.
Более наглядно в файле во вложении.
Может кто помочь с такой задачкой? Буду очень благодарен.
К сообщению приложен файл: _-.xlsx(11Kb)


Сергей
 
Ответить
СообщениеФорумчане, добрый день!
Прошу помочь вот с каким вопросом:
Есть табличка с данными - "Данные поставщика", которая заполняется вручную. Есть табличка "Данные заказчика" - которая должна рассчитывается автоматически. Но, при расчете данной таблички есть условия: 1. По показателям 1 и 2 не должно по поставщикам не должно быть данных менее 2.8. 2. В то же время, тотал по данной табличке должен быть равен желтой табличке с названием "Должно быть"по обоим показателям и разницы быть не должно.
Более наглядно в файле во вложении.
Может кто помочь с такой задачкой? Буду очень благодарен.

Автор - Sega2016
Дата добавления - 18.08.2016 в 09:11
Pelena Дата: Четверг, 18.08.2016, 09:48 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11607
Репутация: 2573 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Можно попробовать использовать округление ОКРУГЛ().
Или более подробно распишите алгоритм "разнесения значений"
К сообщению приложен файл: 8659427.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно попробовать использовать округление ОКРУГЛ().
Или более подробно распишите алгоритм "разнесения значений"

Автор - Pelena
Дата добавления - 18.08.2016 в 09:48
Sega2016 Дата: Четверг, 18.08.2016, 09:55 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Pelena, спасибо за совет, но не могу менять в таблице "Данные заказчика" итог на Вашу формулу, там должна оставаться формула
Код
=СУММПРОИЗВ(G4:G9;F4:F9)/F10.


Сергей

Сообщение отредактировал Manyasha - Четверг, 18.08.2016, 10:16
 
Ответить
СообщениеPelena, спасибо за совет, но не могу менять в таблице "Данные заказчика" итог на Вашу формулу, там должна оставаться формула
Код
=СУММПРОИЗВ(G4:G9;F4:F9)/F10.

Автор - Sega2016
Дата добавления - 18.08.2016 в 09:55
Sega2016 Дата: Четверг, 18.08.2016, 10:20 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Или более подробно распишите алгоритм "разнесения значений"

Pelena, условия таковы: в таблице "Данные поставщика" есть поставщики с Показателями менее 2.8. В таблице "Данные заказчика" показатели по этим поставщикам должны быть не менее 2.8. В то же время Итог по таблице "Данные заказчика" должен быть равен желтой таблице "Должно быть". Используя текущие формулы не получается добиться такого.
По логике, для того, чтобы Итог сошелся, необходимо у "богатых" поставщиков снять необходимое количество для "бедных"(те, у кого изначально менее 2.8), при таком раскладе Итог сойдется.


Сергей
 
Ответить
Сообщение
Или более подробно распишите алгоритм "разнесения значений"

Pelena, условия таковы: в таблице "Данные поставщика" есть поставщики с Показателями менее 2.8. В таблице "Данные заказчика" показатели по этим поставщикам должны быть не менее 2.8. В то же время Итог по таблице "Данные заказчика" должен быть равен желтой таблице "Должно быть". Используя текущие формулы не получается добиться такого.
По логике, для того, чтобы Итог сошелся, необходимо у "богатых" поставщиков снять необходимое количество для "бедных"(те, у кого изначально менее 2.8), при таком раскладе Итог сойдется.

Автор - Sega2016
Дата добавления - 18.08.2016 в 10:20
Sega2016 Дата: Четверг, 18.08.2016, 12:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Других вариантов больше нет?


Сергей
 
Ответить
СообщениеДругих вариантов больше нет?

Автор - Sega2016
Дата добавления - 18.08.2016 в 12:01
Pelena Дата: Четверг, 18.08.2016, 15:38 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11607
Репутация: 2573 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Вариант с доп. столбцами
К сообщению приложен файл: -1-.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант с доп. столбцами

Автор - Pelena
Дата добавления - 18.08.2016 в 15:38
Sega2016 Дата: Четверг, 18.08.2016, 15:57 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Pelena, Большое спасибо! То что надо!


Сергей
 
Ответить
СообщениеPelena, Большое спасибо! То что надо!

Автор - Sega2016
Дата добавления - 18.08.2016 в 15:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разнесение значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!