Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества дат, при условии что даты повторяются - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества дат, при условии что даты повторяются (Формулы/Formulas)
Подсчет количества дат, при условии что даты повторяются
FDS1989 Дата: Воскресенье, 21.08.2016, 12:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Дорогие форумчане, подскажите, можно ли при помощи формулы, не прибегая к макросам решить следующего рода задачу. На листе "Учет отработанного времени" находятся исходные данные, в которых указаны даты, когда сотрудник работал. Возможно ли на листе "Отработано дней" обобщить информацию о количестве отработанных дней? В один день, сотрудник может выполнять разные работы, поэтому даты дублируются и возникает необходимость подсчета отработанных дней по дате.
К сообщению приложен файл: 1111.rar(8Kb)
 
Ответить
СообщениеДобрый день. Дорогие форумчане, подскажите, можно ли при помощи формулы, не прибегая к макросам решить следующего рода задачу. На листе "Учет отработанного времени" находятся исходные данные, в которых указаны даты, когда сотрудник работал. Возможно ли на листе "Отработано дней" обобщить информацию о количестве отработанных дней? В один день, сотрудник может выполнять разные работы, поэтому даты дублируются и возникает необходимость подсчета отработанных дней по дате.

Автор - FDS1989
Дата добавления - 21.08.2016 в 12:01
Pelena Дата: Воскресенье, 21.08.2016, 15:48 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Например, можно формулой массива
Код
=СУММ(--(ЧАСТОТА(ЕСЛИ('Отработано дней'!A3='Учет отработанного времени'!$C$3:$C$29;'Учет отработанного времени'!$A$3:$A$29);ЕСЛИ(A3='Учет отработанного времени'!$C$3:$C$29;'Учет отработанного времени'!$A$3:$A$29))>0))
К сообщению приложен файл: 1111.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Например, можно формулой массива
Код
=СУММ(--(ЧАСТОТА(ЕСЛИ('Отработано дней'!A3='Учет отработанного времени'!$C$3:$C$29;'Учет отработанного времени'!$A$3:$A$29);ЕСЛИ(A3='Учет отработанного времени'!$C$3:$C$29;'Учет отработанного времени'!$A$3:$A$29))>0))

Автор - Pelena
Дата добавления - 21.08.2016 в 15:48
Karataev Дата: Воскресенье, 21.08.2016, 18:03 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 643
Репутация: 226 ±
Замечаний: 0% ±

Excel
Вариант без формулы массива, но с допстолбцом.
Допстолбец на листе "Учет отработанного времени", в столбце "D":
Код
=ЕСЛИ(СЧЁТЕСЛИМН($A$3:A3;A3;$C$3:C3;C3)=1;A3)

Формула для листа "Отработано дней":
Код
=СЧЁТЕСЛИМН('Учет отработанного времени'!C:C;A3;'Учет отработанного времени'!D:D;"<>ЛОЖЬ")

PS. На листе "Учет отработанного времени" в столбце "A" в строках 9, 11 неправильно записана дата.
К сообщению приложен файл: 8979421.xlsx(11Kb)


 
Ответить
СообщениеВариант без формулы массива, но с допстолбцом.
Допстолбец на листе "Учет отработанного времени", в столбце "D":
Код
=ЕСЛИ(СЧЁТЕСЛИМН($A$3:A3;A3;$C$3:C3;C3)=1;A3)

Формула для листа "Отработано дней":
Код
=СЧЁТЕСЛИМН('Учет отработанного времени'!C:C;A3;'Учет отработанного времени'!D:D;"<>ЛОЖЬ")

PS. На листе "Учет отработанного времени" в столбце "A" в строках 9, 11 неправильно записана дата.

Автор - Karataev
Дата добавления - 21.08.2016 в 18:03
FDS1989 Дата: Понедельник, 22.08.2016, 18:52 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большое, использовал вариант с доп столбцом
 
Ответить
СообщениеСпасибо большое, использовал вариант с доп столбцом

Автор - FDS1989
Дата добавления - 22.08.2016 в 18:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества дат, при условии что даты повторяются (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!