Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Совместить несколько формул в одной формуле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совместить несколько формул в одной формуле (Формулы/Formulas)
Совместить несколько формул в одной формуле
sgkorolew Дата: Среда, 24.08.2016, 16:31 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Во вложении пример задачи.
Исходные данные содержат:
Код контрагента,
Номер договора,
Дата договора,
Сумма1,
Сумма2,
Сумма3.
Нужно сделать следующее:
1. Найти договор с наиболее поздней датой заключения по каждому контрагенту,
2. Произвести сравнении сумм (Сумма1 и Сумма2+Сумма3) по договорам с наиболее поздними датами заключения.
! Весь расчет нужно сделать одной формулой.
Подскажите, пож-та, как сделать.
К сообщению приложен файл: 1107686.xlsx(12Kb)
 
Ответить
СообщениеДобрый вечер!
Во вложении пример задачи.
Исходные данные содержат:
Код контрагента,
Номер договора,
Дата договора,
Сумма1,
Сумма2,
Сумма3.
Нужно сделать следующее:
1. Найти договор с наиболее поздней датой заключения по каждому контрагенту,
2. Произвести сравнении сумм (Сумма1 и Сумма2+Сумма3) по договорам с наиболее поздними датами заключения.
! Весь расчет нужно сделать одной формулой.
Подскажите, пож-та, как сделать.

Автор - sgkorolew
Дата добавления - 24.08.2016 в 16:31
sgkorolew Дата: Среда, 24.08.2016, 17:07 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вроде бы сам решил:
Код
=ЕСЛИ(МАКС(ЕСЛИ(B2:B6=B4;D2:D6))=D4;ЕСЛИ(E4>F4+G4;"текст1";"текст2");"")

Сейчас думаю над альтернативой части формулы:
Код
МАКС(ЕСЛИ(B2:B6=B4;D2:D6))=D4


Сообщение отредактировал sgkorolew - Среда, 24.08.2016, 17:12
 
Ответить
СообщениеВроде бы сам решил:
Код
=ЕСЛИ(МАКС(ЕСЛИ(B2:B6=B4;D2:D6))=D4;ЕСЛИ(E4>F4+G4;"текст1";"текст2");"")

Сейчас думаю над альтернативой части формулы:
Код
МАКС(ЕСЛИ(B2:B6=B4;D2:D6))=D4

Автор - sgkorolew
Дата добавления - 24.08.2016 в 17:07
krosav4ig Дата: Среда, 24.08.2016, 22:38 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1465
Репутация: 596 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте
Код
=ЕСЛИ(СЧЁТЕСЛИМН(B4:B14;B4;D4:D14;">"&D4);"";"Сумма1 "&ТЕКСТ(E4-F4-G4;"больше \че\м;не больше \че\м;равна")&" Сумма2+Сумма3")


(_)Õvõ(_)
 
Ответить
СообщениеЗдравствуйте
Код
=ЕСЛИ(СЧЁТЕСЛИМН(B4:B14;B4;D4:D14;">"&D4);"";"Сумма1 "&ТЕКСТ(E4-F4-G4;"больше \че\м;не больше \че\м;равна")&" Сумма2+Сумма3")

Автор - krosav4ig
Дата добавления - 24.08.2016 в 22:38
buchlotnik Дата: Среда, 24.08.2016, 22:54 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2628
Репутация: 751 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
такая вот массивка родилась:
Код
=ЕСЛИ(D4=МАКС($D$4:$D$14*($B$4:$B$14=B4));"Сумма1 "&ЕСЛИ(E4>F4+G4;"";"не ")&"больше чем Сумма2+Сумма3";"")
К сообщению приложен файл: 4498361.xlsx(11Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетакая вот массивка родилась:
Код
=ЕСЛИ(D4=МАКС($D$4:$D$14*($B$4:$B$14=B4));"Сумма1 "&ЕСЛИ(E4>F4+G4;"";"не ")&"больше чем Сумма2+Сумма3";"")

Автор - buchlotnik
Дата добавления - 24.08.2016 в 22:54
sgkorolew Дата: Четверг, 25.08.2016, 08:44 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 87
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - sgkorolew
Дата добавления - 25.08.2016 в 08:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совместить несколько формул в одной формуле (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!