Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/избегание повторов в списке по критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » избегание повторов в списке по критерию (Формулы/Formulas)
избегание повторов в списке по критерию
zaak88 Дата: Среда, 24.08.2016, 17:49 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Добрый день!

Коллеги, при использовании функции НАИМЕНЬШИЙ, необходимо расставить месяцы по значениям. Но есть месяцы с совпадающими значениями. Необходимо вывести после первого месяца, второй, третий и так пока не кончится повтор, а не один и тот же. Цветом выделил проблемные ячейки. Спасибо!
К сообщению приложен файл: 5741929.xlsx(9Kb)
 
Ответить
СообщениеДобрый день!

Коллеги, при использовании функции НАИМЕНЬШИЙ, необходимо расставить месяцы по значениям. Но есть месяцы с совпадающими значениями. Необходимо вывести после первого месяца, второй, третий и так пока не кончится повтор, а не один и тот же. Цветом выделил проблемные ячейки. Спасибо!

Автор - zaak88
Дата добавления - 24.08.2016 в 17:49
Gustav Дата: Среда, 24.08.2016, 18:33 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1211
Репутация: 484 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Нужно поле второго ключа, считающего повторы. Естественно, этот вариант - с допстолбцами. По крайней мере, я по-другому не вижу.
К сообщению приложен файл: 5741929_03.xlsx(10Kb)


Мой tip box - яд 41001663842605
 
Ответить
СообщениеНужно поле второго ключа, считающего повторы. Естественно, этот вариант - с допстолбцами. По крайней мере, я по-другому не вижу.

Автор - Gustav
Дата добавления - 24.08.2016 в 18:33
buchlotnik Дата: Среда, 24.08.2016, 18:33 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
такая массивка получилась:
Код
=ИНДЕКС($A$1:$A$14;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$14=E3;СТРОКА($B$3:$B$14);"");СЧЁТЕСЛИ($E$2:E3;E3)))
К сообщению приложен файл: 6248792.xlsx(9Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетакая массивка получилась:
Код
=ИНДЕКС($A$1:$A$14;НАИМЕНЬШИЙ(ЕСЛИ($B$3:$B$14=E3;СТРОКА($B$3:$B$14);"");СЧЁТЕСЛИ($E$2:E3;E3)))

Автор - buchlotnik
Дата добавления - 24.08.2016 в 18:33
zaak88 Дата: Среда, 24.08.2016, 18:42 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Gustav, buchlotnik, спасибо за помощь! второй вариант очень понравился!
 
Ответить
СообщениеGustav, buchlotnik, спасибо за помощь! второй вариант очень понравился!

Автор - zaak88
Дата добавления - 24.08.2016 в 18:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » избегание повторов в списке по критерию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!