Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма вниз по столбцу до первой пустой ячейки. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма вниз по столбцу до первой пустой ячейки. (Формулы/Formulas)
Сумма вниз по столбцу до первой пустой ячейки.
IlIEFF Дата: Среда, 24.08.2016, 22:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет!

Ребята, подскажите, есть ли формула, позволяющая суммировать все значения ниже по столбцу до первой пустой ячейки, не обращая внимание на значения, которые идут после пустой ?
К сообщению приложен файл: 9560298.xlsx(9Kb)


И принцип в принципе не принцип вовсе, когда поставил на зеро, а выпадает восемь Оо.

Сообщение отредактировал IlIEFF - Среда, 24.08.2016, 23:07
 
Ответить
СообщениеВсем привет!

Ребята, подскажите, есть ли формула, позволяющая суммировать все значения ниже по столбцу до первой пустой ячейки, не обращая внимание на значения, которые идут после пустой ?

Автор - IlIEFF
Дата добавления - 24.08.2016 в 22:51
buchlotnik Дата: Среда, 24.08.2016, 22:56 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
файл?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениефайл?

Автор - buchlotnik
Дата добавления - 24.08.2016 в 22:56
IlIEFF Дата: Среда, 24.08.2016, 23:05 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
файл?

Прикрепил к первому сообщению


И принцип в принципе не принцип вовсе, когда поставил на зеро, а выпадает восемь Оо.
 
Ответить
Сообщение
файл?

Прикрепил к первому сообщению

Автор - IlIEFF
Дата добавления - 24.08.2016 в 23:05
buchlotnik Дата: Среда, 24.08.2016, 23:09 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
вариант намонстрячил (массивка):
Код
=ЕСЛИ(ЕПУСТО(A1);СУММ(A2:$A$21*(СТРОКА(A2:$A$21)<=МИН(ЕСЛИ(ЕОШ(1/A2:$A$21);СТРОКА(A2:$A$21);""))));"")
К сообщению приложен файл: 7327651.xlsx(9Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениевариант намонстрячил (массивка):
Код
=ЕСЛИ(ЕПУСТО(A1);СУММ(A2:$A$21*(СТРОКА(A2:$A$21)<=МИН(ЕСЛИ(ЕОШ(1/A2:$A$21);СТРОКА(A2:$A$21);""))));"")

Автор - buchlotnik
Дата добавления - 24.08.2016 в 23:09
IlIEFF Дата: Среда, 24.08.2016, 23:50 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
вариант намонстрячил

В какой-то степени выход, большое спасибо, но если пустая ячейка содержит формулу, скажем ="" то Ваша формула даёт ошибку, это можно как-то обойти ?


И принцип в принципе не принцип вовсе, когда поставил на зеро, а выпадает восемь Оо.

Сообщение отредактировал IlIEFF - Среда, 24.08.2016, 23:51
 
Ответить
Сообщение
вариант намонстрячил

В какой-то степени выход, большое спасибо, но если пустая ячейка содержит формулу, скажем ="" то Ваша формула даёт ошибку, это можно как-то обойти ?

Автор - IlIEFF
Дата добавления - 24.08.2016 в 23:50
buchlotnik Дата: Четверг, 25.08.2016, 00:03 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
но если
а я для чего просил
Цитата
файл?
вам бы почитать rules
Цитата
можно как-то обойти ?
ясен-красен можно
Код
=ЕСЛИ(ЕПУСТО(A1);СУММ(ЕСЛИ(ЕЧИСЛО(A2:$A$21);A2:$A$21;0)*(СТРОКА(A2:$A$21)<=МИН(ЕСЛИ(ЕОШ(1/A2:$A$21);СТРОКА(A2:$A$21);""))));"")
К сообщению приложен файл: 7327651-1-.xlsx(9Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
но если
а я для чего просил
Цитата
файл?
вам бы почитать rules
Цитата
можно как-то обойти ?
ясен-красен можно
Код
=ЕСЛИ(ЕПУСТО(A1);СУММ(ЕСЛИ(ЕЧИСЛО(A2:$A$21);A2:$A$21;0)*(СТРОКА(A2:$A$21)<=МИН(ЕСЛИ(ЕОШ(1/A2:$A$21);СТРОКА(A2:$A$21);""))));"")

Автор - buchlotnik
Дата добавления - 25.08.2016 в 00:03
IlIEFF Дата: Четверг, 25.08.2016, 00:14 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
а я для чего просил

Понял, виноват =)

Всё работает, большое спасибо Вам за помощь )


И принцип в принципе не принцип вовсе, когда поставил на зеро, а выпадает восемь Оо.
 
Ответить
Сообщение
а я для чего просил

Понял, виноват =)

Всё работает, большое спасибо Вам за помощь )

Автор - IlIEFF
Дата добавления - 25.08.2016 в 00:14
AlexM Дата: Четверг, 25.08.2016, 01:05 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Формула массива
Код
=СУММ(A2:ИНДЕКС(A2:A99;ПОИСКПОЗ(1;Ч(A2:A99="");)))
К сообщению приложен файл: 9560298_01.xls(27Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула массива
Код
=СУММ(A2:ИНДЕКС(A2:A99;ПОИСКПОЗ(1;Ч(A2:A99="");)))

Автор - AlexM
Дата добавления - 25.08.2016 в 01:05
Nic70y Дата: Четверг, 25.08.2016, 19:27 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3487
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(A1="";СУММ(A2:A$20000)-СУММ(B2:$B$20000);"")
К сообщению приложен файл: 9298862.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(A1="";СУММ(A2:A$20000)-СУММ(B2:$B$20000);"")

Автор - Nic70y
Дата добавления - 25.08.2016 в 19:27
AlexM Дата: Четверг, 25.08.2016, 20:42 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

или так
Код
=ЕСЛИ(A1;"";СУММПРОИЗВ(A2:B20000*{1;-1}))


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 25.08.2016, 22:58
 
Ответить
Сообщениеили так
Код
=ЕСЛИ(A1;"";СУММПРОИЗВ(A2:B20000*{1;-1}))

Автор - AlexM
Дата добавления - 25.08.2016 в 20:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма вниз по столбцу до первой пустой ячейки. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!